TapQuoteAPI: TapQuoteAPI介绍

TapQuoteAPI
易盛行情API V9.3.0.0
  • API介绍
  • 函数接口说明
  • 数据类型说明
TapQuoteAPI介绍

TapQuoteAPI

TapQuoteAPI 是易盛公司提供给开发者的启明星交易系统的行情接口。API基于C++实现，主要功能包括：合约的查询、行情的订阅与退订等。

API由调用接口类和回调接口类两部分组成，类名分别为ITapQuoteAPI和ITapQuoteAPINotify，ITapQuoteAPI包含了用户可以使用的函数，ITapQuoteAPINotify为提供给用户的回调接口，调用API提供的函数后相应结果通过回调的形参返回。回调类中所有函数均为虚函数，API内部没有默认的实现，用户需要且必须通过继承实现自己需要的功能。

注意：API的回调接口为纯虚函数，实现时需要继承实现所有接口。

生成于 2016年 二月 3日 星期三 11:30:03 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: 函数接口说明

  • 函数接口说明
  • 数据类型说明
函数接口说明
  • 1.接口的创建和销毁
  • 2.日志设置
  • 3.使用API登录服务器
  • 4.断开连接
  • 5.获取品种信息
  • 6.获取合约信息
  • 7.行情信息的订阅与退订


TapQuoteAPI: 1.接口的创建和销毁

函数
1.接口的创建和销毁

函数

TAP_DLLEXPORT ITapQuoteAPI
*TAP_CDECL 		CreateTapQuoteAPI (const TapAPIApplicationInfo *appInfo, TAPIINT32 &iResult)
TAP_DLLEXPORT void TAP_CDECL FreeTapQuoteAPI (ITapQuoteAPI *apiObj)
TAP_DLLEXPORT const TAPICHAR
*TAP_CDECL 		GetTapQuoteAPIVersion ()

详细描述

函数说明

TAP_DLLEXPORT ITapQuoteAPI* TAP_CDECL CreateTapQuoteAPI | ( | const TapAPIApplicationInfo * | appInfo,
 |  | TAPIINT32 & | iResult
 | ) |  |

创建TapQuoteAPI的接口对象。

创建整个行情API的接口

参数
[in] | appInfo | 应用程序相关信息。
[in] | iResult | 创建接口的错误码。
返回值
NULL | 创建失败。
!NULL | 实现了ITapQuoteAPI接口的对象指针。
TAP_DLLEXPORT void TAP_CDECL FreeTapQuoteAPI ( ITapQuoteAPI * apiObj )

销毁通过CreateTapQuoteAPI函数创建的ITapQuoteAPI对象。

参数
[in] apiObj ITapQuoteAPI对象指针。
TAP_DLLEXPORT const TAPICHAR* TAP_CDECL GetTapQuoteAPIVersion ( )

获取TapQuoteAPI的版本信息


TapQuoteAPI: 2.日志设置

函数
2.日志设置

函数

TAP_DLLEXPORT TAPIINT32 TAP_CDECL | SetTapQuoteAPIDataPath (const TAPICHAR *path)
TAP_DLLEXPORT TAPIINT32 TAP_CDECL | SetTapQuoteAPILogLevel (TAPILOGLEVEL level)

详细描述

函数说明

TAP_DLLEXPORT TAPIINT32 TAP_CDECL SetTapQuoteAPIDataPath ( const TAPICHAR * path )

设置API自身保存数据目录

调用函数的同时会在path描述的目录下打开以年月日（格式TapQuoteAPI[YYYYMMDD].log)命名的文件，
没有此文件的情况下会试图创建此文件。
文件中保存的数据为API接收到的重要数据和API的使用和错误日志。

参数
[in] path 目录。必须可用，目录符号Window下为”\”或者”/”, Linux下为”/”。
返回值
0 | 成功
非0 | 错误码
操作类型
同步操作
TAP_DLLEXPORT TAPIINT32 TAP_CDECL SetTapQuoteAPILogLevel ( TAPILOGLEVEL level )

设置API的日志级别

设定日志的输出级别，只有当实际日志级别与此处设定的级别相同或更高时，才会将日志写入SetTapQuoteAPIDataPath()函数打开的日志文件。

参数
[in] level 日志级别：
APILOGLEVEL_NONE ：不记录日志
APILOGLEVEL_ERROR ：记录Error日志
APILOGLEVEL_WARNING ：记录Error和Warning日志
APILOGLEVEL_DEBUG ：记录Error、Warning和Debug日志
返回值
0 | 设定成功
非0 | 错误码
操作类型
同步操作


TapQuoteAPI: 3.使用API登录服务器

函数
3.使用API登录服务器

函数

virtual void TAP_CDECL | ITapQuoteAPINotify::OnRspLogin (TAPIINT32 errorCode, const TapAPIQuotLoginRspInfo *info)=0
virtual void TAP_CDECL | ITapQuoteAPINotify::OnAPIReady ()=0
virtual TAPIINT32 TAP_CDECL | ITapQuoteAPI::SetAPINotify (ITapQuoteAPINotify *apiNotify)=0
virtual TAPIINT32 TAP_CDECL | ITapQuoteAPI::SetHostAddress (const TAPICHAR *IP, TAPIUINT16 port)=0
virtual TAPIINT32 TAP_CDECL | ITapQuoteAPI::Login (const TapAPIQuoteLoginAuth *loginAuth)=0

详细描述

函数说明

virtual TAPIINT32 TAP_CDECL ITapQuoteAPI::Login ( const TapAPIQuoteLoginAuth * loginAuth )
pure virtual

发起登录请求。API将先连接服务，建立链路，发起登录认证。

在使用函数函数前用户需要完成服务器的设置SetHostAddress()，并且创建TapAPIQuoteLoginAuth类型的用户信息， 并且需要设置好回调接口。
连接建立后的用户验证回馈信息通过回调OnLogin()返回给用户。
登录成功后API会自动进行API的初始化，API向服务器请求基础数据，查询完以后会通过回调OnAPIReady() 指示用户API初始化完成，可以进行后续的操作了。

参数
[in] loginAuth 登录验证信息结构指针。包含登录需要的验证信息。
返回值
0 | 登录成功，API开始准备后台数据
非0 | 错误码
注意
登录成功与否要根据OnLogin回调判断。
操作类型
异步操作
警告
Login()函数调用成功只是代表于服务器建立了链路连接，只有回调OnLogin()的返回能指示用户是否成功登录了。
virtual void TAP_CDECL ITapQuoteAPINotify::OnAPIReady ( )
pure virtual

通知用户API准备就绪。

只有用户回调收到此就绪通知时才能进行后续的各种行情数据查询操作。
此回调函数是API能否正常工作的标志。

注意
就绪后才可以进行后续正常操作
virtual void TAP_CDECL ITapQuoteAPINotify::OnRspLogin | ( | TAPIINT32 | errorCode,
 |  | const TapAPIQuotLoginRspInfo * | info
 | ) |  |
pure virtual

系统登录过程回调。

此函数为Login()登录函数的回调，调用Login()成功后建立了链路连接，然后API将向服务器发送登录认证信息， 登录期间的数据发送情况和登录的回馈信息传递到此回调函数中。

参数
[in] | errorCode | 返回错误码,0表示成功。
[in] | info | 登陆应答信息，如果errorCode!=0，则info=NULL。
注意
该回调返回成功，说明用户登录成功。但是不代表API准备完毕。需要等到OnAPIReady才能进行查询与订阅请求。
virtual TAPIINT32 TAP_CDECL ITapQuoteAPI::SetAPINotify ( ITapQuoteAPINotify * apiNotify )
pure virtual

设置API的回调接口对象。

系统对API的通知将通过设置的回调对象通知给使用者。 ITapQuoteAPINofify是API的回调接口，用户需要继承实现此接口类对象来完成用户需要的功能。 如果用户没有设置回调接口，则API不会向用户返回任何有用的信息。
ITapQuoteAPINotify类的详细内容请查看TapQuoteAPI.h 文件。

参数
[in] apiNotify 实现了ITapQuoteAPINotify接口的对象指针。
操作类型
同步操作
virtual TAPIINT32 TAP_CDECL ITapQuoteAPI::SetHostAddress | ( | const TAPICHAR * | IP,
 |  | TAPIUINT16 | port
 | ) |  |
pure virtual

设置服务器的IP地址和端口。等到调用Login时真正发起连接。

参数
[in] | IP | IP地址
[in] | port | 端口号
操作类型
同步操作


TapQuoteAPI: 4.断开连接

函数
4.断开连接

函数

virtual void TAP_CDECL | ITapQuoteAPINotify::OnDisconnect (TAPIINT32 reasonCode)=0
virtual TAPIINT32 TAP_CDECL | ITapQuoteAPI::Disconnect ()=0

详细描述

函数说明

virtual TAPIINT32 TAP_CDECL ITapQuoteAPI::Disconnect ( )
pure virtual

断开和服务器的链路连接。

调用函数后API将登出并断开与服务器的连接。

操作类型
异步操作
virtual void TAP_CDECL ITapQuoteAPINotify::OnDisconnect ( TAPIINT32 reasonCode )
pure virtual

API和服务失去连接的回调

在API使用过程中主动或者被动与服务器服务失去连接后都会触发此回调通知用户与服务器的连接已经断开。

参数
[in] reasonCode 断开原因代码。具体原因请参见错误码列表


TapQuoteAPI: 5.获取品种信息

函数
5.获取品种信息

函数

virtual void TAP_CDECL | ITapQuoteAPINotify::OnRspQryCommodity (TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteCommodityInfo *info)=0
virtual TAPIINT32 TAP_CDECL | ITapQuoteAPI::QryCommodity (TAPIUINT32 *sessionID)=0

详细描述

函数说明

virtual void TAP_CDECL ITapQuoteAPINotify::OnRspQryCommodity | ( | TAPIUINT32 | sessionID,
 |  | TAPIINT32 | errorCode,
 |  | TAPIYNFLAG | isLast,
 |  | const TapAPIQuoteCommodityInfo * | info
 | ) |  |
pure virtual

返回所有品种信息。

此回调接口用于向用户返回得到的所有品种信息。

参数
[in] | sessionID | 请求的会话ID
[in] | errorCode | 错误码，当errorCode!=0时,info为NULL；
[in] | isLast | 标示是否是最后一批数据；
[in] | info | 返回的信息数组的起始指针。
注意
不要修改和删除info所指示的数据；函数调用结束，参数不再有效。
virtual TAPIINT32 TAP_CDECL ITapQuoteAPI::QryCommodity ( TAPIUINT32 * sessionID )
pure virtual

得到所有品种

参数
[out] sessionID 返回请求的会话ID。
返回值
0 | 请求成功
非0 | 错误码
操作类型
异步操作


TapQuoteAPI: 6.获取合约信息

函数
6.获取合约信息

函数

virtual void TAP_CDECL | ITapQuoteAPINotify::OnRspQryContract (TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteContractInfo *info)=0
virtual TAPIINT32 TAP_CDECL | ITapQuoteAPI::QryContract (TAPIUINT32 *sessionID, const TapAPICommodity *qryReq)=0

详细描述

函数说明

virtual void TAP_CDECL ITapQuoteAPINotify::OnRspQryContract | ( | TAPIUINT32 | sessionID,
 |  | TAPIINT32 | errorCode,
 |  | TAPIYNFLAG | isLast,
 |  | const TapAPIQuoteContractInfo * | info
 | ) |  |
pure virtual

返回系统中合约信息

参数
[in] | sessionID | 请求的会话ID；
[in] | errorCode | 错误码，当errorCode!=0时,info为NULL；
[in] | isLast | 标示是否是最后一批数据；
[in] | info | 指向返回的信息结构体。当errorCode不为0时，info为空。
注意
不要修改和删除info所指示的数据；函数调用结束，参数不再有效。
virtual TAPIINT32 TAP_CDECL ITapQuoteAPI::QryContract | ( | TAPIUINT32 * | sessionID,
 |  | const TapAPICommodity * | qryReq
 | ) |  |
pure virtual

查询系统中指定品种的合约信息

使用此函数前需要先QryCommodity()取得品种信息， 然后选择需要的品种将信息填入TapAPICommodity结构体中完成查询请求。

参数
[out] sessionID 返回请求的会话ID;
[in] qryReq 查询系统中指定品种的合约信息请求的结构体指针;
该参数各字段为可选字段，可以用以下方法查询：
1.全部留空：查所有合约
2.仅交易所编码有效：查该交易所下所有品种的合约
3.交易所编码和品种类型有效：查该交易所下指定品种类型的合约
4.交易所编码、品种类型和品种编码都有效：查该品种下的所有合约
返回值
0 | 请求成功
非0 | 错误码
操作类型
异步操作


TapQuoteAPI: 7.行情信息的订阅与退订

函数
7.行情信息的订阅与退订

函数

virtual void TAP_CDECL | ITapQuoteAPINotify::OnRspSubscribeQuote (TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteWhole *info)=0
virtual void TAP_CDECL | ITapQuoteAPINotify::OnRspUnSubscribeQuote (TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIContract *info)=0
virtual void TAP_CDECL | ITapQuoteAPINotify::OnRtnQuote (const TapAPIQuoteWhole *info)=0
virtual TAPIINT32 TAP_CDECL | ITapQuoteAPI::SubscribeQuote (TAPIUINT32 *sessionID, const TapAPIContract *contract)=0
virtual TAPIINT32 TAP_CDECL | ITapQuoteAPI::UnSubscribeQuote (TAPIUINT32 *sessionID, const TapAPIContract *contract)=0

详细描述

函数说明

virtual void TAP_CDECL ITapQuoteAPINotify::OnRspSubscribeQuote | ( | TAPIUINT32 | sessionID,
 |  | TAPIINT32 | errorCode,
 |  | TAPIYNFLAG | isLast,
 |  | const TapAPIQuoteWhole * | info
 | ) |  |
pure virtual

返回订阅行情的全文。

此回调接口用来返回订阅行情的全文。全文为当前时间的行情信息。

参数
[in] | sessionID | 请求的会话ID；
[in] | isLast | 标示是否是最后一批数据；
[in] | errorCode | 错误码，当errorCode!=0时,info为NULL；
[in] | info | 指向返回的信息结构体。当errorCode不为0时，info为空。
注意
不要修改和删除info所指示的数据；函数调用结束，参数不再有效。
virtual void TAP_CDECL ITapQuoteAPINotify::OnRspUnSubscribeQuote | ( | TAPIUINT32 | sessionID,
 |  | TAPIINT32 | errorCode,
 |  | TAPIYNFLAG | isLast,
 |  | const TapAPIContract * | info
 | ) |  |
pure virtual

退订指定合约的行情的结果回调

参数
[in] | sessionID | 请求的会话ID；
[in] | errorCode | 错误码，当errorCode!=0时,info为NULL；
[in] | isLast | 标示是否是最后一批数据；
[in] | info | 指向返回的信息结构体。当errorCode不为0时，info为空。
注意
不要修改和删除info所指示的数据；函数调用结束，参数不再有效。
virtual void TAP_CDECL ITapQuoteAPINotify::OnRtnQuote ( const TapAPIQuoteWhole * info )
pure virtual

返回订阅行情的变化内容。

此回调接口用来通知用户行情信息产生了变化，并向用户提交新的行情全文。

参数
[in] info 最新的行情全文内容
注意
不要修改和删除Quote指示的数据；函数调用结束，参数不再有效。
virtual TAPIINT32 TAP_CDECL ITapQuoteAPI::SubscribeQuote | ( | TAPIUINT32 * | sessionID,
 |  | const TapAPIContract * | contract
 | ) |  |
pure virtual

订阅指定合约的行情

函数向服务器请求contract描述的合约的行情信息，行情订阅成功后服务器将持续向用户推送行情信息， 直到用户退订行情信息或者断开于服务器的通信。
调用此函数前先获取合约信息，然后从合约信息中取出合约填入contract。

参数
[out] | sessionID | 返回请求的会话ID。
[in] | contract | 指定合约。
返回值
0 | 请求成功
非0 | 错误码
操作类型
异步操作
virtual TAPIINT32 TAP_CDECL ITapQuoteAPI::UnSubscribeQuote | ( | TAPIUINT32 * | sessionID,
 |  | const TapAPIContract * | contract
 | ) |  |
pure virtual

退订指定合约的行情

退订已经订阅的行情信息。

参数
[out] | sessionID | 返回请求的会话ID；
[in] | contract | 指定合约。
返回值
0 | 请求成功
非0 | 错误码
操作类型
异步操作


TapQuoteAPI: 数据类型说明

  • 错误码说明
  • 基本类型说明
数据类型说明
  • 错误码说明
  • 基本类型说明


TapQuoteAPI: 错误码说明

错误码说明

目录

  • TapAPI内部返回的错误码定义。
  • 输入参数检查错误
  • 网络断开错误代码定义
  • 业务返回的错误代码定义

TapAPI内部返回的错误码定义。

错误码 | 错误码定义 | 内容
0 | TAPIERROR_SUCCEED | 成功
-1 | TAPIERROR_ConnectFail | 连接服务失败
-2 | TAPIERROR_LinkAuthFail | 链路认证失败
-3 | TAPIERROR_HostUnavailable | 主机地址不可用
-4 | TAPIERROR_SendDataError | 发送数据错误
-5 | TAPIERROR_TestIDError | 测试编号不合法
-6 | TAPIERROR_NotReadyTestNetwork | 没准备好测试网络
-7 | TAPIERROR_CurTestNotOver | 当前网络测试还没结束
-8 | TAPIERROR_NOFrontAvailable | 没用可用的接入前置
-9 | TAPIERROR_DataPathAvaiable | 数据路径不可用
-10 | TAPIERROR_RepeatLogin | 重复登录
-11 | TAPIERROR_InnerError | 内部错误
-12 | TAPIERROR_LastReqNotFinish | 上一次请求还没有结束
-13 | TAPIERROR_InputValueError | 输入参数非法
-14 | TAPIERROR_AuthCode_Invalid | 授权码不合法
-15 | TAPIERROR_AuthCode_Expired | 授权码超期
-16 | TAPIERROR_AuthCode_TypeNotMatch | 授权码类型不匹配
-17 | TAPIERROR_API_NotReady | API还没有准备好
-18 | TAPIERROR_UDP_LISTEN_FAILED | UDP端口监听失败
-19 | TAPIERROR_UDP_LISTENING | UDP正在监听
-20 | TAPIERROR_NotImplemented | 接口未实现
-21 | TAPIERROR_CallOneTimeOnly | 每次登陆只允许调用一次

输入参数检查错误

错误码 | 错误码定义 | 内容
-10000 | TAPIERROR_INPUTERROR_NULL | 输入数据为NULL
-10001 | TAPIERROR_INPUTERROR_TAPIYNFLAG | 输入错误的:TAPIYNFLAG
-10002 | TAPIERROR_INPUTERROR_TAPILOGLEVEL | 输入错误的:TAPILOGLEVEL
-10003 | TAPIERROR_INPUTERROR_TAPICommodityType | 输入错误的:TAPICommodityType
-10004 | TAPIERROR_INPUTERROR_TAPICallOrPutFlagType | 输入错误的:TAPICallOrPutFlagType

网络断开错误代码定义

错误码 | 错误码定义 | 内容
1 | TAPIERROR_DISCONNECT_CLOSE_INIT | 主动断开
2 | TAPIERROR_DISCONNECT_CLOSE_PASS | 被动断开
3 | TAPIERROR_DISCONNECT_READ_ERROR | 读错误
4 | TAPIERROR_DISCONNECT_WRITE_ERROR | 写错误
5 | TAPIERROR_DISCONNECT_BUF_FULL | 缓冲区满
6 | TAPIERROR_DISCONNECT_IOCP_ERROR | 异步操作错误
7 | TAPIERROR_DISCONNECT_PARSE_ERROR | 解析数据错误
8 | TAPIERROR_DISCONNECT_CONNECT_TIMEOUT | 连接超时
9 | TAPIERROR_DISCONNECT_INIT_ERROR | 初始化失败
10 | TAPIERROR_DISCONNECT_HAS_CONNECTED | 已经连接
11 | TAPIERROR_DISCONNECT_HAS_EXIT | 工作线程已结束
12 | TAPIERROR_DISCONNECT_TRY_LATER | 操作正在进行，请稍后重试

业务返回的错误代码定义

错误码 | 错误码定义 | 内容
10001 | TAPIERROR_LOGIN | 登录过程执行错误
10002 | TAPIERROR_LOGIN_USER | 登录用户不存在
10003 | TAPIERROR_LOGIN_DDA | 需要进行动态认证
10004 | TAPIERROR_LOGIN_LICENSE | 登录用户未授权
10005 | TAPIERROR_LOGIN_MODULE | 登录模块不正确
10007 | TAPIERROR_LOGIN_STATE | 登录状态禁止登陆
10008 | TAPIERROR_LOGIN_PASS | 登录密码不正确
10009 | TAPIERROR_LOGIN_RIGHT | 没有该模块登录权限
10010 | TAPIERROR_LOGIN_COUNT | 登录数量超限
10011 | TAPIERROR_LOGIN_NOTIN_SERVERFLAGUSRES | 登录用户不在服务器标识下可登录用户列表中
72001 | TAPIERROR_SUBSCRIBEQUOTE_MAX | 超过行情最大总订阅数
72002 | TAPIERROR_SUBSCRIBEQUOTE_EXCHANGE_MAX | 超过该交易所行情最大订阅数
72101 | TAPIERROR_SUBSCRIBEQUOTE_NO_RIGHT | 没有该行情的订阅权限
72102 | TAPIERROR_SUBSCRIBEQUOTE_NO_EXCHANGE_RIGHT | 没有该交易所下行情的订阅权限
72103 | TAPIERROR_SUBSCRIBEQUOTE_COMMODITY_NOT_EXIST | 品种不存在
72104 | TAPIERROR_SUBSCRIBEQUOTE_CONTRACT_MAY_NOT_EXIST | 合约可能不存在


TapQuoteAPI: 数据类型说明

数据类型说明

目录

  • 基本字符串类型定义
  • 基本数值类型定义
  • 是否标示
  • 日期时间类型定义
  • 日志级别
  • 品种类型
  • 看涨看跌标示
  • 行情基本类型

基本字符串类型定义

类型 | 原始类型 | 说明
TAPISTR_10 | char[11] | 长度为10的字符串
TAPISTR_20 | char[21] | 长度为20的字符串
TAPISTR_30 | char[31] | 长度为30的字符串
TAPISTR_40 | char[41] | 长度为40的字符串
TAPISTR_50 | char[51] | 长度为50的字符串
TAPISTR_70 | char[71] | 长度为70的字符串
TAPISTR_100 | char[101] | 长度为100的字符串
TAPISTR_300 | char[301] | 长度为300的字符串
TAPISTR_500 | char[501] | 长度为500的字符串
TAPISTR_2000 | char[2001] | 长度为2000的字符串
TAPIAUTHCODE | char[513] | Authorization Code.
TAPICHAR | char | 单字符定义，可用于定义其他类型

基本数值类型定义

类型 | 原始类型 | 说明
TAPIINT32 | int | int 32
TAPIUINT32 | unsigned int | unsigned 32
TAPIINT64 | long long | int 64
TAPIUINT64 | unsigned long long | unsigned 64
TAPIUINT16 | unsigned short | unsigned 16
TAPIUINT8 | unsigned char | unsigned 8
TAPIREAL64 | double | real 64

是否标示

类型 | 原始类型 | 值 | 说明
TAPIYNFLAG | TAPICHAR |  | 是否标示
APIYNFLAG_YES | const TAPIYNFLAG | 'Y' | 是
APIYNFLAG_NO | const TAPIYNFLAG | 'N' | 否

日期时间类型定义

类型 | 原始类型 | 说明
TAPIDTSTAMP | char[24] | 时间戳类型(格式 yyyy-MM-dd hh:nn:ss.xxx)
TAPIDATETIME | char[20] | 日期和时间类型(格式 yyyy-MM-dd hh:nn:ss)
TAPIDATE | char[11] | 日期类型(格式 yyyy-MM-dd)
TAPITIME | char[9] | 时间类型(格式 hh:nn:ss)

日志级别

类型 | 原始类型 | 值 | 说明
TAPILOGLEVEL | TAPICHAR |  | 日志级别
APILOGLEVEL_NONE | const TAPILOGLEVEL | 'N' | 无
APILOGLEVEL_ERROR | const TAPILOGLEVEL | 'E' | Error.
APILOGLEVEL_WARNING | const TAPILOGLEVEL | 'W' | Warning.
APILOGLEVEL_DEBUG | const TAPILOGLEVEL | 'D' | Debug.

品种类型

类型 | 原始类型 | 值 | 说明
TAPICommodityType | TAPICHAR |  | 品种类型
TAPI_COMMODITY_TYPE_NONE | const TAPICommodityType | 'N' | 无
TAPI_COMMODITY_TYPE_SPOT | const TAPICommodityType | 'P' | 现货
TAPI_COMMODITY_TYPE_FUTURES | const TAPICommodityType | 'F' | 期货
TAPI_COMMODITY_TYPE_OPTION | const TAPICommodityType | 'O' | 期权
TAPI_COMMODITY_TYPE_SPREAD_MONTH | const TAPICommodityType | 'S' | 跨期套利
TAPI_COMMODITY_TYPE_SPREAD_COMMODITY | const TAPICommodityType | 'M' | 跨品种套利
TAPI_COMMODITY_TYPE_BUL | const TAPICommodityType | 'U' | 看涨垂直套利
TAPI_COMMODITY_TYPE_BER | const TAPICommodityType | 'E' | 看跌垂直套利
TAPI_COMMODITY_TYPE_STD | const TAPICommodityType | 'D' | 跨式套利
TAPI_COMMODITY_TYPE_STG | const TAPICommodityType | 'G' | 宽跨式套利
TAPI_COMMODITY_TYPE_PRT | const TAPICommodityType | 'R' | 备兑组合
TAPI_COMMODITY_TYPE_DIRECTFOREX | const TAPICommodityType | 'X' | 外汇――直接汇率
TAPI_COMMODITY_TYPE_INDIRECTFOREX | const TAPICommodityType | 'I' | 外汇――间接汇率
TAPI_COMMODITY_TYPE_CROSSFOREX | const TAPICommodityType | 'C' | 外汇――交叉汇率
TAPI_COMMODITY_TYPE_INDEX | const TAPICommodityType | 'Z' | 指数
TAPI_COMMODITY_TYPE_STOCK | const TAPICommodityType | 'T' | 股票

看涨看跌标示

类型 | 原始类型 | 值 | 说明
TAPICallOrPutFlagType | TAPICHAR |  | 看涨看跌标示
TAPI_CALLPUT_FLAG_CALL | const TAPICallOrPutFlagType | 'C' | 买权
TAPI_CALLPUT_FLAG_PUT | const TAPICallOrPutFlagType | 'P' | 卖权
TAPI_CALLPUT_FLAG_NONE | const TAPICallOrPutFlagType | 'N' | 无

行情基本类型

类型 | 原始类型 | 说明
TAPIQPRICE | TAPIREAL64 | 行情价格
TAPIQVOLUME | TAPIUINT64 | 行情量
TAPIQDIFF | TAPIINT64 | 变化值
生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: MDDataTypeTable.h 文件参考

  • 文件列表
  • 文件成员
  • code
  • ext
  • MarkDownTables
  • TapQuoteAPI
MDDataTypeTable.h 文件参考

浏览源代码.

生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: MDDataTypeTable.h 源文件

  • 文件列表
  • 文件成员
  • code
  • ext
  • MarkDownTables
  • TapQuoteAPI
MDDataTypeTable.h
浏览该文件的文档.
1 /** @page P_DataType 数据类型说明
2 @tableofcontents
3
4
5 @section sec_P_DataType1 基本字符串类型定义
6
7 类型|原始类型|说明
8 --|--|--
9 TAPISTR_10|char[11]|长度为10的字符串
10 TAPISTR_20|char[21]|长度为20的字符串
11 TAPISTR_30|char[31]|长度为30的字符串
12 TAPISTR_40|char[41]|长度为40的字符串
13 TAPISTR_50|char[51]|长度为50的字符串
14 TAPISTR_70|char[71]|长度为70的字符串
15 TAPISTR_100|char[101]|长度为100的字符串
16 TAPISTR_300|char[301]|长度为300的字符串
17 TAPISTR_500|char[501]|长度为500的字符串
18 TAPISTR_2000|char[2001]|长度为2000的字符串
19 TAPIAUTHCODE|char[513]|Authorization Code.
20 TAPICHAR|char|单字符定义，可用于定义其他类型
21
22
23 @section sec_P_DataType2 基本数值类型定义
24
25 类型|原始类型|说明
26 --|--|--
27 TAPIINT32|int|int 32
28 TAPIUINT32|unsigned int|unsigned 32
29 TAPIINT64|long long|int 64
30 TAPIUINT64|unsigned long long|unsigned 64
31 TAPIUINT16|unsigned short|unsigned 16
32 TAPIUINT8|unsigned char|unsigned 8
33 TAPIREAL64|double|real 64
34
35
36 @section sec_P_DataType3 是否标示
37
38 类型|原始类型|值|说明
39 --|--|--|--
40 TAPIYNFLAG|TAPICHAR||是否标示
41 APIYNFLAG_YES|const TAPIYNFLAG|'Y'|是
42 APIYNFLAG_NO|const TAPIYNFLAG|'N'|否
43
44
45 @section sec_P_DataType4 日期时间类型定义
46
47 类型|原始类型|说明
48 --|--|--
49 TAPIDTSTAMP|char[24]|时间戳类型(格式 yyyy-MM-dd hh:nn:ss.xxx)
50 TAPIDATETIME|char[20]|日期和时间类型(格式 yyyy-MM-dd hh:nn:ss)
51 TAPIDATE|char[11]|日期类型(格式 yyyy-MM-dd)
52 TAPITIME|char[9]|时间类型(格式 hh:nn:ss)
53
54
55 @section sec_P_DataType5 日志级别
56
57 类型|原始类型|值|说明
58 --|--|--|--
59 TAPILOGLEVEL|TAPICHAR||日志级别
60 APILOGLEVEL_NONE|const TAPILOGLEVEL|'N'|无
61 APILOGLEVEL_ERROR|const TAPILOGLEVEL|'E'|Error.
62 APILOGLEVEL_WARNING|const TAPILOGLEVEL|'W'|Warning.
63 APILOGLEVEL_DEBUG|const TAPILOGLEVEL|'D'|Debug.
64
65
66 @section sec_P_DataType6 品种类型
67
68 类型|原始类型|值|说明
69 --|--|--|--
70 TAPICommodityType|TAPICHAR||品种类型
71 TAPI_COMMODITY_TYPE_NONE|const TAPICommodityType|'N'|无
72 TAPI_COMMODITY_TYPE_SPOT|const TAPICommodityType|'P'|现货
73 TAPI_COMMODITY_TYPE_FUTURES|const TAPICommodityType|'F'|期货
74 TAPI_COMMODITY_TYPE_OPTION|const TAPICommodityType|'O'|期权
75 TAPI_COMMODITY_TYPE_SPREAD_MONTH|const TAPICommodityType|'S'|跨期套利
76 TAPI_COMMODITY_TYPE_SPREAD_COMMODITY|const TAPICommodityType|'M'|跨品种套利
77 TAPI_COMMODITY_TYPE_BUL|const TAPICommodityType|'U'|看涨垂直套利
78 TAPI_COMMODITY_TYPE_BER|const TAPICommodityType|'E'|看跌垂直套利
79 TAPI_COMMODITY_TYPE_STD|const TAPICommodityType|'D'|跨式套利
80 TAPI_COMMODITY_TYPE_STG|const TAPICommodityType|'G'|宽跨式套利
81 TAPI_COMMODITY_TYPE_PRT|const TAPICommodityType|'R'|备兑组合
82 TAPI_COMMODITY_TYPE_DIRECTFOREX|const TAPICommodityType|'X'|外汇――直接汇率
83 TAPI_COMMODITY_TYPE_INDIRECTFOREX|const TAPICommodityType|'I'|外汇――间接汇率
84 TAPI_COMMODITY_TYPE_CROSSFOREX|const TAPICommodityType|'C'|外汇――交叉汇率
85 TAPI_COMMODITY_TYPE_INDEX|const TAPICommodityType|'Z'|指数
86 TAPI_COMMODITY_TYPE_STOCK|const TAPICommodityType|'T'|股票
87
88
89 @section sec_P_DataType7 看涨看跌标示
90
91 类型|原始类型|值|说明
92 --|--|--|--
93 TAPICallOrPutFlagType|TAPICHAR||看涨看跌标示
94 TAPI_CALLPUT_FLAG_CALL|const TAPICallOrPutFlagType|'C'|买权
95 TAPI_CALLPUT_FLAG_PUT|const TAPICallOrPutFlagType|'P'|卖权
96 TAPI_CALLPUT_FLAG_NONE|const TAPICallOrPutFlagType|'N'|无
97
98
99 @section sec_P_DataType8 行情基本类型
100
101 类型|原始类型|说明
102 --|--|--
103 TAPIQPRICE|TAPIREAL64|行情价格
104 TAPIQVOLUME|TAPIUINT64|行情量
105 TAPIQDIFF|TAPIINT64|变化值
106
107 */
生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: MDErrorCodeTable.h 文件参考

  • 文件列表
  • 文件成员
  • code
  • ext
  • MarkDownTables
  • TapQuoteAPI
MDErrorCodeTable.h 文件参考

浏览源代码.

生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: MDErrorCodeTable.h 源文件

  • 文件列表
  • 文件成员
  • code
  • ext
  • MarkDownTables
  • TapQuoteAPI
MDErrorCodeTable.h
浏览该文件的文档.
1 /** @page P_ErrorCode 错误码说明
2 @tableofcontents
3
4
5 @section sec_P_ErrorCode1 TapAPI内部返回的错误码定义。
6
7 错误码|错误码定义|内容
8 --|--|--
9 0|TAPIERROR_SUCCEED|成功
10 -1|TAPIERROR_ConnectFail|连接服务失败
11 -2|TAPIERROR_LinkAuthFail|链路认证失败
12 -3|TAPIERROR_HostUnavailable|主机地址不可用
13 -4|TAPIERROR_SendDataError|发送数据错误
14 -5|TAPIERROR_TestIDError|测试编号不合法
15 -6|TAPIERROR_NotReadyTestNetwork|没准备好测试网络
16 -7|TAPIERROR_CurTestNotOver|当前网络测试还没结束
17 -8|TAPIERROR_NOFrontAvailable|没用可用的接入前置
18 -9|TAPIERROR_DataPathAvaiable|数据路径不可用
19 -10|TAPIERROR_RepeatLogin|重复登录
20 -11|TAPIERROR_InnerError|内部错误
21 -12|TAPIERROR_LastReqNotFinish|上一次请求还没有结束
22 -13|TAPIERROR_InputValueError|输入参数非法
23 -14|TAPIERROR_AuthCode_Invalid|授权码不合法
24 -15|TAPIERROR_AuthCode_Expired|授权码超期
25 -16|TAPIERROR_AuthCode_TypeNotMatch|授权码类型不匹配
26 -17|TAPIERROR_API_NotReady|API还没有准备好
27 -18|TAPIERROR_UDP_LISTEN_FAILED|UDP端口监听失败
28 -19|TAPIERROR_UDP_LISTENING|UDP正在监听
29 -20|TAPIERROR_NotImplemented|接口未实现
30 -21|TAPIERROR_CallOneTimeOnly|每次登陆只允许调用一次
31
32
33 @section sec_P_ErrorCode2 输入参数检查错误
34
35 错误码|错误码定义|内容
36 --|--|--
37 -10000|TAPIERROR_INPUTERROR_NULL|输入数据为NULL
38 -10001|TAPIERROR_INPUTERROR_TAPIYNFLAG|输入错误的:TAPIYNFLAG
39 -10002|TAPIERROR_INPUTERROR_TAPILOGLEVEL|输入错误的:TAPILOGLEVEL
40 -10003|TAPIERROR_INPUTERROR_TAPICommodityType|输入错误的:TAPICommodityType
41 -10004|TAPIERROR_INPUTERROR_TAPICallOrPutFlagType|输入错误的:TAPICallOrPutFlagType
42
43
44 @section sec_P_ErrorCode3 网络断开错误代码定义
45
46 错误码|错误码定义|内容
47 --|--|--
48 1|TAPIERROR_DISCONNECT_CLOSE_INIT|主动断开
49 2|TAPIERROR_DISCONNECT_CLOSE_PASS|被动断开
50 3|TAPIERROR_DISCONNECT_READ_ERROR|读错误
51 4|TAPIERROR_DISCONNECT_WRITE_ERROR|写错误
52 5|TAPIERROR_DISCONNECT_BUF_FULL|缓冲区满
53 6|TAPIERROR_DISCONNECT_IOCP_ERROR|异步操作错误
54 7|TAPIERROR_DISCONNECT_PARSE_ERROR|解析数据错误
55 8|TAPIERROR_DISCONNECT_CONNECT_TIMEOUT|连接超时
56 9|TAPIERROR_DISCONNECT_INIT_ERROR|初始化失败
57 10|TAPIERROR_DISCONNECT_HAS_CONNECTED|已经连接
58 11|TAPIERROR_DISCONNECT_HAS_EXIT|工作线程已结束
59 12|TAPIERROR_DISCONNECT_TRY_LATER|操作正在进行，请稍后重试
60
61
62 @section sec_P_ErrorCode4 业务返回的错误代码定义
63
64 错误码|错误码定义|内容
65 --|--|--
66 10001|TAPIERROR_LOGIN|登录过程执行错误
67 10002|TAPIERROR_LOGIN_USER|登录用户不存在
68 10003|TAPIERROR_LOGIN_DDA|需要进行动态认证
69 10004|TAPIERROR_LOGIN_LICENSE|登录用户未授权
70 10005|TAPIERROR_LOGIN_MODULE|登录模块不正确
71 10007|TAPIERROR_LOGIN_STATE|登录状态禁止登陆
72 10008|TAPIERROR_LOGIN_PASS|登录密码不正确
73 10009|TAPIERROR_LOGIN_RIGHT|没有该模块登录权限
74 10010|TAPIERROR_LOGIN_COUNT|登录数量超限
75 10011|TAPIERROR_LOGIN_NOTIN_SERVERFLAGUSRES|登录用户不在服务器标识下可登录用户列表中
76 72001|TAPIERROR_SUBSCRIBEQUOTE_MAX|超过行情最大总订阅数
77 72002|TAPIERROR_SUBSCRIBEQUOTE_EXCHANGE_MAX|超过该交易所行情最大订阅数
78 72101|TAPIERROR_SUBSCRIBEQUOTE_NO_RIGHT|没有该行情的订阅权限
79 72102|TAPIERROR_SUBSCRIBEQUOTE_NO_EXCHANGE_RIGHT|没有该交易所下行情的订阅权限
80 72103|TAPIERROR_SUBSCRIBEQUOTE_COMMODITY_NOT_EXIST|品种不存在
81 72104|TAPIERROR_SUBSCRIBEQUOTE_CONTRACT_MAY_NOT_EXIST|合约可能不存在
82
83 */
生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: TapAPICommDef.h 文件参考

  • 文件列表
  • 文件成员
  • code
  • include
类 | 类型定义 | 变量
TapAPICommDef.h 文件参考

浏览源代码.

类

struct | TapAPIApplicationInfo
struct | TapAPICommodity
struct | TapAPIContract
struct | TapAPIExchangeInfo
struct | TapAPIChangePasswordReq

类型定义

typedef char | TAPISTR_10 [11]
typedef char | TAPISTR_20 [21]
typedef char | TAPISTR_30 [31]
typedef char | TAPISTR_40 [41]
typedef char | TAPISTR_50 [51]
typedef char | TAPISTR_70 [71]
typedef char | TAPISTR_100 [101]
typedef char | TAPISTR_300 [301]
typedef char | TAPISTR_500 [501]
typedef char | TAPISTR_2000 [2001]
typedef char | TAPIAUTHCODE [513]
typedef char | TAPICHAR
typedef int | TAPIINT32
typedef unsigned int | TAPIUINT32
typedef long long | TAPIINT64
typedef unsigned long long | TAPIUINT64
typedef unsigned short | TAPIUINT16
typedef unsigned char | TAPIUINT8
typedef double | TAPIREAL64
typedef TAPICHAR | TAPIYNFLAG
typedef char | TAPIDTSTAMP [24]
typedef char | TAPIDATETIME [20]
typedef char | TAPIDATE [11]
typedef char | TAPITIME [9]
typedef TAPICHAR | TAPILOGLEVEL
typedef TAPICHAR | TAPICommodityType
typedef TAPICHAR | TAPICallOrPutFlagType

变量

const TAPIYNFLAG | APIYNFLAG_YES ='Y'
const TAPIYNFLAG | APIYNFLAG_NO ='N'
const TAPILOGLEVEL | APILOGLEVEL_NONE ='N'
const TAPILOGLEVEL | APILOGLEVEL_ERROR ='E'
const TAPILOGLEVEL | APILOGLEVEL_WARNING ='W'
const TAPILOGLEVEL | APILOGLEVEL_DEBUG ='D'
const TAPICommodityType | TAPI_COMMODITY_TYPE_NONE = 'N'
const TAPICommodityType | TAPI_COMMODITY_TYPE_SPOT = 'P'
const TAPICommodityType | TAPI_COMMODITY_TYPE_FUTURES = 'F'
const TAPICommodityType | TAPI_COMMODITY_TYPE_OPTION = 'O'
const TAPICommodityType | TAPI_COMMODITY_TYPE_SPREAD_MONTH = 'S'
const TAPICommodityType | TAPI_COMMODITY_TYPE_SPREAD_COMMODITY = 'M'
const TAPICommodityType | TAPI_COMMODITY_TYPE_BUL = 'U'
const TAPICommodityType | TAPI_COMMODITY_TYPE_BER = 'E'
const TAPICommodityType | TAPI_COMMODITY_TYPE_STD = 'D'
const TAPICommodityType | TAPI_COMMODITY_TYPE_STG = 'G'
const TAPICommodityType | TAPI_COMMODITY_TYPE_PRT = 'R'
const TAPICommodityType | TAPI_COMMODITY_TYPE_DIRECTFOREX = 'X'
const TAPICommodityType | TAPI_COMMODITY_TYPE_INDIRECTFOREX = 'I'
const TAPICommodityType | TAPI_COMMODITY_TYPE_CROSSFOREX = 'C'
const TAPICommodityType | TAPI_COMMODITY_TYPE_INDEX = 'Z'
const TAPICommodityType | TAPI_COMMODITY_TYPE_STOCK = 'T'
const TAPICallOrPutFlagType | TAPI_CALLPUT_FLAG_CALL = 'C'
const TAPICallOrPutFlagType | TAPI_CALLPUT_FLAG_PUT = 'P'
const TAPICallOrPutFlagType | TAPI_CALLPUT_FLAG_NONE = 'N'
生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: TapAPICommDef.h 源文件

  • 文件列表
  • 文件成员
  • code
  • include
TapAPICommDef.h
浏览该文件的文档.
1 #ifndef TAP_API_COMM_DEF_H
2 #define TAP_API_COMM_DEF_H
3
4 #pragma pack(push, 1)
5
6 //=============================================================================
7 /**
8 * \addtogroup G_DATATYPE_CHARS 基本字符串类型定义
9 * @{
10 */
11 //=============================================================================
12
13 //! 长度为10的字符串
14 typedef char TAPISTR_10[11];
15 //! 长度为20的字符串
16 typedef char TAPISTR_20[21];
17 //! 长度为30的字符串
18 typedef char TAPISTR_30[31];
19 //! 长度为40的字符串
20 typedef char TAPISTR_40[41];
21 //! 长度为50的字符串
22 typedef char TAPISTR_50[51];
23 //! 长度为70的字符串
24 typedef char TAPISTR_70[71];
25 //! 长度为100的字符串
26 typedef char TAPISTR_100[101];
27 //! 长度为300的字符串
28 typedef char TAPISTR_300[301];
29 //! 长度为500的字符串
30 typedef char TAPISTR_500[501];
31 //! 长度为2000的字符串
32 typedef char TAPISTR_2000[2001];
33
34 //! Authorization Code
35 typedef char TAPIAUTHCODE[513];
36
37
38 //! 单字符定义，可用于定义其他类型
39 typedef char TAPICHAR;
40 /** @}*/
41
42
43 //=============================================================================
44 /**
45 * \addtogroup G_DATATYPE_NUMBER 基本数值类型定义
46 * @{
47 */
48 //=============================================================================
49
50 //! int 32
51 typedef int TAPIINT32;
52 //! unsigned 32
53 typedef unsigned int TAPIUINT32;
54 //! int 64
55 typedef long long TAPIINT64;
56 //! unsigned 64
57 typedef unsigned long long TAPIUINT64;
58 //! unsigned 16
59 typedef unsigned short TAPIUINT16;
60 //! unsigned 8
61 typedef unsigned char TAPIUINT8;
62 //! real 64
63 typedef double TAPIREAL64;
64
65 /** @}*/
66
67 //=============================================================================
68 /**
69 * \addtogroup G_DATATYPE_YNFLAG 是否标示
70 * @{
71 */
72 //=============================================================================
73 //! 是否标示
74 typedef TAPICHAR TAPIYNFLAG;
75 //! 是
76 const TAPIYNFLAG APIYNFLAG_YES ='Y';
77 //! 否
78 const TAPIYNFLAG APIYNFLAG_NO ='N';
79
80 /** @}*/
81
82
83
84 //=============================================================================
85 /**
86 * \addtogroup G_DATATYPE_DATETIME 日期时间类型定义
87 * @{
88 */
89 //=============================================================================
90
91 //! 时间戳类型(格式 yyyy-MM-dd hh:nn:ss.xxx)
92 typedef char TAPIDTSTAMP[24];
93 //! 日期和时间类型(格式 yyyy-MM-dd hh:nn:ss)
94 typedef char TAPIDATETIME[20];
95 //! 日期类型(格式 yyyy-MM-dd)
96 typedef char TAPIDATE[11];
97 //! 时间类型(格式 hh:nn:ss)
98 typedef char TAPITIME[9];
99 /** @}*/
100
101 //=============================================================================
102 /**
103 * \addtogroup G_DATATYPE_LOG_LEVEL 日志级别
104 * @{
105 */
106 //=============================================================================
107 //! 日志级别
108 typedef TAPICHAR TAPILOGLEVEL;
109 //! 无
110 const TAPILOGLEVEL APILOGLEVEL_NONE ='N';
111 //! Error
112 const TAPILOGLEVEL APILOGLEVEL_ERROR ='E';
113 //! Warning
114 const TAPILOGLEVEL APILOGLEVEL_WARNING ='W';
115 //! Debug
116 const TAPILOGLEVEL APILOGLEVEL_DEBUG ='D';
117 /** @}*/
118
119
120 //=============================================================================
121 /**
122 * \addtogroup G_DATATYPE_COMMODITY_TYPE 品种类型
123 * @{
124 */
125 //=============================================================================
126
127 //! 品种类型
128 typedef TAPICHAR TAPICommodityType;
129 //! 无
130 const TAPICommodityType TAPI_COMMODITY_TYPE_NONE = 'N';
131 //! 现货
132 const TAPICommodityType TAPI_COMMODITY_TYPE_SPOT = 'P';
133 //! 期货
134 const TAPICommodityType TAPI_COMMODITY_TYPE_FUTURES = 'F';
135 //! 期权
136 const TAPICommodityType TAPI_COMMODITY_TYPE_OPTION = 'O';
137 //! 跨期套利
138 const TAPICommodityType TAPI_COMMODITY_TYPE_SPREAD_MONTH = 'S';
139 //! 跨品种套利
140 const TAPICommodityType TAPI_COMMODITY_TYPE_SPREAD_COMMODITY = 'M';
141 //! 看涨垂直套利
142 const TAPICommodityType TAPI_COMMODITY_TYPE_BUL = 'U';
143 //! 看跌垂直套利
144 const TAPICommodityType TAPI_COMMODITY_TYPE_BER = 'E';
145 //! 跨式套利
146 const TAPICommodityType TAPI_COMMODITY_TYPE_STD = 'D';
147 //! 宽跨式套利
148 const TAPICommodityType TAPI_COMMODITY_TYPE_STG = 'G';
149 //! 备兑组合
150 const TAPICommodityType TAPI_COMMODITY_TYPE_PRT = 'R';
151 //! 外汇――直接汇率
152 const TAPICommodityType TAPI_COMMODITY_TYPE_DIRECTFOREX = 'X';
153 //! 外汇――间接汇率
154 const TAPICommodityType TAPI_COMMODITY_TYPE_INDIRECTFOREX = 'I';
155 //! 外汇――交叉汇率
156 const TAPICommodityType TAPI_COMMODITY_TYPE_CROSSFOREX = 'C';
157 //! 指数
158 const TAPICommodityType TAPI_COMMODITY_TYPE_INDEX = 'Z';
159 //! 股票
160 const TAPICommodityType TAPI_COMMODITY_TYPE_STOCK = 'T';
161
162 /** @}*/
163
164
165 //=============================================================================
166 /**
167 * \addtogroup G_DATATYPE_CALL_OR_PUT 看涨看跌标示
168 * @{
169 */
170 //=============================================================================
171
172 //! 看涨看跌标示
173 typedef TAPICHAR TAPICallOrPutFlagType;
174 //! 买权
175 const TAPICallOrPutFlagType TAPI_CALLPUT_FLAG_CALL = 'C';
176 //! 卖权
177 const TAPICallOrPutFlagType TAPI_CALLPUT_FLAG_PUT = 'P';
178 //! 无
179 const TAPICallOrPutFlagType TAPI_CALLPUT_FLAG_NONE = 'N';
180
181 /** @}*/
182
183
184 //! Application信息
185 struct TapAPIApplicationInfo
186 {
187 TAPIAUTHCODE AuthCode; ///< 授权码
188 TAPISTR_300 KeyOperationLogPath; ///< 关键操作日志路径
189 };
190
191
192 //! 品种编码结构
193 struct TapAPICommodity
194 {
195 TAPISTR_10 ExchangeNo; ///< 交易所编码
196 TAPICommodityType CommodityType; ///< 品种类型
197 TAPISTR_10 CommodityNo; ///< 品种编号
198 };
199
200 //! 合约编码结构
201 struct TapAPIContract
202 {
203 TapAPICommodity Commodity; ///< 品种
204 TAPISTR_10 ContractNo1; ///< 合约代码1
205 TAPISTR_10 StrikePrice1; ///< 执行价1
206 TAPICallOrPutFlagType CallOrPutFlag1; ///< 看涨看跌标示1
207 TAPISTR_10 ContractNo2; ///< 合约代码2
208 TAPISTR_10 StrikePrice2; ///< 执行价2
209 TAPICallOrPutFlagType CallOrPutFlag2; ///< 看涨看跌标示2
210 };
211
212 //! 交易所信息
213 struct TapAPIExchangeInfo
214 {
215 TAPISTR_10 ExchangeNo; ///< 交易所编码
216 TAPISTR_20 ExchangeName; ///< 交易所名称
217 };
218
219 //! 修改密码请求
220 struct TapAPIChangePasswordReq
221 {
222 TAPISTR_20 OldPassword; ///< 旧密码
223 TAPISTR_20 NewPassword; ///< 新密码
224 };
225
226 #pragma pack(pop)
227
228 #endif
TAPISTR_40
char TAPISTR_40[41]
长度为40的字符串
Definition: TapAPICommDef.h:20
TAPI_COMMODITY_TYPE_SPOT
const TAPICommodityType TAPI_COMMODITY_TYPE_SPOT
现货
Definition: TapAPICommDef.h:132
TapAPIContract::StrikePrice2
TAPISTR_10 StrikePrice2
执行价2
Definition: TapAPICommDef.h:208
TAPIINT32
int TAPIINT32
int 32
Definition: TapAPICommDef.h:51
TAPIUINT64
unsigned long long TAPIUINT64
unsigned 64
Definition: TapAPICommDef.h:57
TAPI_COMMODITY_TYPE_PRT
const TAPICommodityType TAPI_COMMODITY_TYPE_PRT
备兑组合
Definition: TapAPICommDef.h:150
TAPI_COMMODITY_TYPE_INDEX
const TAPICommodityType TAPI_COMMODITY_TYPE_INDEX
指数
Definition: TapAPICommDef.h:158
TAPIREAL64
double TAPIREAL64
real 64
Definition: TapAPICommDef.h:63
TAPISTR_30
char TAPISTR_30[31]
长度为30的字符串
Definition: TapAPICommDef.h:18
TAPITIME
char TAPITIME[9]
时间类型(格式 hh:nn:ss)
Definition: TapAPICommDef.h:98
TAPISTR_100
char TAPISTR_100[101]
长度为100的字符串
Definition: TapAPICommDef.h:26
APIYNFLAG_YES
const TAPIYNFLAG APIYNFLAG_YES
是
Definition: TapAPICommDef.h:76
TapAPICommodity::ExchangeNo
TAPISTR_10 ExchangeNo
交易所编码
Definition: TapAPICommDef.h:195
TapAPICommodity::CommodityType
TAPICommodityType CommodityType
品种类型
Definition: TapAPICommDef.h:196
TAPICallOrPutFlagType
TAPICHAR TAPICallOrPutFlagType
看涨看跌标示
Definition: TapAPICommDef.h:173
TAPIUINT32
unsigned int TAPIUINT32
unsigned 32
Definition: TapAPICommDef.h:53
TapAPIContract::Commodity
TapAPICommodity Commodity
品种
Definition: TapAPICommDef.h:203
TAPIINT64
long long TAPIINT64
int 64
Definition: TapAPICommDef.h:55
TapAPIChangePasswordReq::NewPassword
TAPISTR_20 NewPassword
新密码
Definition: TapAPICommDef.h:223
TapAPIContract::StrikePrice1
TAPISTR_10 StrikePrice1
执行价1
Definition: TapAPICommDef.h:205
TAPI_COMMODITY_TYPE_SPREAD_COMMODITY
const TAPICommodityType TAPI_COMMODITY_TYPE_SPREAD_COMMODITY
跨品种套利
Definition: TapAPICommDef.h:140
TAPIYNFLAG
TAPICHAR TAPIYNFLAG
是否标示
Definition: TapAPICommDef.h:74
TAPI_COMMODITY_TYPE_SPREAD_MONTH
const TAPICommodityType TAPI_COMMODITY_TYPE_SPREAD_MONTH
跨期套利
Definition: TapAPICommDef.h:138
TapAPIContract::ContractNo1
TAPISTR_10 ContractNo1
合约代码1
Definition: TapAPICommDef.h:204
TapAPIApplicationInfo::KeyOperationLogPath
TAPISTR_300 KeyOperationLogPath
关键操作日志路径
Definition: TapAPICommDef.h:188
TAPISTR_500
char TAPISTR_500[501]
长度为500的字符串
Definition: TapAPICommDef.h:30
APILOGLEVEL_WARNING
const TAPILOGLEVEL APILOGLEVEL_WARNING
Warning.
Definition: TapAPICommDef.h:114
TapAPIContract::ContractNo2
TAPISTR_10 ContractNo2
合约代码2
Definition: TapAPICommDef.h:207
TAPI_COMMODITY_TYPE_BUL
const TAPICommodityType TAPI_COMMODITY_TYPE_BUL
看涨垂直套利
Definition: TapAPICommDef.h:142
TAPISTR_20
char TAPISTR_20[21]
长度为20的字符串
Definition: TapAPICommDef.h:16
TAPISTR_10
char TAPISTR_10[11]
长度为10的字符串
Definition: TapAPICommDef.h:14
TapAPIChangePasswordReq::OldPassword
TAPISTR_20 OldPassword
旧密码
Definition: TapAPICommDef.h:222
TAPI_COMMODITY_TYPE_OPTION
const TAPICommodityType TAPI_COMMODITY_TYPE_OPTION
期权
Definition: TapAPICommDef.h:136
TAPIAUTHCODE
char TAPIAUTHCODE[513]
Authorization Code.
Definition: TapAPICommDef.h:35
TapAPIExchangeInfo
交易所信息
Definition: TapAPICommDef.h:213
TAPICHAR
char TAPICHAR
单字符定义，可用于定义其他类型
Definition: TapAPICommDef.h:39
TAPILOGLEVEL
TAPICHAR TAPILOGLEVEL
日志级别
Definition: TapAPICommDef.h:108
TAPI_COMMODITY_TYPE_FUTURES
const TAPICommodityType TAPI_COMMODITY_TYPE_FUTURES
期货
Definition: TapAPICommDef.h:134
TapAPIExchangeInfo::ExchangeName
TAPISTR_20 ExchangeName
交易所名称
Definition: TapAPICommDef.h:216
TapAPIContract::CallOrPutFlag2
TAPICallOrPutFlagType CallOrPutFlag2
看涨看跌标示2
Definition: TapAPICommDef.h:209
TapAPIApplicationInfo::AuthCode
TAPIAUTHCODE AuthCode
授权码
Definition: TapAPICommDef.h:187
TAPIUINT16
unsigned short TAPIUINT16
unsigned 16
Definition: TapAPICommDef.h:59
TAPI_CALLPUT_FLAG_PUT
const TAPICallOrPutFlagType TAPI_CALLPUT_FLAG_PUT
卖权
Definition: TapAPICommDef.h:177
TapAPICommodity
品种编码结构
Definition: TapAPICommDef.h:193
APILOGLEVEL_DEBUG
const TAPILOGLEVEL APILOGLEVEL_DEBUG
Debug.
Definition: TapAPICommDef.h:116
TapAPIChangePasswordReq
修改密码请求
Definition: TapAPICommDef.h:220
TapAPIContract::CallOrPutFlag1
TAPICallOrPutFlagType CallOrPutFlag1
看涨看跌标示1
Definition: TapAPICommDef.h:206
TapAPIExchangeInfo::ExchangeNo
TAPISTR_10 ExchangeNo
交易所编码
Definition: TapAPICommDef.h:215
TAPI_COMMODITY_TYPE_BER
const TAPICommodityType TAPI_COMMODITY_TYPE_BER
看跌垂直套利
Definition: TapAPICommDef.h:144
TAPIDATE
char TAPIDATE[11]
日期类型(格式 yyyy-MM-dd)
Definition: TapAPICommDef.h:96
TAPI_COMMODITY_TYPE_INDIRECTFOREX
const TAPICommodityType TAPI_COMMODITY_TYPE_INDIRECTFOREX
外汇――间接汇率
Definition: TapAPICommDef.h:154
TAPI_CALLPUT_FLAG_CALL
const TAPICallOrPutFlagType TAPI_CALLPUT_FLAG_CALL
买权
Definition: TapAPICommDef.h:175
TAPISTR_2000
char TAPISTR_2000[2001]
长度为2000的字符串
Definition: TapAPICommDef.h:32
TAPISTR_70
char TAPISTR_70[71]
长度为70的字符串
Definition: TapAPICommDef.h:24
TAPI_CALLPUT_FLAG_NONE
const TAPICallOrPutFlagType TAPI_CALLPUT_FLAG_NONE
无
Definition: TapAPICommDef.h:179
TAPIUINT8
unsigned char TAPIUINT8
unsigned 8
Definition: TapAPICommDef.h:61
APILOGLEVEL_ERROR
const TAPILOGLEVEL APILOGLEVEL_ERROR
Error.
Definition: TapAPICommDef.h:112
TAPI_COMMODITY_TYPE_DIRECTFOREX
const TAPICommodityType TAPI_COMMODITY_TYPE_DIRECTFOREX
外汇――直接汇率
Definition: TapAPICommDef.h:152
TAPI_COMMODITY_TYPE_NONE
const TAPICommodityType TAPI_COMMODITY_TYPE_NONE
无
Definition: TapAPICommDef.h:130
TAPICommodityType
TAPICHAR TAPICommodityType
品种类型
Definition: TapAPICommDef.h:128
TapAPIApplicationInfo
Application信息
Definition: TapAPICommDef.h:185
APIYNFLAG_NO
const TAPIYNFLAG APIYNFLAG_NO
否
Definition: TapAPICommDef.h:78
APILOGLEVEL_NONE
const TAPILOGLEVEL APILOGLEVEL_NONE
无
Definition: TapAPICommDef.h:110
TapAPIContract
合约编码结构
Definition: TapAPICommDef.h:201
TAPI_COMMODITY_TYPE_STD
const TAPICommodityType TAPI_COMMODITY_TYPE_STD
跨式套利
Definition: TapAPICommDef.h:146
TAPIDATETIME
char TAPIDATETIME[20]
日期和时间类型(格式 yyyy-MM-dd hh:nn:ss)
Definition: TapAPICommDef.h:94
TAPI_COMMODITY_TYPE_STG
const TAPICommodityType TAPI_COMMODITY_TYPE_STG
宽跨式套利
Definition: TapAPICommDef.h:148
TAPI_COMMODITY_TYPE_CROSSFOREX
const TAPICommodityType TAPI_COMMODITY_TYPE_CROSSFOREX
外汇――交叉汇率
Definition: TapAPICommDef.h:156
TAPI_COMMODITY_TYPE_STOCK
const TAPICommodityType TAPI_COMMODITY_TYPE_STOCK
股票
Definition: TapAPICommDef.h:160
TAPISTR_50
char TAPISTR_50[51]
长度为50的字符串
Definition: TapAPICommDef.h:22
TapAPICommodity::CommodityNo
TAPISTR_10 CommodityNo
品种编号
Definition: TapAPICommDef.h:197
TAPISTR_300
char TAPISTR_300[301]
长度为300的字符串
Definition: TapAPICommDef.h:28
TAPIDTSTAMP
char TAPIDTSTAMP[24]
时间戳类型(格式 yyyy-MM-dd hh:nn:ss.xxx)
Definition: TapAPICommDef.h:92
生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: TapAPIError.h 文件参考

  • 文件列表
  • 文件成员
  • code
  • include
变量
TapAPIError.h 文件参考

浏览源代码.

变量

const int | TAPIERROR_SUCCEED = 0
const int | TAPIERROR_ConnectFail = -1
const int | TAPIERROR_LinkAuthFail = -2
const int | TAPIERROR_HostUnavailable = -3
const int | TAPIERROR_SendDataError = -4
const int | TAPIERROR_TestIDError = -5
const int | TAPIERROR_NotReadyTestNetwork = -6
const int | TAPIERROR_CurTestNotOver = -7
const int | TAPIERROR_NOFrontAvailable = -8
const int | TAPIERROR_DataPathAvaiable = -9
const int | TAPIERROR_RepeatLogin = -10
const int | TAPIERROR_InnerError = -11
const int | TAPIERROR_LastReqNotFinish = -12
const int | TAPIERROR_InputValueError = -13
const int | TAPIERROR_AuthCode_Invalid = -14
const int | TAPIERROR_AuthCode_Expired = -15
const int | TAPIERROR_AuthCode_TypeNotMatch = -16
const int | TAPIERROR_API_NotReady = -17
const int | TAPIERROR_UDP_LISTEN_FAILED = -18
const int | TAPIERROR_UDP_LISTENING = -19
const int | TAPIERROR_NotImplemented = -20
const int | TAPIERROR_CallOneTimeOnly = -21
const int | TAPIERROR_INPUTERROR_NULL = -10000
const int | TAPIERROR_INPUTERROR_TAPIYNFLAG = -10001
const int | TAPIERROR_INPUTERROR_TAPILOGLEVEL = -10002
const int | TAPIERROR_INPUTERROR_TAPICommodityType = -10003
const int | TAPIERROR_INPUTERROR_TAPICallOrPutFlagType = -10004
const int | TAPIERROR_DISCONNECT_CLOSE_INIT = 1
const int | TAPIERROR_DISCONNECT_CLOSE_PASS = 2
const int | TAPIERROR_DISCONNECT_READ_ERROR = 3
const int | TAPIERROR_DISCONNECT_WRITE_ERROR = 4
const int | TAPIERROR_DISCONNECT_BUF_FULL = 5
const int | TAPIERROR_DISCONNECT_IOCP_ERROR = 6
const int | TAPIERROR_DISCONNECT_PARSE_ERROR = 7
const int | TAPIERROR_DISCONNECT_CONNECT_TIMEOUT = 8
const int | TAPIERROR_DISCONNECT_INIT_ERROR = 9
const int | TAPIERROR_DISCONNECT_HAS_CONNECTED = 10
const int | TAPIERROR_DISCONNECT_HAS_EXIT = 11
const int | TAPIERROR_DISCONNECT_TRY_LATER = 12
const int | TAPIERROR_LOGIN = 10001
const int | TAPIERROR_LOGIN_USER = 10002
const int | TAPIERROR_LOGIN_DDA = 10003
const int | TAPIERROR_LOGIN_LICENSE = 10004
const int | TAPIERROR_LOGIN_MODULE = 10005
const int | TAPIERROR_LOGIN_STATE = 10007
const int | TAPIERROR_LOGIN_PASS = 10008
const int | TAPIERROR_LOGIN_RIGHT = 10009
const int | TAPIERROR_LOGIN_COUNT = 10010
const int | TAPIERROR_LOGIN_NOTIN_SERVERFLAGUSRES = 10011
const int | TAPIERROR_SUBSCRIBEQUOTE_MAX = 72001
const int | TAPIERROR_SUBSCRIBEQUOTE_EXCHANGE_MAX = 72002
const int | TAPIERROR_SUBSCRIBEQUOTE_NO_RIGHT = 72101
const int | TAPIERROR_SUBSCRIBEQUOTE_NO_EXCHANGE_RIGHT = 72102
const int | TAPIERROR_SUBSCRIBEQUOTE_COMMODITY_NOT_EXIST = 72103
const int | TAPIERROR_SUBSCRIBEQUOTE_CONTRACT_MAY_NOT_EXIST = 72104
生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: TapAPIError.h 源文件

  • 文件列表
  • 文件成员
  • code
  • include
TapAPIError.h
浏览该文件的文档.
1 #ifndef TAP_API_ERROR_H
2 #define TAP_API_ERROR_H
3
4 //=============================================================================
5 /**
6 * \addtogroup G_ERR_INNER_API TapAPI内部返回的错误码定义。
7 * @{
8 */
9 //=============================================================================
10 //! 成功
11 const int TAPIERROR_SUCCEED = 0;
12 //! 连接服务失败
13 const int TAPIERROR_ConnectFail = -1;
14 //! 链路认证失败
15 const int TAPIERROR_LinkAuthFail = -2;
16 //! 主机地址不可用
17 const int TAPIERROR_HostUnavailable = -3;
18 //! 发送数据错误
19 const int TAPIERROR_SendDataError = -4;
20 //! 测试编号不合法
21 const int TAPIERROR_TestIDError = -5;
22 //! 没准备好测试网络
23 const int TAPIERROR_NotReadyTestNetwork = -6;
24 //! 当前网络测试还没结束
25 const int TAPIERROR_CurTestNotOver = -7;
26 //! 没用可用的接入前置
27 const int TAPIERROR_NOFrontAvailable = -8;
28 //! 数据路径不可用
29 const int TAPIERROR_DataPathAvaiable = -9;
30 //! 重复登录
31 const int TAPIERROR_RepeatLogin = -10;
32 //! 内部错误
33 const int TAPIERROR_InnerError = -11;
34 //! 上一次请求还没有结束
35 const int TAPIERROR_LastReqNotFinish = -12;
36 //! 输入参数非法
37 const int TAPIERROR_InputValueError = -13;
38 //! 授权码不合法
39 const int TAPIERROR_AuthCode_Invalid = -14;
40 //! 授权码超期
41 const int TAPIERROR_AuthCode_Expired = -15;
42 //! 授权码类型不匹配
43 const int TAPIERROR_AuthCode_TypeNotMatch = -16;
44 //! API还没有准备好
45 const int TAPIERROR_API_NotReady = -17;
46 //! UDP端口监听失败
47 const int TAPIERROR_UDP_LISTEN_FAILED = -18;
48 //! UDP正在监听
49 const int TAPIERROR_UDP_LISTENING = -19;
50 //! 接口未实现
51 const int TAPIERROR_NotImplemented = -20;
52 //! 每次登陆只允许调用一次
53 const int TAPIERROR_CallOneTimeOnly = -21;
54
55 /** @}*/
56
57
58 //=============================================================================
59 /**
60 * \addtogroup G_ERR_INPUT_CHECK 输入参数检查错误
61 * @{
62 */
63 //=============================================================================
64 //! 输入数据为NULL
65 const int TAPIERROR_INPUTERROR_NULL = -10000;
66 //! 输入错误的:TAPIYNFLAG
67 const int TAPIERROR_INPUTERROR_TAPIYNFLAG = -10001;
68 //! 输入错误的:TAPILOGLEVEL
69 const int TAPIERROR_INPUTERROR_TAPILOGLEVEL = -10002;
70 //! 输入错误的:TAPICommodityType
71 const int TAPIERROR_INPUTERROR_TAPICommodityType = -10003;
72 //! 输入错误的:TAPICallOrPutFlagType
73 const int TAPIERROR_INPUTERROR_TAPICallOrPutFlagType = -10004;
74 /** @}*/
75
76 //=============================================================================
77 /**
78 * \addtogroup G_ERR_DISCONNECT_REASON 网络断开错误代码定义
79 * @{
80 */
81 //=============================================================================
82 //! 主动断开
83 const int TAPIERROR_DISCONNECT_CLOSE_INIT = 1;
84 //! 被动断开
85 const int TAPIERROR_DISCONNECT_CLOSE_PASS = 2;
86 //! 读错误
87 const int TAPIERROR_DISCONNECT_READ_ERROR = 3;
88 //! 写错误
89 const int TAPIERROR_DISCONNECT_WRITE_ERROR = 4;
90 //! 缓冲区满
91 const int TAPIERROR_DISCONNECT_BUF_FULL = 5;
92 //! 异步操作错误
93 const int TAPIERROR_DISCONNECT_IOCP_ERROR = 6;
94 //! 解析数据错误
95 const int TAPIERROR_DISCONNECT_PARSE_ERROR = 7;
96 //! 连接超时
97 const int TAPIERROR_DISCONNECT_CONNECT_TIMEOUT = 8;
98 //! 初始化失败
99 const int TAPIERROR_DISCONNECT_INIT_ERROR = 9;
100 //! 已经连接
101 const int TAPIERROR_DISCONNECT_HAS_CONNECTED = 10;
102 //! 工作线程已结束
103 const int TAPIERROR_DISCONNECT_HAS_EXIT = 11;
104 //! 操作正在进行，请稍后重试
105 const int TAPIERROR_DISCONNECT_TRY_LATER = 12;
106
107 /** @}*/
108
109 //=============================================================================
110 /**
111 * \addtogroup G_ERR_BUSINESS 业务返回的错误代码定义
112 * @{
113 */
114 //=============================================================================
115
116 //! 登录过程执行错误
117 const int TAPIERROR_LOGIN = 10001;
118 //! 登录用户不存在
119 const int TAPIERROR_LOGIN_USER = 10002;
120 //! 需要进行动态认证
121 const int TAPIERROR_LOGIN_DDA = 10003;
122 //! 登录用户未授权
123 const int TAPIERROR_LOGIN_LICENSE = 10004;
124 //! 登录模块不正确
125 const int TAPIERROR_LOGIN_MODULE = 10005;
126 //! 登录状态禁止登陆
127 const int TAPIERROR_LOGIN_STATE = 10007;
128 //! 登录密码不正确
129 const int TAPIERROR_LOGIN_PASS = 10008;
130 //! 没有该模块登录权限
131 const int TAPIERROR_LOGIN_RIGHT = 10009;
132 //! 登录数量超限
133 const int TAPIERROR_LOGIN_COUNT = 10010;
134 //! 登录用户不在服务器标识下可登录用户列表中
135 const int TAPIERROR_LOGIN_NOTIN_SERVERFLAGUSRES = 10011;
136 //! 超过行情最大总订阅数
137 const int TAPIERROR_SUBSCRIBEQUOTE_MAX = 72001;
138 //! 超过该交易所行情最大订阅数
139 const int TAPIERROR_SUBSCRIBEQUOTE_EXCHANGE_MAX = 72002;
140 //! 没有该行情的订阅权限
141 const int TAPIERROR_SUBSCRIBEQUOTE_NO_RIGHT = 72101;
142 //! 没有该交易所下行情的订阅权限
143 const int TAPIERROR_SUBSCRIBEQUOTE_NO_EXCHANGE_RIGHT = 72102;
144 //! 品种不存在
145 const int TAPIERROR_SUBSCRIBEQUOTE_COMMODITY_NOT_EXIST = 72103;
146 //! 合约可能不存在
147 const int TAPIERROR_SUBSCRIBEQUOTE_CONTRACT_MAY_NOT_EXIST = 72104;
148 /** @}*/
149
150
151 #endif //! TAP_API_ERROR_H
TAPIERROR_LOGIN_MODULE
const int TAPIERROR_LOGIN_MODULE
登录模块不正确
Definition: TapAPIError.h:125
TAPIERROR_DISCONNECT_BUF_FULL
const int TAPIERROR_DISCONNECT_BUF_FULL
缓冲区满
Definition: TapAPIError.h:91
TAPIERROR_DISCONNECT_CLOSE_INIT
const int TAPIERROR_DISCONNECT_CLOSE_INIT
主动断开
Definition: TapAPIError.h:83
TAPIERROR_INPUTERROR_TAPICallOrPutFlagType
const int TAPIERROR_INPUTERROR_TAPICallOrPutFlagType
输入错误的:TAPICallOrPutFlagType
Definition: TapAPIError.h:73
TAPIERROR_SUBSCRIBEQUOTE_EXCHANGE_MAX
const int TAPIERROR_SUBSCRIBEQUOTE_EXCHANGE_MAX
超过该交易所行情最大订阅数
Definition: TapAPIError.h:139
TAPIERROR_LinkAuthFail
const int TAPIERROR_LinkAuthFail
链路认证失败
Definition: TapAPIError.h:15
TAPIERROR_DISCONNECT_WRITE_ERROR
const int TAPIERROR_DISCONNECT_WRITE_ERROR
写错误
Definition: TapAPIError.h:89
TAPIERROR_NotReadyTestNetwork
const int TAPIERROR_NotReadyTestNetwork
没准备好测试网络
Definition: TapAPIError.h:23
TAPIERROR_RepeatLogin
const int TAPIERROR_RepeatLogin
重复登录
Definition: TapAPIError.h:31
TAPIERROR_LOGIN_NOTIN_SERVERFLAGUSRES
const int TAPIERROR_LOGIN_NOTIN_SERVERFLAGUSRES
登录用户不在服务器标识下可登录用户列表中
Definition: TapAPIError.h:135
TAPIERROR_SUBSCRIBEQUOTE_MAX
const int TAPIERROR_SUBSCRIBEQUOTE_MAX
超过行情最大总订阅数
Definition: TapAPIError.h:137
TAPIERROR_DISCONNECT_HAS_EXIT
const int TAPIERROR_DISCONNECT_HAS_EXIT
工作线程已结束
Definition: TapAPIError.h:103
TAPIERROR_LOGIN
const int TAPIERROR_LOGIN
登录过程执行错误
Definition: TapAPIError.h:117
TAPIERROR_DISCONNECT_READ_ERROR
const int TAPIERROR_DISCONNECT_READ_ERROR
读错误
Definition: TapAPIError.h:87
TAPIERROR_LOGIN_USER
const int TAPIERROR_LOGIN_USER
登录用户不存在
Definition: TapAPIError.h:119
TAPIERROR_LOGIN_RIGHT
const int TAPIERROR_LOGIN_RIGHT
没有该模块登录权限
Definition: TapAPIError.h:131
TAPIERROR_SUCCEED
const int TAPIERROR_SUCCEED
成功
Definition: TapAPIError.h:11
TAPIERROR_ConnectFail
const int TAPIERROR_ConnectFail
连接服务失败
Definition: TapAPIError.h:13
TAPIERROR_LOGIN_DDA
const int TAPIERROR_LOGIN_DDA
需要进行动态认证
Definition: TapAPIError.h:121
TAPIERROR_SUBSCRIBEQUOTE_COMMODITY_NOT_EXIST
const int TAPIERROR_SUBSCRIBEQUOTE_COMMODITY_NOT_EXIST
品种不存在
Definition: TapAPIError.h:145
TAPIERROR_DISCONNECT_INIT_ERROR
const int TAPIERROR_DISCONNECT_INIT_ERROR
初始化失败
Definition: TapAPIError.h:99
TAPIERROR_DISCONNECT_CONNECT_TIMEOUT
const int TAPIERROR_DISCONNECT_CONNECT_TIMEOUT
连接超时
Definition: TapAPIError.h:97
TAPIERROR_LOGIN_COUNT
const int TAPIERROR_LOGIN_COUNT
登录数量超限
Definition: TapAPIError.h:133
TAPIERROR_UDP_LISTEN_FAILED
const int TAPIERROR_UDP_LISTEN_FAILED
UDP端口监听失败
Definition: TapAPIError.h:47
TAPIERROR_AuthCode_Invalid
const int TAPIERROR_AuthCode_Invalid
授权码不合法
Definition: TapAPIError.h:39
TAPIERROR_CurTestNotOver
const int TAPIERROR_CurTestNotOver
当前网络测试还没结束
Definition: TapAPIError.h:25
TAPIERROR_InnerError
const int TAPIERROR_InnerError
内部错误
Definition: TapAPIError.h:33
TAPIERROR_LOGIN_PASS
const int TAPIERROR_LOGIN_PASS
登录密码不正确
Definition: TapAPIError.h:129
TAPIERROR_LastReqNotFinish
const int TAPIERROR_LastReqNotFinish
上一次请求还没有结束
Definition: TapAPIError.h:35
TAPIERROR_DISCONNECT_CLOSE_PASS
const int TAPIERROR_DISCONNECT_CLOSE_PASS
被动断开
Definition: TapAPIError.h:85
TAPIERROR_DISCONNECT_HAS_CONNECTED
const int TAPIERROR_DISCONNECT_HAS_CONNECTED
已经连接
Definition: TapAPIError.h:101
TAPIERROR_DataPathAvaiable
const int TAPIERROR_DataPathAvaiable
数据路径不可用
Definition: TapAPIError.h:29
TAPIERROR_LOGIN_STATE
const int TAPIERROR_LOGIN_STATE
登录状态禁止登陆
Definition: TapAPIError.h:127
TAPIERROR_UDP_LISTENING
const int TAPIERROR_UDP_LISTENING
UDP正在监听
Definition: TapAPIError.h:49
TAPIERROR_AuthCode_Expired
const int TAPIERROR_AuthCode_Expired
授权码超期
Definition: TapAPIError.h:41
TAPIERROR_DISCONNECT_PARSE_ERROR
const int TAPIERROR_DISCONNECT_PARSE_ERROR
解析数据错误
Definition: TapAPIError.h:95
TAPIERROR_AuthCode_TypeNotMatch
const int TAPIERROR_AuthCode_TypeNotMatch
授权码类型不匹配
Definition: TapAPIError.h:43
TAPIERROR_INPUTERROR_TAPIYNFLAG
const int TAPIERROR_INPUTERROR_TAPIYNFLAG
输入错误的:TAPIYNFLAG
Definition: TapAPIError.h:67
TAPIERROR_INPUTERROR_TAPICommodityType
const int TAPIERROR_INPUTERROR_TAPICommodityType
输入错误的:TAPICommodityType
Definition: TapAPIError.h:71
TAPIERROR_NOFrontAvailable
const int TAPIERROR_NOFrontAvailable
没用可用的接入前置
Definition: TapAPIError.h:27
TAPIERROR_CallOneTimeOnly
const int TAPIERROR_CallOneTimeOnly
每次登陆只允许调用一次
Definition: TapAPIError.h:53
TAPIERROR_NotImplemented
const int TAPIERROR_NotImplemented
接口未实现
Definition: TapAPIError.h:51
TAPIERROR_API_NotReady
const int TAPIERROR_API_NotReady
API还没有准备好
Definition: TapAPIError.h:45
TAPIERROR_DISCONNECT_IOCP_ERROR
const int TAPIERROR_DISCONNECT_IOCP_ERROR
异步操作错误
Definition: TapAPIError.h:93
TAPIERROR_InputValueError
const int TAPIERROR_InputValueError
输入参数非法
Definition: TapAPIError.h:37
TAPIERROR_SUBSCRIBEQUOTE_NO_RIGHT
const int TAPIERROR_SUBSCRIBEQUOTE_NO_RIGHT
没有该行情的订阅权限
Definition: TapAPIError.h:141
TAPIERROR_SUBSCRIBEQUOTE_CONTRACT_MAY_NOT_EXIST
const int TAPIERROR_SUBSCRIBEQUOTE_CONTRACT_MAY_NOT_EXIST
合约可能不存在
Definition: TapAPIError.h:147
TAPIERROR_LOGIN_LICENSE
const int TAPIERROR_LOGIN_LICENSE
登录用户未授权
Definition: TapAPIError.h:123
TAPIERROR_SUBSCRIBEQUOTE_NO_EXCHANGE_RIGHT
const int TAPIERROR_SUBSCRIBEQUOTE_NO_EXCHANGE_RIGHT
没有该交易所下行情的订阅权限
Definition: TapAPIError.h:143
TAPIERROR_HostUnavailable
const int TAPIERROR_HostUnavailable
主机地址不可用
Definition: TapAPIError.h:17
TAPIERROR_INPUTERROR_TAPILOGLEVEL
const int TAPIERROR_INPUTERROR_TAPILOGLEVEL
输入错误的:TAPILOGLEVEL
Definition: TapAPIError.h:69
TAPIERROR_SendDataError
const int TAPIERROR_SendDataError
发送数据错误
Definition: TapAPIError.h:19
TAPIERROR_DISCONNECT_TRY_LATER
const int TAPIERROR_DISCONNECT_TRY_LATER
操作正在进行，请稍后重试
Definition: TapAPIError.h:105
TAPIERROR_INPUTERROR_NULL
const int TAPIERROR_INPUTERROR_NULL
输入数据为NULL
Definition: TapAPIError.h:65
TAPIERROR_TestIDError
const int TAPIERROR_TestIDError
测试编号不合法
Definition: TapAPIError.h:21
生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: TapQuoteAPI.h 文件参考

  • 文件列表
  • 文件成员
  • code
  • include
类 | 宏定义 | 函数
TapQuoteAPI.h 文件参考
#include "TapQuoteAPIDataType.h"

浏览源代码.

类

class | ITapQuoteAPINotify
class | ITapQuoteAPI

宏定义

#define | TAP_CDECL
#define | TAP_DLLEXPORT

函数

TAP_DLLEXPORT ITapQuoteAPI
*TAP_CDECL 		CreateTapQuoteAPI (const TapAPIApplicationInfo *appInfo, TAPIINT32 &iResult)
TAP_DLLEXPORT void TAP_CDECL | FreeTapQuoteAPI (ITapQuoteAPI *apiObj)
TAP_DLLEXPORT const TAPICHAR
*TAP_CDECL 		GetTapQuoteAPIVersion ()
TAP_DLLEXPORT TAPIINT32 TAP_CDECL | SetTapQuoteAPIDataPath (const TAPICHAR *path)
TAP_DLLEXPORT TAPIINT32 TAP_CDECL | SetTapQuoteAPILogLevel (TAPILOGLEVEL level)

宏定义说明

#define TAP_CDECL
#define TAP_DLLEXPORT
生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: TapQuoteAPI.h 源文件

  • 文件列表
  • 文件成员
  • code
  • include
TapQuoteAPI.h
浏览该文件的文档.
1 #ifndef TAP_QUOTE_API_H
2 #define TAP_QUOTE_API_H
3
4 #include "TapQuoteAPIDataType.h"
5
6 #ifdef _WIN32
7 #define TAP_CDECL __cdecl
8 #define TAP_DLLEXPORT __declspec(dllexport)
9 #else
10 #define TAP_CDECL
11 #define TAP_DLLEXPORT
12 #endif
13
14 //TapQuoteAPI.h
15 //文件定义了TapQuoteAPI提供给开发者的对外接口、函数和回调接口。
16
17 //TapQuoteAPI 的回调通知接口。
18 class ITapQuoteAPINotify
19 {
20 public:
21 /**
22 * @brief 系统登录过程回调。
23 * @details 此函数为Login()登录函数的回调，调用Login()成功后建立了链路连接，然后API将向服务器发送登录认证信息，
24 * 登录期间的数据发送情况和登录的回馈信息传递到此回调函数中。
25 * @param[in] errorCode 返回错误码,0表示成功。
26 * @param[in] info 登陆应答信息，如果errorCode!=0，则info=NULL。
27 * @attention 该回调返回成功，说明用户登录成功。但是不代表API准备完毕。需要等到OnAPIReady才能进行查询与订阅请求。
28 * @ingroup G_Q_Login
29 */
30 virtual void TAP_CDECL OnRspLogin(TAPIINT32 errorCode, const TapAPIQuotLoginRspInfo *info) = 0;
31 /**
32 * @brief 通知用户API准备就绪。
33 * @details 只有用户回调收到此就绪通知时才能进行后续的各种行情数据查询操作。\n
34 * 此回调函数是API能否正常工作的标志。
35 * @attention 就绪后才可以进行后续正常操作
36 * @ingroup G_Q_Login
37 */
38 virtual void TAP_CDECL OnAPIReady() = 0;
39 /**
40 * @brief API和服务失去连接的回调
41 * @details 在API使用过程中主动或者被动与服务器服务失去连接后都会触发此回调通知用户与服务器的连接已经断开。
42 * @param[in] reasonCode 断开原因代码。具体原因请参见错误码列表 \n
43 * @ingroup G_Q_Disconnect
44 */
45 virtual void TAP_CDECL OnDisconnect(TAPIINT32 reasonCode) = 0;
46 /**
47 * @brief 返回所有品种信息。
48 * @details 此回调接口用于向用户返回得到的所有品种信息。
49 * @param[in] sessionID 请求的会话ID
50 * @param[in] errorCode 错误码，当errorCode!=0时,info为NULL；
51 * @param[in] isLast 标示是否是最后一批数据；
52 * @param[in] info 返回的信息数组的起始指针。
53 * @attention 不要修改和删除info所指示的数据；函数调用结束，参数不再有效。
54 * @ingroup G_Q_Commodity
55 */
56 virtual void TAP_CDECL OnRspQryCommodity(TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteCommodityInfo *info) = 0;
57 /**
58 * @brief 返回系统中合约信息
59 * @param[in] sessionID 请求的会话ID；
60 * @param[in] errorCode 错误码，当errorCode!=0时,info为NULL；
61 * @param[in] isLast 标示是否是最后一批数据；
62 * @param[in] info 指向返回的信息结构体。当errorCode不为0时，info为空。
63 * @attention 不要修改和删除info所指示的数据；函数调用结束，参数不再有效。
64 * @ingroup G_Q_Contract
65 */
66 virtual void TAP_CDECL OnRspQryContract(TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteContractInfo *info) = 0;
67 /**
68 * @brief 返回订阅行情的全文。
69 * @details 此回调接口用来返回订阅行情的全文。全文为当前时间的行情信息。
70 * @param[in] sessionID 请求的会话ID；
71 * @param[in] isLast 标示是否是最后一批数据；
72 * @param[in] errorCode 错误码，当errorCode!=0时,info为NULL；
73 * @param[in] info 指向返回的信息结构体。当errorCode不为0时，info为空。
74 * @attention 不要修改和删除info所指示的数据；函数调用结束，参数不再有效。
75 * @ingroup G_Q_Quote
76 */
77 virtual void TAP_CDECL OnRspSubscribeQuote(TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteWhole *info) = 0;
78 /**
79 * @brief 退订指定合约的行情的结果回调
80 * @param[in] sessionID 请求的会话ID；
81 * @param[in] errorCode 错误码，当errorCode!=0时,info为NULL；
82 * @param[in] isLast 标示是否是最后一批数据；
83 * @param[in] info 指向返回的信息结构体。当errorCode不为0时，info为空。
84 * @attention 不要修改和删除info所指示的数据；函数调用结束，参数不再有效。
85 * @ingroup G_Q_Quote
86 */
87 virtual void TAP_CDECL OnRspUnSubscribeQuote(TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIContract *info) = 0;
88 /**
89 * @brief 返回订阅行情的变化内容。
90 * @details 此回调接口用来通知用户行情信息产生了变化，并向用户提交新的行情全文。
91 * @param[in] info 最新的行情全文内容
92 * @attention 不要修改和删除Quote指示的数据；函数调用结束，参数不再有效。
93 * @ingroup G_Q_Quote
94 */
95 virtual void TAP_CDECL OnRtnQuote(const TapAPIQuoteWhole *info) = 0;
96 };
97
98 //TapQuoteAPI 对外功能接口。包含了用户可以调用的功能函数。
99 class ITapQuoteAPI
100 {
101 public:
102 /**
103 * @brief 设置API的回调接口对象。
104 * @details 系统对API的通知将通过设置的回调对象通知给使用者。
105 * ITapQuoteAPINofify是API的回调接口，用户需要继承实现此接口类对象来完成用户需要的功能。
106 * 如果用户没有设置回调接口，则API不会向用户返回任何有用的信息。\n
107 * ITapQuoteAPINotify类的详细内容请查看TapQuoteAPI.h 文件。
108 * @param[in] apiNotify 实现了ITapQuoteAPINotify接口的对象指针。
109 * @operationtype 同步操作
110 * @ingroup G_Q_Login
111 */
112 virtual TAPIINT32 TAP_CDECL SetAPINotify(ITapQuoteAPINotify *apiNotify) = 0;
113 /**
114 * @brief 设置服务器的IP地址和端口。等到调用Login时真正发起连接。
115 * @param[in] IP IP地址
116 * @param[in] port 端口号
117 * @operationtype 同步操作
118 * @ingroup G_Q_Login
119 */
120 virtual TAPIINT32 TAP_CDECL SetHostAddress(const TAPICHAR *IP, TAPIUINT16 port) = 0;
121 /**
122 * @brief 发起登录请求。API将先连接服务，建立链路，发起登录认证。
123 * @details 在使用函数函数前用户需要完成服务器的设置SetHostAddress()，并且创建TapAPIQuoteLoginAuth类型的用户信息，
124 * 并且需要设置好回调接口。\n
125 * 连接建立后的用户验证回馈信息通过回调OnLogin()返回给用户。\n
126 * 登录成功后API会自动进行API的初始化，API向服务器请求基础数据，查询完以后会通过回调OnAPIReady()
127 * 指示用户API初始化完成，可以进行后续的操作了。
128 * @param[in] loginAuth 登录验证信息结构指针。包含登录需要的验证信息。
129 * @retval 0 登录成功，API开始准备后台数据
130 * @retval 非0 错误码
131 * @attention 登录成功与否要根据OnLogin回调判断。
132 * @operationtype 异步操作
133 * @warning Login()函数调用成功只是代表于服务器建立了链路连接，只有回调OnLogin()的返回能指示用户是否成功登录了。
134 * @ingroup G_Q_Login
135 */
136 virtual TAPIINT32 TAP_CDECL Login(const TapAPIQuoteLoginAuth *loginAuth) = 0;
137 /**
138 * @brief 断开和服务器的链路连接。
139 * @details 调用函数后API将登出并断开与服务器的连接。
140 * @operationtype 异步操作
141 * @ingroup G_Q_Disconnect
142 */
143 virtual TAPIINT32 TAP_CDECL Disconnect() = 0;
144 /**
145 * @brief 得到所有品种
146 * @param[out] sessionID 返回请求的会话ID。
147 * @retval 0 请求成功
148 * @retval 非0 错误码
149 * @operationtype 异步操作
150 * @ingroup G_Q_Commodity
151 */
152 virtual TAPIINT32 TAP_CDECL QryCommodity(TAPIUINT32 *sessionID) = 0;
153 /**
154 * @brief 查询系统中指定品种的合约信息
155 * @details 使用此函数前需要先QryCommodity()取得品种信息，
156 * 然后选择需要的品种将信息填入TapAPICommodity结构体中完成查询请求。
157 * @param[out] sessionID 返回请求的会话ID;
158 * @param[in] qryReq 查询系统中指定品种的合约信息请求的结构体指针;\n
159 * 该参数各字段为可选字段，可以用以下方法查询：\n
160 * 1.全部留空：查所有合约\n
161 * 2.仅交易所编码有效：查该交易所下所有品种的合约\n
162 * 3.交易所编码和品种类型有效：查该交易所下指定品种类型的合约\n
163 * 4.交易所编码、品种类型和品种编码都有效：查该品种下的所有合约
164 * @retval 0 请求成功
165 * @retval 非0 错误码
166 * @operationtype 异步操作
167 * @ingroup G_Q_Contract
168 */
169 virtual TAPIINT32 TAP_CDECL QryContract(TAPIUINT32 *sessionID, const TapAPICommodity *qryReq) = 0;
170 /**
171 * @brief 订阅指定合约的行情
172 * @details 函数向服务器请求contract描述的合约的行情信息，行情订阅成功后服务器将持续向用户推送行情信息，
173 * 直到用户退订行情信息或者断开于服务器的通信。\n
174 * 调用此函数前先获取合约信息，然后从合约信息中取出合约填入contract。\n
175 * @param[out] sessionID 返回请求的会话ID。
176 * @param[in] contract 指定合约。
177 * @retval 0 请求成功
178 * @retval 非0 错误码
179 * @operationtype 异步操作
180 * @ingroup G_Q_Quote
181 */
182 virtual TAPIINT32 TAP_CDECL SubscribeQuote(TAPIUINT32 *sessionID, const TapAPIContract *contract) = 0;
183 /**
184 * @brief 退订指定合约的行情
185 * @details 退订已经订阅的行情信息。
186 * @param[out] sessionID 返回请求的会话ID；
187 * @param[in] contract 指定合约。
188 * @retval 0 请求成功
189 * @retval 非0 错误码
190 * @operationtype 异步操作
191 * @ingroup G_Q_Quote
192 */
193 virtual TAPIINT32 TAP_CDECL UnSubscribeQuote(TAPIUINT32 *sessionID, const TapAPIContract *contract) = 0;
194 };
195
196 //-----------------------------TapQuoteAPI导出函数------------------------------------
197
198
199 #ifdef __cplusplus
200 extern "C" {
201 #endif // __cplusplus
202
203 /**
204 * @brief 创建TapQuoteAPI的接口对象。
205 * @details 创建整个行情API的接口
206 * @param[in] appInfo 应用程序相关信息。
207 * @param[in] iResult 创建接口的错误码。
208 * @retval NULL 创建失败。
209 * @retval !NULL 实现了ITapQuoteAPI接口的对象指针。
210 * @ingroup G_Q_API
211 */
212 TAP_DLLEXPORT ITapQuoteAPI *TAP_CDECL CreateTapQuoteAPI(const TapAPIApplicationInfo *appInfo, TAPIINT32 &iResult);
213 /**
214 * @brief 销毁通过CreateTapQuoteAPI函数创建的ITapQuoteAPI对象。
215 * @param[in] apiObj ITapQuoteAPI对象指针。
216 * @ingroup G_Q_API
217 */
218 TAP_DLLEXPORT void TAP_CDECL FreeTapQuoteAPI(ITapQuoteAPI *apiObj);
219 /**
220 * @brief 获取TapQuoteAPI的版本信息
221 * @ingroup G_Q_API
222 */
223 TAP_DLLEXPORT const TAPICHAR *TAP_CDECL GetTapQuoteAPIVersion();
224 /**
225 * @brief 设置API自身保存数据目录
226 * @details 调用函数的同时会在path描述的目录下打开以年月日（格式TapQuoteAPI[YYYYMMDD].log)命名的文件，\n
227 * 没有此文件的情况下会试图创建此文件。\n
228 * 文件中保存的数据为API接收到的重要数据和API的使用和错误日志。
229 * @param[in] path 目录。必须可用，目录符号Window下为”\\”或者”/”, Linux下为”/”。
230 * @retval 0 成功
231 * @retval 非0 错误码
232 * @operationtype 同步操作
233 * @ingroup G_Q_LogConfig
234 */
235 TAP_DLLEXPORT TAPIINT32 TAP_CDECL SetTapQuoteAPIDataPath(const TAPICHAR *path);
236 /**
237 * @brief 设置API的日志级别
238 * @details 设定日志的输出级别，只有当实际日志级别与此处设定的级别相同或更高时，才会将日志写入SetTapQuoteAPIDataPath()函数打开的日志文件。\n
239 * @param[in] level 日志级别：\n
240 * APILOGLEVEL_NONE ：不记录日志\n
241 * APILOGLEVEL_ERROR ：记录Error日志\n
242 * APILOGLEVEL_WARNING ：记录Error和Warning日志\n
243 * APILOGLEVEL_DEBUG ：记录Error、Warning和Debug日志\n
244 * @retval 0 设定成功
245 * @retval 非0 错误码
246 * @operationtype 同步操作
247 * @ingroup G_Q_LogConfig
248 */
249 TAP_DLLEXPORT TAPIINT32 TAP_CDECL SetTapQuoteAPILogLevel(TAPILOGLEVEL level);
250
251 #ifdef __cplusplus
252 }
253 #endif // __cplusplus
254
255 #endif // TAP_QUOTE_API_H
TAPIINT32
int TAPIINT32
int 32
Definition: TapAPICommDef.h:51
ITapQuoteAPINotify::OnDisconnect
virtual void TAP_CDECL OnDisconnect(TAPIINT32 reasonCode)=0
API和服务失去连接的回调
TapAPIQuoteContractInfo
行情合约信息
Definition: TapQuoteAPIDataType.h:82
ITapQuoteAPI
Definition: TapQuoteAPI.h:99
SetTapQuoteAPILogLevel
TAP_DLLEXPORT TAPIINT32 TAP_CDECL SetTapQuoteAPILogLevel(TAPILOGLEVEL level)
设置API的日志级别
ITapQuoteAPINotify::OnRspLogin
virtual void TAP_CDECL OnRspLogin(TAPIINT32 errorCode, const TapAPIQuotLoginRspInfo *info)=0
系统登录过程回调。
ITapQuoteAPI::UnSubscribeQuote
virtual TAPIINT32 TAP_CDECL UnSubscribeQuote(TAPIUINT32 *sessionID, const TapAPIContract *contract)=0
退订指定合约的行情
ITapQuoteAPI::Disconnect
virtual TAPIINT32 TAP_CDECL Disconnect()=0
断开和服务器的链路连接。
TAPIUINT32
unsigned int TAPIUINT32
unsigned 32
Definition: TapAPICommDef.h:53
TAP_CDECL
#define TAP_CDECL
Definition: TapQuoteAPI.h:10
ITapQuoteAPINotify::OnRspQryCommodity
virtual void TAP_CDECL OnRspQryCommodity(TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteCommodityInfo *info)=0
返回所有品种信息。
TAPIYNFLAG
TAPICHAR TAPIYNFLAG
是否标示
Definition: TapAPICommDef.h:74
TapAPIQuotLoginRspInfo
登录反馈信息
Definition: TapQuoteAPIDataType.h:46
ITapQuoteAPI::QryCommodity
virtual TAPIINT32 TAP_CDECL QryCommodity(TAPIUINT32 *sessionID)=0
得到所有品种
ITapQuoteAPI::SubscribeQuote
virtual TAPIINT32 TAP_CDECL SubscribeQuote(TAPIUINT32 *sessionID, const TapAPIContract *contract)=0
订阅指定合约的行情
FreeTapQuoteAPI
TAP_DLLEXPORT void TAP_CDECL FreeTapQuoteAPI(ITapQuoteAPI *apiObj)
销毁通过CreateTapQuoteAPI函数创建的ITapQuoteAPI对象。
TapAPIQuoteCommodityInfo
品种信息
Definition: TapQuoteAPIDataType.h:65
ITapQuoteAPI::QryContract
virtual TAPIINT32 TAP_CDECL QryContract(TAPIUINT32 *sessionID, const TapAPICommodity *qryReq)=0
查询系统中指定品种的合约信息
ITapQuoteAPINotify::OnRspUnSubscribeQuote
virtual void TAP_CDECL OnRspUnSubscribeQuote(TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIContract *info)=0
退订指定合约的行情的结果回调
TAPICHAR
char TAPICHAR
单字符定义，可用于定义其他类型
Definition: TapAPICommDef.h:39
TAPILOGLEVEL
TAPICHAR TAPILOGLEVEL
日志级别
Definition: TapAPICommDef.h:108
GetTapQuoteAPIVersion
TAP_DLLEXPORT const TAPICHAR *TAP_CDECL GetTapQuoteAPIVersion()
获取TapQuoteAPI的版本信息
ITapQuoteAPINotify::OnAPIReady
virtual void TAP_CDECL OnAPIReady()=0
通知用户API准备就绪。
ITapQuoteAPINotify::OnRspQryContract
virtual void TAP_CDECL OnRspQryContract(TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteContractInfo *info)=0
返回系统中合约信息
TAPIUINT16
unsigned short TAPIUINT16
unsigned 16
Definition: TapAPICommDef.h:59
ITapQuoteAPI::SetAPINotify
virtual TAPIINT32 TAP_CDECL SetAPINotify(ITapQuoteAPINotify *apiNotify)=0
设置API的回调接口对象。
TapAPICommodity
品种编码结构
Definition: TapAPICommDef.h:193
TapAPIQuoteLoginAuth
登录认证信息
Definition: TapQuoteAPIDataType.h:34
ITapQuoteAPINotify::OnRtnQuote
virtual void TAP_CDECL OnRtnQuote(const TapAPIQuoteWhole *info)=0
返回订阅行情的变化内容。
SetTapQuoteAPIDataPath
TAP_DLLEXPORT TAPIINT32 TAP_CDECL SetTapQuoteAPIDataPath(const TAPICHAR *path)
设置API自身保存数据目录
TapAPIQuoteWhole
行情全文
Definition: TapQuoteAPIDataType.h:94
TapQuoteAPIDataType.h
ITapQuoteAPINotify
Definition: TapQuoteAPI.h:18
ITapQuoteAPINotify::OnRspSubscribeQuote
virtual void TAP_CDECL OnRspSubscribeQuote(TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteWhole *info)=0
返回订阅行情的全文。
TAP_DLLEXPORT
#define TAP_DLLEXPORT
Definition: TapQuoteAPI.h:11
ITapQuoteAPI::SetHostAddress
virtual TAPIINT32 TAP_CDECL SetHostAddress(const TAPICHAR *IP, TAPIUINT16 port)=0
设置服务器的IP地址和端口。等到调用Login时真正发起连接。
TapAPIApplicationInfo
Application信息
Definition: TapAPICommDef.h:185
ITapQuoteAPI::Login
virtual TAPIINT32 TAP_CDECL Login(const TapAPIQuoteLoginAuth *loginAuth)=0
发起登录请求。API将先连接服务，建立链路，发起登录认证。
TapAPIContract
合约编码结构
Definition: TapAPICommDef.h:201
CreateTapQuoteAPI
TAP_DLLEXPORT ITapQuoteAPI *TAP_CDECL CreateTapQuoteAPI(const TapAPIApplicationInfo *appInfo, TAPIINT32 &iResult)
创建TapQuoteAPI的接口对象。
生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: TapQuoteAPIDataType.h 文件参考

  • 文件列表
  • 文件成员
  • code
  • include
类 | 类型定义
TapQuoteAPIDataType.h 文件参考
#include "TapAPICommDef.h"

浏览源代码.

类

struct | TapAPIQuoteLoginAuth
struct | TapAPIQuotLoginRspInfo
struct | TapAPIQuoteCommodityInfo
struct | TapAPIQuoteContractInfo
struct | TapAPIQuoteWhole

类型定义

typedef TAPIREAL64 | TAPIQPRICE
typedef TAPIUINT64 | TAPIQVOLUME
typedef TAPIINT64 | TAPIQDIFF
生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: TapQuoteAPIDataType.h 源文件

  • 文件列表
  • 文件成员
  • code
  • include
TapQuoteAPIDataType.h
浏览该文件的文档.
1 #ifndef TAP_QUOTE_API_DATA_TYPE_H
2 #define TAP_QUOTE_API_DATA_TYPE_H
3 //该文件定义了TapQuoteAPI 使用的数据类型和数据结构
4
5 #include "TapAPICommDef.h"
6
7 #pragma pack(push, 1)
8
9 //=============================================================================
10 /**
11 * \addtogroup G_DATATYPE_Q_BASIC 行情基本类型
12 * @{
13 */
14 //=============================================================================
15
16 //! 行情价格
17 typedef TAPIREAL64 TAPIQPRICE;
18 //! 行情量
19 typedef TAPIUINT64 TAPIQVOLUME;
20 //! 变化值
21 typedef TAPIINT64 TAPIQDIFF;
22
23 /** @}*/
24
25
26 //=============================================================================
27 /**
28 * \addtogroup G_STRUCT_Q 行情结构体定义
29 * @{
30 */
31 //=============================================================================
32
33 //! 登录认证信息
34 struct TapAPIQuoteLoginAuth
35 {
36 TAPISTR_20 UserNo; ///< 用户名
37 TAPIYNFLAG ISModifyPassword; ///< 是否修改密码，'Y'表示是，'N'表示否
38 TAPISTR_20 Password; ///< 用户密码
39 TAPISTR_20 NewPassword; ///< 新密码，如果设置了修改密码则需要填写此字段
40 TAPISTR_20 QuoteTempPassword; ///< 行情临时密码
41 TAPIYNFLAG ISDDA; ///< 是否需呀动态认证，'Y'表示是，'N'表示否
42 TAPISTR_30 DDASerialNo; ///< 动态认证码
43 };
44
45 //! 登录反馈信息
46 struct TapAPIQuotLoginRspInfo
47 {
48 TAPISTR_20 UserNo; ///< 用户名
49 TAPIINT32 UserType; ///< 用户类型
50 TAPISTR_20 UserName; ///< 昵称，GBK编码格式
51 TAPISTR_20 QuoteTempPassword; ///< 行情临时密码
52 TAPISTR_50 ReservedInfo; ///< 用户自己设置的预留信息
53 TAPISTR_40 LastLoginIP; ///< 上次登录的地址
54 TAPIUINT32 LastLoginProt; ///< 上次登录使用的端口
55 TAPIDATETIME LastLoginTime; ///< 上次登录的时间
56 TAPIDATETIME LastLogoutTime; ///< 上次退出的时间
57 TAPIDATE TradeDate; ///< 当前交易日期
58 TAPIDATETIME LastSettleTime; ///< 上次结算时间
59 TAPIDATETIME StartTime; ///< 系统启动时间
60 TAPIDATETIME InitTime; ///< 系统初始化时间
61 };
62
63
64 //! 品种信息
65 struct TapAPIQuoteCommodityInfo
66 {
67 TapAPICommodity Commodity; ///< 品种
68 TAPISTR_20 CommodityName; ///< 品种名称,GBK编码格式
69 TAPISTR_30 CommodityEngName; ///< 品种英文名称
70 TAPIREAL64 ContractSize; ///< 每手乘数
71 TAPIREAL64 CommodityTickSize; ///< 最小变动价位
72 TAPIINT32 CommodityDenominator; ///< 报价分母
73 TAPICHAR CmbDirect; ///< 组合方向
74 TAPIINT32 CommodityContractLen; ///< 品种合约年限
75 TAPIYNFLAG IsDST; ///< 是否夏令时,'Y'为是,'N'为否
76 TapAPICommodity RelateCommodity1; ///< 关联品种1
77 TapAPICommodity RelateCommodity2; ///< 关联品种2
78 };
79
80
81 //! 行情合约信息
82 struct TapAPIQuoteContractInfo
83 {
84 TapAPIContract Contract; ///< 合约
85 TAPICHAR ContractType; ///< 合约类型,'1'表示交易行情合约,'2'表示行情合约
86 TAPISTR_10 QuoteUnderlyingContract; ///< 行情真实合约
87 TAPISTR_70 ContractName; ///< 合约名称
88 TAPIDATE ContractExpDate; ///< 合约到期日
89 TAPIDATE LastTradeDate; ///< 最后交易日
90 TAPIDATE FirstNoticeDate; ///< 首次通知日
91 };
92
93 //! 行情全文
94 struct TapAPIQuoteWhole
95 {
96 TapAPIContract Contract; ///< 合约
97 TAPISTR_10 CurrencyNo; ///< 币种编号
98 TAPICHAR TradingState; ///< 交易状态。1,集合竞价;2,集合竞价撮合;3,连续交易;4,交易暂停;5,闭市
99 TAPIDTSTAMP DateTimeStamp; ///< 时间戳
100 TAPIQPRICE QPreClosingPrice; ///< 昨收盘价
101 TAPIQPRICE QPreSettlePrice; ///< 昨结算价
102 TAPIQVOLUME QPrePositionQty; ///< 昨持仓量
103 TAPIQPRICE QOpeningPrice; ///< 开盘价
104 TAPIQPRICE QLastPrice; ///< 最新价
105 TAPIQPRICE QHighPrice; ///< 最高价
106 TAPIQPRICE QLowPrice; ///< 最低价
107 TAPIQPRICE QHisHighPrice; ///< 历史最高价
108 TAPIQPRICE QHisLowPrice; ///< 历史最低价
109 TAPIQPRICE QLimitUpPrice; ///< 涨停价
110 TAPIQPRICE QLimitDownPrice; ///< 跌停价
111 TAPIQVOLUME QTotalQty; ///< 当日总成交量
112 TAPIQPRICE QTotalTurnover; ///< 当日成交金额
113 TAPIQVOLUME QPositionQty; ///< 持仓量
114 TAPIQPRICE QAveragePrice; ///< 均价
115 TAPIQPRICE QClosingPrice; ///< 收盘价
116 TAPIQPRICE QSettlePrice; ///< 结算价
117 TAPIQVOLUME QLastQty; ///< 最新成交量
118 TAPIQPRICE QBidPrice[20]; ///< 买价1-20档
119 TAPIQVOLUME QBidQty[20]; ///< 买量1-20档
120 TAPIQPRICE QAskPrice[20]; ///< 卖价1-20档
121 TAPIQVOLUME QAskQty[20]; ///< 卖量1-20档
122 TAPIQPRICE QImpliedBidPrice; ///< 隐含买价
123 TAPIQVOLUME QImpliedBidQty; ///< 隐含买量
124 TAPIQPRICE QImpliedAskPrice; ///< 隐含卖价
125 TAPIQVOLUME QImpliedAskQty; ///< 隐含卖量
126 TAPIQPRICE QPreDelta; ///< 昨虚实度
127 TAPIQPRICE QCurrDelta; ///< 今虚实度
128 TAPIQVOLUME QInsideQty; ///< 内盘量
129 TAPIQVOLUME QOutsideQty; ///< 外盘量
130 TAPIQPRICE QTurnoverRate; ///< 换手率
131 TAPIQVOLUME Q5DAvgQty; ///< 五日均量
132 TAPIQPRICE QPERatio; ///< 市盈率
133 TAPIQPRICE QTotalValue; ///< 总市值
134 TAPIQPRICE QNegotiableValue; ///< 流通市值
135 TAPIQDIFF QPositionTrend; ///< 持仓走势
136 TAPIQPRICE QChangeSpeed; ///< 涨速
137 TAPIQPRICE QChangeRate; ///< 涨幅
138 TAPIQPRICE QChangeValue; ///< 涨跌值
139 TAPIQPRICE QSwing; ///< 振幅
140 TAPIQVOLUME QTotalBidQty; ///< 委买总量
141 TAPIQVOLUME QTotalAskQty; ///< 委卖总量
142 };
143
144
145 /** @}*/
146
147
148
149
150
151 #pragma pack(pop)
152
153 #endif
TapAPIQuoteWhole::QTotalQty
TAPIQVOLUME QTotalQty
当日总成交量
Definition: TapQuoteAPIDataType.h:111
TAPISTR_40
char TAPISTR_40[41]
长度为40的字符串
Definition: TapAPICommDef.h:20
TapAPIQuoteCommodityInfo::CmbDirect
TAPICHAR CmbDirect
组合方向
Definition: TapQuoteAPIDataType.h:73
TAPIQPRICE
TAPIREAL64 TAPIQPRICE
行情价格
Definition: TapQuoteAPIDataType.h:17
TAPIINT32
int TAPIINT32
int 32
Definition: TapAPICommDef.h:51
TapAPIQuoteCommodityInfo::CommodityEngName
TAPISTR_30 CommodityEngName
品种英文名称
Definition: TapQuoteAPIDataType.h:69
TapAPIQuoteWhole::QChangeValue
TAPIQPRICE QChangeValue
涨跌值
Definition: TapQuoteAPIDataType.h:138
TapAPIQuoteLoginAuth::NewPassword
TAPISTR_20 NewPassword
新密码，如果设置了修改密码则需要填写此字段
Definition: TapQuoteAPIDataType.h:39
TAPIUINT64
unsigned long long TAPIUINT64
unsigned 64
Definition: TapAPICommDef.h:57
TapAPIQuoteWhole::QSwing
TAPIQPRICE QSwing
振幅
Definition: TapQuoteAPIDataType.h:139
TapAPIQuoteContractInfo
行情合约信息
Definition: TapQuoteAPIDataType.h:82
TAPIREAL64
double TAPIREAL64
real 64
Definition: TapAPICommDef.h:63
TapAPIQuotLoginRspInfo::UserName
TAPISTR_20 UserName
昵称，GBK编码格式
Definition: TapQuoteAPIDataType.h:50
TapAPIQuotLoginRspInfo::LastLoginIP
TAPISTR_40 LastLoginIP
上次登录的地址
Definition: TapQuoteAPIDataType.h:53
TapAPIQuotLoginRspInfo::LastLoginProt
TAPIUINT32 LastLoginProt
上次登录使用的端口
Definition: TapQuoteAPIDataType.h:54
TAPISTR_30
char TAPISTR_30[31]
长度为30的字符串
Definition: TapAPICommDef.h:18
TapAPIQuoteWhole::QChangeRate
TAPIQPRICE QChangeRate
涨幅
Definition: TapQuoteAPIDataType.h:137
TapAPIQuotLoginRspInfo::InitTime
TAPIDATETIME InitTime
系统初始化时间
Definition: TapQuoteAPIDataType.h:60
TapAPIQuoteWhole::QHisHighPrice
TAPIQPRICE QHisHighPrice
历史最高价
Definition: TapQuoteAPIDataType.h:107
TapAPIQuoteWhole::QAskQty
TAPIQVOLUME QAskQty[20]
卖量1-20档
Definition: TapQuoteAPIDataType.h:121
TapAPIQuotLoginRspInfo::LastLogoutTime
TAPIDATETIME LastLogoutTime
上次退出的时间
Definition: TapQuoteAPIDataType.h:56
TapAPIQuoteCommodityInfo::CommodityName
TAPISTR_20 CommodityName
品种名称,GBK编码格式
Definition: TapQuoteAPIDataType.h:68
TapAPIQuoteWhole::QImpliedAskQty
TAPIQVOLUME QImpliedAskQty
隐含卖量
Definition: TapQuoteAPIDataType.h:125
TapAPIQuoteCommodityInfo::RelateCommodity2
TapAPICommodity RelateCommodity2
关联品种2
Definition: TapQuoteAPIDataType.h:77
TapAPIQuoteWhole::QPERatio
TAPIQPRICE QPERatio
市盈率
Definition: TapQuoteAPIDataType.h:132
TapAPIQuoteWhole::QLimitUpPrice
TAPIQPRICE QLimitUpPrice
涨停价
Definition: TapQuoteAPIDataType.h:109
TapAPIQuotLoginRspInfo::StartTime
TAPIDATETIME StartTime
系统启动时间
Definition: TapQuoteAPIDataType.h:59
TAPIUINT32
unsigned int TAPIUINT32
unsigned 32
Definition: TapAPICommDef.h:53
TAPIINT64
long long TAPIINT64
int 64
Definition: TapAPICommDef.h:55
TapAPIQuoteWhole::QTotalTurnover
TAPIQPRICE QTotalTurnover
当日成交金额
Definition: TapQuoteAPIDataType.h:112
TAPIYNFLAG
TAPICHAR TAPIYNFLAG
是否标示
Definition: TapAPICommDef.h:74
TapAPIQuoteCommodityInfo::IsDST
TAPIYNFLAG IsDST
是否夏令时,'Y'为是,'N'为否
Definition: TapQuoteAPIDataType.h:75
TapAPIQuotLoginRspInfo::ReservedInfo
TAPISTR_50 ReservedInfo
用户自己设置的预留信息
Definition: TapQuoteAPIDataType.h:52
TapAPIQuotLoginRspInfo
登录反馈信息
Definition: TapQuoteAPIDataType.h:46
TapAPIQuoteWhole::QImpliedAskPrice
TAPIQPRICE QImpliedAskPrice
隐含卖价
Definition: TapQuoteAPIDataType.h:124
TapAPIQuoteLoginAuth::UserNo
TAPISTR_20 UserNo
用户名
Definition: TapQuoteAPIDataType.h:36
TapAPIQuoteCommodityInfo::RelateCommodity1
TapAPICommodity RelateCommodity1
关联品种1
Definition: TapQuoteAPIDataType.h:76
TapAPIQuoteWhole::QLowPrice
TAPIQPRICE QLowPrice
最低价
Definition: TapQuoteAPIDataType.h:106
TapAPIQuoteCommodityInfo::CommodityTickSize
TAPIREAL64 CommodityTickSize
最小变动价位
Definition: TapQuoteAPIDataType.h:71
TapAPIQuoteWhole::QLimitDownPrice
TAPIQPRICE QLimitDownPrice
跌停价
Definition: TapQuoteAPIDataType.h:110
TapAPIQuoteCommodityInfo::Commodity
TapAPICommodity Commodity
品种
Definition: TapQuoteAPIDataType.h:67
TapAPIQuoteCommodityInfo
品种信息
Definition: TapQuoteAPIDataType.h:65
TAPIQDIFF
TAPIINT64 TAPIQDIFF
变化值
Definition: TapQuoteAPIDataType.h:21
TapAPIQuoteWhole::QBidQty
TAPIQVOLUME QBidQty[20]
买量1-20档
Definition: TapQuoteAPIDataType.h:119
TapAPIQuoteWhole::QCurrDelta
TAPIQPRICE QCurrDelta
今虚实度
Definition: TapQuoteAPIDataType.h:127
TapAPIQuoteWhole::Q5DAvgQty
TAPIQVOLUME Q5DAvgQty
五日均量
Definition: TapQuoteAPIDataType.h:131
TAPISTR_20
char TAPISTR_20[21]
长度为20的字符串
Definition: TapAPICommDef.h:16
TapAPIQuoteContractInfo::QuoteUnderlyingContract
TAPISTR_10 QuoteUnderlyingContract
行情真实合约
Definition: TapQuoteAPIDataType.h:86
TAPISTR_10
char TAPISTR_10[11]
长度为10的字符串
Definition: TapAPICommDef.h:14
TapAPIQuoteWhole::QImpliedBidQty
TAPIQVOLUME QImpliedBidQty
隐含买量
Definition: TapQuoteAPIDataType.h:123
TapAPIQuoteContractInfo::FirstNoticeDate
TAPIDATE FirstNoticeDate
首次通知日
Definition: TapQuoteAPIDataType.h:90
TapAPIQuoteWhole::QPositionQty
TAPIQVOLUME QPositionQty
持仓量
Definition: TapQuoteAPIDataType.h:113
TapAPIQuoteWhole::DateTimeStamp
TAPIDTSTAMP DateTimeStamp
时间戳
Definition: TapQuoteAPIDataType.h:99
TapAPIQuoteContractInfo::ContractName
TAPISTR_70 ContractName
合约名称
Definition: TapQuoteAPIDataType.h:87
TapAPIQuoteWhole::QOutsideQty
TAPIQVOLUME QOutsideQty
外盘量
Definition: TapQuoteAPIDataType.h:129
TapAPIQuoteWhole::CurrencyNo
TAPISTR_10 CurrencyNo
币种编号
Definition: TapQuoteAPIDataType.h:97
TapAPIQuoteWhole::QAskPrice
TAPIQPRICE QAskPrice[20]
卖价1-20档
Definition: TapQuoteAPIDataType.h:120
TapAPIQuoteWhole::QAveragePrice
TAPIQPRICE QAveragePrice
均价
Definition: TapQuoteAPIDataType.h:114
TAPICHAR
char TAPICHAR
单字符定义，可用于定义其他类型
Definition: TapAPICommDef.h:39
TapAPIQuoteContractInfo::LastTradeDate
TAPIDATE LastTradeDate
最后交易日
Definition: TapQuoteAPIDataType.h:89
TapAPIQuoteContractInfo::Contract
TapAPIContract Contract
合约
Definition: TapQuoteAPIDataType.h:84
TapAPIQuoteWhole::QBidPrice
TAPIQPRICE QBidPrice[20]
买价1-20档
Definition: TapQuoteAPIDataType.h:118
TapAPIQuoteWhole::TradingState
TAPICHAR TradingState
交易状态。1,集合竞价;2,集合竞价撮合;3,连续交易;4,交易暂停;5,闭市
Definition: TapQuoteAPIDataType.h:98
TapAPIQuoteWhole::QNegotiableValue
TAPIQPRICE QNegotiableValue
流通市值
Definition: TapQuoteAPIDataType.h:134
TapAPIQuoteWhole::QImpliedBidPrice
TAPIQPRICE QImpliedBidPrice
隐含买价
Definition: TapQuoteAPIDataType.h:122
TapAPIQuoteWhole::QLastQty
TAPIQVOLUME QLastQty
最新成交量
Definition: TapQuoteAPIDataType.h:117
TapAPICommodity
品种编码结构
Definition: TapAPICommDef.h:193
TapAPIQuoteLoginAuth::DDASerialNo
TAPISTR_30 DDASerialNo
动态认证码
Definition: TapQuoteAPIDataType.h:42
TapAPIQuoteLoginAuth
登录认证信息
Definition: TapQuoteAPIDataType.h:34
TapAPIQuoteWhole::QPositionTrend
TAPIQDIFF QPositionTrend
持仓走势
Definition: TapQuoteAPIDataType.h:135
TapAPIQuoteWhole::QTurnoverRate
TAPIQPRICE QTurnoverRate
换手率
Definition: TapQuoteAPIDataType.h:130
TapAPIQuotLoginRspInfo::UserNo
TAPISTR_20 UserNo
用户名
Definition: TapQuoteAPIDataType.h:48
TapAPIQuoteWhole::QHighPrice
TAPIQPRICE QHighPrice
最高价
Definition: TapQuoteAPIDataType.h:105
TapAPIQuoteLoginAuth::ISModifyPassword
TAPIYNFLAG ISModifyPassword
是否修改密码，'Y'表示是，'N'表示否
Definition: TapQuoteAPIDataType.h:37
TAPIDATE
char TAPIDATE[11]
日期类型(格式 yyyy-MM-dd)
Definition: TapAPICommDef.h:96
TapAPIQuoteWhole::QLastPrice
TAPIQPRICE QLastPrice
最新价
Definition: TapQuoteAPIDataType.h:104
TapAPIQuoteWhole::QPreSettlePrice
TAPIQPRICE QPreSettlePrice
昨结算价
Definition: TapQuoteAPIDataType.h:101
TapAPIQuoteCommodityInfo::CommodityContractLen
TAPIINT32 CommodityContractLen
品种合约年限
Definition: TapQuoteAPIDataType.h:74
TapAPIQuotLoginRspInfo::QuoteTempPassword
TAPISTR_20 QuoteTempPassword
行情临时密码
Definition: TapQuoteAPIDataType.h:51
TapAPIQuoteWhole::QTotalValue
TAPIQPRICE QTotalValue
总市值
Definition: TapQuoteAPIDataType.h:133
TapAPIQuoteLoginAuth::QuoteTempPassword
TAPISTR_20 QuoteTempPassword
行情临时密码
Definition: TapQuoteAPIDataType.h:40
TapAPIQuoteWhole::QPreDelta
TAPIQPRICE QPreDelta
昨虚实度
Definition: TapQuoteAPIDataType.h:126
TapAPIQuoteWhole
行情全文
Definition: TapQuoteAPIDataType.h:94
TapAPIQuoteWhole::QChangeSpeed
TAPIQPRICE QChangeSpeed
涨速
Definition: TapQuoteAPIDataType.h:136
TapAPIQuoteWhole::QClosingPrice
TAPIQPRICE QClosingPrice
收盘价
Definition: TapQuoteAPIDataType.h:115
TAPIQVOLUME
TAPIUINT64 TAPIQVOLUME
行情量
Definition: TapQuoteAPIDataType.h:19
TAPISTR_70
char TAPISTR_70[71]
长度为70的字符串
Definition: TapAPICommDef.h:24
TapAPIQuoteWhole::QHisLowPrice
TAPIQPRICE QHisLowPrice
历史最低价
Definition: TapQuoteAPIDataType.h:108
TapAPIQuoteWhole::QPreClosingPrice
TAPIQPRICE QPreClosingPrice
昨收盘价
Definition: TapQuoteAPIDataType.h:100
TapAPIQuoteContractInfo::ContractExpDate
TAPIDATE ContractExpDate
合约到期日
Definition: TapQuoteAPIDataType.h:88
TapAPIQuotLoginRspInfo::LastSettleTime
TAPIDATETIME LastSettleTime
上次结算时间
Definition: TapQuoteAPIDataType.h:58
TapAPIQuoteWhole::QTotalAskQty
TAPIQVOLUME QTotalAskQty
委卖总量
Definition: TapQuoteAPIDataType.h:141
TapAPIQuoteWhole::QSettlePrice
TAPIQPRICE QSettlePrice
结算价
Definition: TapQuoteAPIDataType.h:116
TapAPIQuotLoginRspInfo::TradeDate
TAPIDATE TradeDate
当前交易日期
Definition: TapQuoteAPIDataType.h:57
TapAPIQuoteCommodityInfo::CommodityDenominator
TAPIINT32 CommodityDenominator
报价分母
Definition: TapQuoteAPIDataType.h:72
TapAPIQuotLoginRspInfo::UserType
TAPIINT32 UserType
用户类型
Definition: TapQuoteAPIDataType.h:49
TapAPIContract
合约编码结构
Definition: TapAPICommDef.h:201
TapAPIQuoteWhole::QInsideQty
TAPIQVOLUME QInsideQty
内盘量
Definition: TapQuoteAPIDataType.h:128
TapAPIQuoteContractInfo::ContractType
TAPICHAR ContractType
合约类型,'1'表示交易行情合约,'2'表示行情合约
Definition: TapQuoteAPIDataType.h:85
TapAPIQuoteCommodityInfo::ContractSize
TAPIREAL64 ContractSize
每手乘数
Definition: TapQuoteAPIDataType.h:70
TAPIDATETIME
char TAPIDATETIME[20]
日期和时间类型(格式 yyyy-MM-dd hh:nn:ss)
Definition: TapAPICommDef.h:94
TapAPIQuoteWhole::Contract
TapAPIContract Contract
合约
Definition: TapQuoteAPIDataType.h:96
TapAPIQuoteWhole::QOpeningPrice
TAPIQPRICE QOpeningPrice
开盘价
Definition: TapQuoteAPIDataType.h:103
TapAPIQuoteLoginAuth::ISDDA
TAPIYNFLAG ISDDA
是否需呀动态认证，'Y'表示是，'N'表示否
Definition: TapQuoteAPIDataType.h:41
TapAPIQuoteWhole::QPrePositionQty
TAPIQVOLUME QPrePositionQty
昨持仓量
Definition: TapQuoteAPIDataType.h:102
TapAPICommDef.h
TAPISTR_50
char TAPISTR_50[51]
长度为50的字符串
Definition: TapAPICommDef.h:22
TapAPIQuotLoginRspInfo::LastLoginTime
TAPIDATETIME LastLoginTime
上次登录的时间
Definition: TapQuoteAPIDataType.h:55
TapAPIQuoteLoginAuth::Password
TAPISTR_20 Password
用户密码
Definition: TapQuoteAPIDataType.h:38
TapAPIQuoteWhole::QTotalBidQty
TAPIQVOLUME QTotalBidQty
委买总量
Definition: TapQuoteAPIDataType.h:140
TAPIDTSTAMP
char TAPIDTSTAMP[24]
时间戳类型(格式 yyyy-MM-dd hh:nn:ss.xxx)
Definition: TapAPICommDef.h:92
生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: 类列表

  • 类列表
  • 类索引
  • 类成员
类列表
这里列出了所有类、结构、联合以及接口定义等，并附带简要说明:
o C ITapQuoteAPI |
o C ITapQuoteAPINotify |
o C TapAPIApplicationInfo | Application信息
o C TapAPIChangePasswordReq | 修改密码请求
o C TapAPICommodity | 品种编码结构
o C TapAPIContract | 合约编码结构
o C TapAPIExchangeInfo | 交易所信息
o C TapAPIQuoteCommodityInfo | 品种信息
o C TapAPIQuoteContractInfo | 行情合约信息
o C TapAPIQuoteLoginAuth | 登录认证信息
o C TapAPIQuoteWhole | 行情全文
\ C TapAPIQuotLoginRspInfo | 登录反馈信息


TapQuoteAPI: ITapQuoteAPI类 参考

  • 类列表
  • 类索引
  • 类成员
Public 成员函数 | 所有成员列表
ITapQuoteAPI类 参考abstract

#include <TapQuoteAPI.h>

Public 成员函数

virtual TAPIINT32 TAP_CDECL | SetAPINotify (ITapQuoteAPINotify *apiNotify)=0
virtual TAPIINT32 TAP_CDECL | SetHostAddress (const TAPICHAR *IP, TAPIUINT16 port)=0
virtual TAPIINT32 TAP_CDECL | Login (const TapAPIQuoteLoginAuth *loginAuth)=0
virtual TAPIINT32 TAP_CDECL | Disconnect ()=0
virtual TAPIINT32 TAP_CDECL | QryCommodity (TAPIUINT32 *sessionID)=0
virtual TAPIINT32 TAP_CDECL | QryContract (TAPIUINT32 *sessionID, const TapAPICommodity *qryReq)=0
virtual TAPIINT32 TAP_CDECL | SubscribeQuote (TAPIUINT32 *sessionID, const TapAPIContract *contract)=0
virtual TAPIINT32 TAP_CDECL | UnSubscribeQuote (TAPIUINT32 *sessionID, const TapAPIContract *contract)=0
该类的文档由以下文件生成:
  • TapQuoteAPI.h


TapQuoteAPI: 成员列表

  • 类列表
  • 类索引
  • 类成员
ITapQuoteAPI 成员列表

成员的完整列表，这些成员属于 ITapQuoteAPI,包括所有继承而来的类成员

Disconnect()=0 | ITapQuoteAPI | pure virtual
Login(const TapAPIQuoteLoginAuth *loginAuth)=0 | ITapQuoteAPI | pure virtual
QryCommodity(TAPIUINT32 *sessionID)=0 | ITapQuoteAPI | pure virtual
QryContract(TAPIUINT32 *sessionID, const TapAPICommodity *qryReq)=0 | ITapQuoteAPI | pure virtual
SetAPINotify(ITapQuoteAPINotify *apiNotify)=0 | ITapQuoteAPI | pure virtual
SetHostAddress(const TAPICHAR *IP, TAPIUINT16 port)=0 | ITapQuoteAPI | pure virtual
SubscribeQuote(TAPIUINT32 *sessionID, const TapAPIContract *contract)=0 | ITapQuoteAPI | pure virtual
UnSubscribeQuote(TAPIUINT32 *sessionID, const TapAPIContract *contract)=0 | ITapQuoteAPI | pure virtual


TapQuoteAPI: ITapQuoteAPINotify类 参考

  • 类列表
  • 类索引
  • 类成员
Public 成员函数 | 所有成员列表
ITapQuoteAPINotify类 参考abstract

#include <TapQuoteAPI.h>

Public 成员函数

virtual void TAP_CDECL | OnRspLogin (TAPIINT32 errorCode, const TapAPIQuotLoginRspInfo *info)=0
virtual void TAP_CDECL | OnAPIReady ()=0
virtual void TAP_CDECL | OnDisconnect (TAPIINT32 reasonCode)=0
virtual void TAP_CDECL | OnRspQryCommodity (TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteCommodityInfo *info)=0
virtual void TAP_CDECL | OnRspQryContract (TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteContractInfo *info)=0
virtual void TAP_CDECL | OnRspSubscribeQuote (TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteWhole *info)=0
virtual void TAP_CDECL | OnRspUnSubscribeQuote (TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIContract *info)=0
virtual void TAP_CDECL | OnRtnQuote (const TapAPIQuoteWhole *info)=0
该类的文档由以下文件生成:
  • TapQuoteAPI.h


TapQuoteAPI: 成员列表

  • 类列表
  • 类索引
  • 类成员
ITapQuoteAPINotify 成员列表

成员的完整列表，这些成员属于 ITapQuoteAPINotify,包括所有继承而来的类成员

OnAPIReady()=0 | ITapQuoteAPINotify | pure virtual
OnDisconnect(TAPIINT32 reasonCode)=0 | ITapQuoteAPINotify | pure virtual
OnRspLogin(TAPIINT32 errorCode, const TapAPIQuotLoginRspInfo *info)=0 | ITapQuoteAPINotify | pure virtual
OnRspQryCommodity(TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteCommodityInfo *info)=0 | ITapQuoteAPINotify | pure virtual
OnRspQryContract(TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteContractInfo *info)=0 | ITapQuoteAPINotify | pure virtual
OnRspSubscribeQuote(TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIQuoteWhole *info)=0 | ITapQuoteAPINotify | pure virtual
OnRspUnSubscribeQuote(TAPIUINT32 sessionID, TAPIINT32 errorCode, TAPIYNFLAG isLast, const TapAPIContract *info)=0 | ITapQuoteAPINotify | pure virtual
OnRtnQuote(const TapAPIQuoteWhole *info)=0 | ITapQuoteAPINotify | pure virtual


TapQuoteAPI: 类索引

  • 类列表
  • 类索引
  • 类成员
类索引
I | T
I
T
TapAPICommodity TapAPIQuoteContractInfo
TapAPIContract TapAPIQuoteLoginAuth
ITapQuoteAPI TapAPIApplicationInfo TapAPIExchangeInfo TapAPIQuoteWhole
ITapQuoteAPINotify TapAPIChangePasswordReq TapAPIQuoteCommodityInfo TapAPIQuotLoginRspInfo
I | T


TapQuoteAPI: MarkDownTables 目录参考

  • code
  • ext
  • MarkDownTables
MarkDownTables 目录参考

目录

目录 TapQuoteAPI


TapQuoteAPI: Quote 目录参考

  • code
  • ext
  • PagesAndGroups
  • Quote
Quote 目录参考

文件

文件 | doxygen_Q_GroupsDefine.h [代码]
文件 | doxygen_Q_PagesDefine.h [代码]


TapQuoteAPI: PagesAndGroups 目录参考

  • code
  • ext
  • PagesAndGroups
PagesAndGroups 目录参考

目录

目录 Quote


TapQuoteAPI: code 目录参考

  • code
code 目录参考

目录

目录 | ext
目录 | include


TapQuoteAPI: ext 目录参考

  • code
  • ext
ext 目录参考

目录

目录 | MarkDownTables
目录 | PagesAndGroups


TapQuoteAPI: TapQuoteAPI 目录参考

  • code
  • ext
  • MarkDownTables
  • TapQuoteAPI
TapQuoteAPI 目录参考

文件

文件 | MDDataTypeTable.h [代码]
文件 | MDErrorCodeTable.h [代码]


TapQuoteAPI: include 目录参考

  • code
  • include
include 目录参考

文件

文件 | TapAPICommDef.h [代码]
文件 | TapAPIError.h [代码]
文件 | TapQuoteAPI.h [代码]
文件 | TapQuoteAPIDataType.h [代码]


TapQuoteAPI: doxygen_Q_GroupsDefine.h 文件参考

  • 文件列表
  • 文件成员
  • code
  • ext
  • PagesAndGroups
  • Quote
doxygen_Q_GroupsDefine.h 文件参考

浏览源代码.

生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: doxygen_Q_GroupsDefine.h 源文件

  • 文件列表
  • 文件成员
  • code
  • ext
  • PagesAndGroups
  • Quote
doxygen_Q_GroupsDefine.h
浏览该文件的文档.
1 /** @defgroup G_Q_API 1.接口的创建和销毁
2 *
3 *
4 */
5
6 /** @defgroup G_Q_LogConfig 2.日志设置
7 *
8 *
9 */
10
11 /** @defgroup G_Q_Login 3.使用API登录服务器
12 *
13 *
14 */
15
16 /** @defgroup G_Q_Disconnect 4.断开连接
17 *
18 *
19 */
20
21 /** @defgroup G_Q_Commodity 5.获取品种信息
22 *
23 *
24 */
25
26 /** @defgroup G_Q_Contract 6.获取合约信息
27 *
28 *
29 */
30
31 /** @defgroup G_Q_Quote 7.行情信息的订阅与退订
32 *
33 *
34 */
35
36
37
38
生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: doxygen_Q_PagesDefine.h 文件参考

  • 文件列表
  • 文件成员
  • code
  • ext
  • PagesAndGroups
  • Quote
doxygen_Q_PagesDefine.h 文件参考

浏览源代码.

生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: doxygen_Q_PagesDefine.h 源文件

  • 文件列表
  • 文件成员
  • code
  • ext
  • PagesAndGroups
  • Quote
doxygen_Q_PagesDefine.h
浏览该文件的文档.
1 /** @mainpage TapQuoteAPI介绍
2
3 @section sec1 TapQuoteAPI
4 <p>TapQuoteAPI 是易盛公司提供给开发者的启明星交易系统的行情接口。API基于C++实现，主要功能包括：合约的查询、行情的订阅与退订等。</p>
5 <p>API由调用接口类和回调接口类两部分组成，类名分别为ITapQuoteAPI和ITapQuoteAPINotify，ITapQuoteAPI包含了用户可以使用的函数，ITapQuoteAPINotify为提供给用户的回调接口，调用API提供的函数后相应结果通过回调的形参返回。回调类中所有函数均为虚函数，API内部没有默认的实现，用户需要且必须通过继承实现自己需要的功能。</p>
6 <p>注意：API的回调接口为纯虚函数，实现时需要继承实现所有接口。
7
8 */
9
10
11
12 /** @page P_Q_APIInfo 函数接口说明
13
14 - @ref G_Q_API
15 - @ref G_Q_LogConfig
16 - @ref G_Q_Login
17 - @ref G_Q_Disconnect
18 - @ref G_Q_Commodity
19 - @ref G_Q_Contract
20 - @ref G_Q_Quote
21 */
生成于 2016年 二月 3日 星期三 11:30:02 , 为 TapQuoteAPI使用 doxygen 1.8.6


TapQuoteAPI: 文件列表

  • 文件列表
  • 文件成员
文件列表
这里列出了所有文件，并附带简要说明:
o * doxygen_Q_GroupsDefine.h
o * doxygen_Q_PagesDefine.h
o * MDDataTypeTable.h
o * MDErrorCodeTable.h
o * TapAPICommDef.h
o * TapAPIError.h
o * TapQuoteAPI.h
\ * TapQuoteAPIDataType.h


TapQuoteAPI: 类成员

  • 类列表
  • 类索引
  • 类成员
  • 全部
  • 函数
  • 变量
  • a
  • c
  • d
  • e
  • f
  • i
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u
这里列出了所有类成员，并附带类的详细说明:

- a -

  • AuthCode : TapAPIApplicationInfo

- c -

  • CallOrPutFlag1 : TapAPIContract
  • CallOrPutFlag2 : TapAPIContract
  • CmbDirect : TapAPIQuoteCommodityInfo
  • Commodity : TapAPIContract , TapAPIQuoteCommodityInfo
  • CommodityContractLen : TapAPIQuoteCommodityInfo
  • CommodityDenominator : TapAPIQuoteCommodityInfo
  • CommodityEngName : TapAPIQuoteCommodityInfo
  • CommodityName : TapAPIQuoteCommodityInfo
  • CommodityNo : TapAPICommodity
  • CommodityTickSize : TapAPIQuoteCommodityInfo
  • CommodityType : TapAPICommodity
  • Contract : TapAPIQuoteContractInfo , TapAPIQuoteWhole
  • ContractExpDate : TapAPIQuoteContractInfo
  • ContractName : TapAPIQuoteContractInfo
  • ContractNo1 : TapAPIContract
  • ContractNo2 : TapAPIContract
  • ContractSize : TapAPIQuoteCommodityInfo
  • ContractType : TapAPIQuoteContractInfo
  • CurrencyNo : TapAPIQuoteWhole

- d -

  • DateTimeStamp : TapAPIQuoteWhole
  • DDASerialNo : TapAPIQuoteLoginAuth
  • Disconnect() : ITapQuoteAPI

- e -

  • ExchangeName : TapAPIExchangeInfo
  • ExchangeNo : TapAPICommodity , TapAPIExchangeInfo

- f -

  • FirstNoticeDate : TapAPIQuoteContractInfo

- i -

  • InitTime : TapAPIQuotLoginRspInfo
  • ISDDA : TapAPIQuoteLoginAuth
  • IsDST : TapAPIQuoteCommodityInfo
  • ISModifyPassword : TapAPIQuoteLoginAuth

- k -

  • KeyOperationLogPath : TapAPIApplicationInfo

- l -

  • LastLoginIP : TapAPIQuotLoginRspInfo
  • LastLoginProt : TapAPIQuotLoginRspInfo
  • LastLoginTime : TapAPIQuotLoginRspInfo
  • LastLogoutTime : TapAPIQuotLoginRspInfo
  • LastSettleTime : TapAPIQuotLoginRspInfo
  • LastTradeDate : TapAPIQuoteContractInfo
  • Login() : ITapQuoteAPI

- n -

  • NewPassword : TapAPIChangePasswordReq , TapAPIQuoteLoginAuth

- o -

  • OldPassword : TapAPIChangePasswordReq
  • OnAPIReady() : ITapQuoteAPINotify
  • OnDisconnect() : ITapQuoteAPINotify
  • OnRspLogin() : ITapQuoteAPINotify
  • OnRspQryCommodity() : ITapQuoteAPINotify
  • OnRspQryContract() : ITapQuoteAPINotify
  • OnRspSubscribeQuote() : ITapQuoteAPINotify
  • OnRspUnSubscribeQuote() : ITapQuoteAPINotify
  • OnRtnQuote() : ITapQuoteAPINotify

- p -

  • Password : TapAPIQuoteLoginAuth

- q -

  • Q5DAvgQty : TapAPIQuoteWhole
  • QAskPrice : TapAPIQuoteWhole
  • QAskQty : TapAPIQuoteWhole
  • QAveragePrice : TapAPIQuoteWhole
  • QBidPrice : TapAPIQuoteWhole
  • QBidQty : TapAPIQuoteWhole
  • QChangeRate : TapAPIQuoteWhole
  • QChangeSpeed : TapAPIQuoteWhole
  • QChangeValue : TapAPIQuoteWhole
  • QClosingPrice : TapAPIQuoteWhole
  • QCurrDelta : TapAPIQuoteWhole
  • QHighPrice : TapAPIQuoteWhole
  • QHisHighPrice : TapAPIQuoteWhole
  • QHisLowPrice : TapAPIQuoteWhole
  • QImpliedAskPrice : TapAPIQuoteWhole
  • QImpliedAskQty : TapAPIQuoteWhole
  • QImpliedBidPrice : TapAPIQuoteWhole
  • QImpliedBidQty : TapAPIQuoteWhole
  • QInsideQty : TapAPIQuoteWhole
  • QLastPrice : TapAPIQuoteWhole
  • QLastQty : TapAPIQuoteWhole
  • QLimitDownPrice : TapAPIQuoteWhole
  • QLimitUpPrice : TapAPIQuoteWhole
  • QLowPrice : TapAPIQuoteWhole
  • QNegotiableValue : TapAPIQuoteWhole
  • QOpeningPrice : TapAPIQuoteWhole
  • QOutsideQty : TapAPIQuoteWhole
  • QPERatio : TapAPIQuoteWhole
  • QPositionQty : TapAPIQuoteWhole
  • QPositionTrend : TapAPIQuoteWhole
  • QPreClosingPrice : TapAPIQuoteWhole
  • QPreDelta : TapAPIQuoteWhole
  • QPrePositionQty : TapAPIQuoteWhole
  • QPreSettlePrice : TapAPIQuoteWhole
  • QryCommodity() : ITapQuoteAPI
  • QryContract() : ITapQuoteAPI
  • QSettlePrice : TapAPIQuoteWhole
  • QSwing : TapAPIQuoteWhole
  • QTotalAskQty : TapAPIQuoteWhole
  • QTotalBidQty : TapAPIQuoteWhole
  • QTotalQty : TapAPIQuoteWhole
  • QTotalTurnover : TapAPIQuoteWhole
  • QTotalValue : TapAPIQuoteWhole
  • QTurnoverRate : TapAPIQuoteWhole
  • QuoteTempPassword : TapAPIQuoteLoginAuth , TapAPIQuotLoginRspInfo
  • QuoteUnderlyingContract : TapAPIQuoteContractInfo

- r -

  • RelateCommodity1 : TapAPIQuoteCommodityInfo
  • RelateCommodity2 : TapAPIQuoteCommodityInfo
  • ReservedInfo : TapAPIQuotLoginRspInfo

- s -

  • SetAPINotify() : ITapQuoteAPI
  • SetHostAddress() : ITapQuoteAPI
  • StartTime : TapAPIQuotLoginRspInfo
  • StrikePrice1 : TapAPIContract
  • StrikePrice2 : TapAPIContract
  • SubscribeQuote() : ITapQuoteAPI

- t -

  • TradeDate : TapAPIQuotLoginRspInfo
  • TradingState : TapAPIQuoteWhole

- u -

  • UnSubscribeQuote() : ITapQuoteAPI
  • UserName : TapAPIQuotLoginRspInfo
  • UserNo : TapAPIQuoteLoginAuth , TapAPIQuotLoginRspInfo
  • UserType : TapAPIQuotLoginRspInfo


TapQuoteAPI: 类成员 - 函数

  • 类列表
  • 类索引
  • 类成员
  • 全部
  • 函数
  • 变量
  • Disconnect() : ITapQuoteAPI
  • Login() : ITapQuoteAPI
  • OnAPIReady() : ITapQuoteAPINotify
  • OnDisconnect() : ITapQuoteAPINotify
  • OnRspLogin() : ITapQuoteAPINotify
  • OnRspQryCommodity() : ITapQuoteAPINotify
  • OnRspQryContract() : ITapQuoteAPINotify
  • OnRspSubscribeQuote() : ITapQuoteAPINotify
  • OnRspUnSubscribeQuote() : ITapQuoteAPINotify
  • OnRtnQuote() : ITapQuoteAPINotify
  • QryCommodity() : ITapQuoteAPI
  • QryContract() : ITapQuoteAPI
  • SetAPINotify() : ITapQuoteAPI
  • SetHostAddress() : ITapQuoteAPI
  • SubscribeQuote() : ITapQuoteAPI
  • UnSubscribeQuote() : ITapQuoteAPI


TapQuoteAPI: 类成员 - 变量

  • 类列表
  • 类索引
  • 类成员
  • 全部
  • 函数
  • 变量
  • a
  • c
  • d
  • e
  • f
  • i
  • k
  • l
  • n
  • o
  • p
  • q
  • r
  • s
  • t
  • u

- a -

  • AuthCode : TapAPIApplicationInfo

- c -

  • CallOrPutFlag1 : TapAPIContract
  • CallOrPutFlag2 : TapAPIContract
  • CmbDirect : TapAPIQuoteCommodityInfo
  • Commodity : TapAPIContract , TapAPIQuoteCommodityInfo
  • CommodityContractLen : TapAPIQuoteCommodityInfo
  • CommodityDenominator : TapAPIQuoteCommodityInfo
  • CommodityEngName : TapAPIQuoteCommodityInfo
  • CommodityName : TapAPIQuoteCommodityInfo
  • CommodityNo : TapAPICommodity
  • CommodityTickSize : TapAPIQuoteCommodityInfo
  • CommodityType : TapAPICommodity
  • Contract : TapAPIQuoteContractInfo , TapAPIQuoteWhole
  • ContractExpDate : TapAPIQuoteContractInfo
  • ContractName : TapAPIQuoteContractInfo
  • ContractNo1 : TapAPIContract
  • ContractNo2 : TapAPIContract
  • ContractSize : TapAPIQuoteCommodityInfo
  • ContractType : TapAPIQuoteContractInfo
  • CurrencyNo : TapAPIQuoteWhole

- d -

  • DateTimeStamp : TapAPIQuoteWhole
  • DDASerialNo : TapAPIQuoteLoginAuth

- e -

  • ExchangeName : TapAPIExchangeInfo
  • ExchangeNo : TapAPICommodity , TapAPIExchangeInfo

- f -

  • FirstNoticeDate : TapAPIQuoteContractInfo

- i -

  • InitTime : TapAPIQuotLoginRspInfo
  • ISDDA : TapAPIQuoteLoginAuth
  • IsDST : TapAPIQuoteCommodityInfo
  • ISModifyPassword : TapAPIQuoteLoginAuth

- k -

  • KeyOperationLogPath : TapAPIApplicationInfo

- l -

  • LastLoginIP : TapAPIQuotLoginRspInfo
  • LastLoginProt : TapAPIQuotLoginRspInfo
  • LastLoginTime : TapAPIQuotLoginRspInfo
  • LastLogoutTime : TapAPIQuotLoginRspInfo
  • LastSettleTime : TapAPIQuotLoginRspInfo
  • LastTradeDate : TapAPIQuoteContractInfo

- n -

  • NewPassword : TapAPIChangePasswordReq , TapAPIQuoteLoginAuth

- o -

  • OldPassword : TapAPIChangePasswordReq

- p -

  • Password : TapAPIQuoteLoginAuth

- q -

  • Q5DAvgQty : TapAPIQuoteWhole
  • QAskPrice : TapAPIQuoteWhole
  • QAskQty : TapAPIQuoteWhole
  • QAveragePrice : TapAPIQuoteWhole
  • QBidPrice : TapAPIQuoteWhole
  • QBidQty : TapAPIQuoteWhole
  • QChangeRate : TapAPIQuoteWhole
  • QChangeSpeed : TapAPIQuoteWhole
  • QChangeValue : TapAPIQuoteWhole
  • QClosingPrice : TapAPIQuoteWhole
  • QCurrDelta : TapAPIQuoteWhole
  • QHighPrice : TapAPIQuoteWhole
  • QHisHighPrice : TapAPIQuoteWhole
  • QHisLowPrice : TapAPIQuoteWhole
  • QImpliedAskPrice : TapAPIQuoteWhole
  • QImpliedAskQty : TapAPIQuoteWhole
  • QImpliedBidPrice : TapAPIQuoteWhole
  • QImpliedBidQty : TapAPIQuoteWhole
  • QInsideQty : TapAPIQuoteWhole
  • QLastPrice : TapAPIQuoteWhole
  • QLastQty : TapAPIQuoteWhole
  • QLimitDownPrice : TapAPIQuoteWhole
  • QLimitUpPrice : TapAPIQuoteWhole
  • QLowPrice : TapAPIQuoteWhole
  • QNegotiableValue : TapAPIQuoteWhole
  • QOpeningPrice : TapAPIQuoteWhole
  • QOutsideQty : TapAPIQuoteWhole
  • QPERatio : TapAPIQuoteWhole
  • QPositionQty : TapAPIQuoteWhole
  • QPositionTrend : TapAPIQuoteWhole
  • QPreClosingPrice : TapAPIQuoteWhole
  • QPreDelta : TapAPIQuoteWhole
  • QPrePositionQty : TapAPIQuoteWhole
  • QPreSettlePrice : TapAPIQuoteWhole
  • QSettlePrice : TapAPIQuoteWhole
  • QSwing : TapAPIQuoteWhole
  • QTotalAskQty : TapAPIQuoteWhole
  • QTotalBidQty : TapAPIQuoteWhole
  • QTotalQty : TapAPIQuoteWhole
  • QTotalTurnover : TapAPIQuoteWhole
  • QTotalValue : TapAPIQuoteWhole
  • QTurnoverRate : TapAPIQuoteWhole
  • QuoteTempPassword : TapAPIQuoteLoginAuth , TapAPIQuotLoginRspInfo
  • QuoteUnderlyingContract : TapAPIQuoteContractInfo

- r -

  • RelateCommodity1 : TapAPIQuoteCommodityInfo
  • RelateCommodity2 : TapAPIQuoteCommodityInfo
  • ReservedInfo : TapAPIQuotLoginRspInfo

- s -

  • StartTime : TapAPIQuotLoginRspInfo
  • StrikePrice1 : TapAPIContract
  • StrikePrice2 : TapAPIContract

- t -

  • TradeDate : TapAPIQuotLoginRspInfo
  • TradingState : TapAPIQuoteWhole

- u -

  • UserName : TapAPIQuotLoginRspInfo
  • UserNo : TapAPIQuoteLoginAuth , TapAPIQuotLoginRspInfo
  • UserType : TapAPIQuotLoginRspInfo


TapQuoteAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 宏定义
  • a
  • c
  • f
  • g
  • s
  • t
这里列出了所有文件成员,并附带其所属的文件:

- a -

  • APILOGLEVEL_DEBUG : TapAPICommDef.h
  • APILOGLEVEL_ERROR : TapAPICommDef.h
  • APILOGLEVEL_NONE : TapAPICommDef.h
  • APILOGLEVEL_WARNING : TapAPICommDef.h
  • APIYNFLAG_NO : TapAPICommDef.h
  • APIYNFLAG_YES : TapAPICommDef.h

- c -

  • CreateTapQuoteAPI() : TapQuoteAPI.h

- f -

  • FreeTapQuoteAPI() : TapQuoteAPI.h

- g -

  • GetTapQuoteAPIVersion() : TapQuoteAPI.h

- s -

  • SetTapQuoteAPIDataPath() : TapQuoteAPI.h
  • SetTapQuoteAPILogLevel() : TapQuoteAPI.h

- t -

  • TAP_CDECL : TapQuoteAPI.h
  • TAP_DLLEXPORT : TapQuoteAPI.h
  • TAPI_CALLPUT_FLAG_CALL : TapAPICommDef.h
  • TAPI_CALLPUT_FLAG_NONE : TapAPICommDef.h
  • TAPI_CALLPUT_FLAG_PUT : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_BER : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_BUL : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_CROSSFOREX : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_DIRECTFOREX : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_FUTURES : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_INDEX : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_INDIRECTFOREX : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_NONE : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_OPTION : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_PRT : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_SPOT : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_SPREAD_COMMODITY : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_SPREAD_MONTH : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_STD : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_STG : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_STOCK : TapAPICommDef.h
  • TAPIAUTHCODE : TapAPICommDef.h
  • TAPICallOrPutFlagType : TapAPICommDef.h
  • TAPICHAR : TapAPICommDef.h
  • TAPICommodityType : TapAPICommDef.h
  • TAPIDATE : TapAPICommDef.h
  • TAPIDATETIME : TapAPICommDef.h
  • TAPIDTSTAMP : TapAPICommDef.h
  • TAPIERROR_API_NotReady : TapAPIError.h
  • TAPIERROR_AuthCode_Expired : TapAPIError.h
  • TAPIERROR_AuthCode_Invalid : TapAPIError.h
  • TAPIERROR_AuthCode_TypeNotMatch : TapAPIError.h
  • TAPIERROR_CallOneTimeOnly : TapAPIError.h
  • TAPIERROR_ConnectFail : TapAPIError.h
  • TAPIERROR_CurTestNotOver : TapAPIError.h
  • TAPIERROR_DataPathAvaiable : TapAPIError.h
  • TAPIERROR_DISCONNECT_BUF_FULL : TapAPIError.h
  • TAPIERROR_DISCONNECT_CLOSE_INIT : TapAPIError.h
  • TAPIERROR_DISCONNECT_CLOSE_PASS : TapAPIError.h
  • TAPIERROR_DISCONNECT_CONNECT_TIMEOUT : TapAPIError.h
  • TAPIERROR_DISCONNECT_HAS_CONNECTED : TapAPIError.h
  • TAPIERROR_DISCONNECT_HAS_EXIT : TapAPIError.h
  • TAPIERROR_DISCONNECT_INIT_ERROR : TapAPIError.h
  • TAPIERROR_DISCONNECT_IOCP_ERROR : TapAPIError.h
  • TAPIERROR_DISCONNECT_PARSE_ERROR : TapAPIError.h
  • TAPIERROR_DISCONNECT_READ_ERROR : TapAPIError.h
  • TAPIERROR_DISCONNECT_TRY_LATER : TapAPIError.h
  • TAPIERROR_DISCONNECT_WRITE_ERROR : TapAPIError.h
  • TAPIERROR_HostUnavailable : TapAPIError.h
  • TAPIERROR_InnerError : TapAPIError.h
  • TAPIERROR_INPUTERROR_NULL : TapAPIError.h
  • TAPIERROR_INPUTERROR_TAPICallOrPutFlagType : TapAPIError.h
  • TAPIERROR_INPUTERROR_TAPICommodityType : TapAPIError.h
  • TAPIERROR_INPUTERROR_TAPILOGLEVEL : TapAPIError.h
  • TAPIERROR_INPUTERROR_TAPIYNFLAG : TapAPIError.h
  • TAPIERROR_InputValueError : TapAPIError.h
  • TAPIERROR_LastReqNotFinish : TapAPIError.h
  • TAPIERROR_LinkAuthFail : TapAPIError.h
  • TAPIERROR_LOGIN : TapAPIError.h
  • TAPIERROR_LOGIN_COUNT : TapAPIError.h
  • TAPIERROR_LOGIN_DDA : TapAPIError.h
  • TAPIERROR_LOGIN_LICENSE : TapAPIError.h
  • TAPIERROR_LOGIN_MODULE : TapAPIError.h
  • TAPIERROR_LOGIN_NOTIN_SERVERFLAGUSRES : TapAPIError.h
  • TAPIERROR_LOGIN_PASS : TapAPIError.h
  • TAPIERROR_LOGIN_RIGHT : TapAPIError.h
  • TAPIERROR_LOGIN_STATE : TapAPIError.h
  • TAPIERROR_LOGIN_USER : TapAPIError.h
  • TAPIERROR_NOFrontAvailable : TapAPIError.h
  • TAPIERROR_NotImplemented : TapAPIError.h
  • TAPIERROR_NotReadyTestNetwork : TapAPIError.h
  • TAPIERROR_RepeatLogin : TapAPIError.h
  • TAPIERROR_SendDataError : TapAPIError.h
  • TAPIERROR_SUBSCRIBEQUOTE_COMMODITY_NOT_EXIST : TapAPIError.h
  • TAPIERROR_SUBSCRIBEQUOTE_CONTRACT_MAY_NOT_EXIST : TapAPIError.h
  • TAPIERROR_SUBSCRIBEQUOTE_EXCHANGE_MAX : TapAPIError.h
  • TAPIERROR_SUBSCRIBEQUOTE_MAX : TapAPIError.h
  • TAPIERROR_SUBSCRIBEQUOTE_NO_EXCHANGE_RIGHT : TapAPIError.h
  • TAPIERROR_SUBSCRIBEQUOTE_NO_RIGHT : TapAPIError.h
  • TAPIERROR_SUCCEED : TapAPIError.h
  • TAPIERROR_TestIDError : TapAPIError.h
  • TAPIERROR_UDP_LISTEN_FAILED : TapAPIError.h
  • TAPIERROR_UDP_LISTENING : TapAPIError.h
  • TAPIINT32 : TapAPICommDef.h
  • TAPIINT64 : TapAPICommDef.h
  • TAPILOGLEVEL : TapAPICommDef.h
  • TAPIQDIFF : TapQuoteAPIDataType.h
  • TAPIQPRICE : TapQuoteAPIDataType.h
  • TAPIQVOLUME : TapQuoteAPIDataType.h
  • TAPIREAL64 : TapAPICommDef.h
  • TAPISTR_10 : TapAPICommDef.h
  • TAPISTR_100 : TapAPICommDef.h
  • TAPISTR_20 : TapAPICommDef.h
  • TAPISTR_2000 : TapAPICommDef.h
  • TAPISTR_30 : TapAPICommDef.h
  • TAPISTR_300 : TapAPICommDef.h
  • TAPISTR_40 : TapAPICommDef.h
  • TAPISTR_50 : TapAPICommDef.h
  • TAPISTR_500 : TapAPICommDef.h
  • TAPISTR_70 : TapAPICommDef.h
  • TAPITIME : TapAPICommDef.h
  • TAPIUINT16 : TapAPICommDef.h
  • TAPIUINT32 : TapAPICommDef.h
  • TAPIUINT64 : TapAPICommDef.h
  • TAPIUINT8 : TapAPICommDef.h
  • TAPIYNFLAG : TapAPICommDef.h


TapQuoteAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 宏定义
  • TAP_CDECL : TapQuoteAPI.h
  • TAP_DLLEXPORT : TapQuoteAPI.h


TapQuoteAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 宏定义
  • CreateTapQuoteAPI() : TapQuoteAPI.h
  • FreeTapQuoteAPI() : TapQuoteAPI.h
  • GetTapQuoteAPIVersion() : TapQuoteAPI.h
  • SetTapQuoteAPIDataPath() : TapQuoteAPI.h
  • SetTapQuoteAPILogLevel() : TapQuoteAPI.h


TapQuoteAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 宏定义
  • TAPIAUTHCODE : TapAPICommDef.h
  • TAPICallOrPutFlagType : TapAPICommDef.h
  • TAPICHAR : TapAPICommDef.h
  • TAPICommodityType : TapAPICommDef.h
  • TAPIDATE : TapAPICommDef.h
  • TAPIDATETIME : TapAPICommDef.h
  • TAPIDTSTAMP : TapAPICommDef.h
  • TAPIINT32 : TapAPICommDef.h
  • TAPIINT64 : TapAPICommDef.h
  • TAPILOGLEVEL : TapAPICommDef.h
  • TAPIQDIFF : TapQuoteAPIDataType.h
  • TAPIQPRICE : TapQuoteAPIDataType.h
  • TAPIQVOLUME : TapQuoteAPIDataType.h
  • TAPIREAL64 : TapAPICommDef.h
  • TAPISTR_10 : TapAPICommDef.h
  • TAPISTR_100 : TapAPICommDef.h
  • TAPISTR_20 : TapAPICommDef.h
  • TAPISTR_2000 : TapAPICommDef.h
  • TAPISTR_30 : TapAPICommDef.h
  • TAPISTR_300 : TapAPICommDef.h
  • TAPISTR_40 : TapAPICommDef.h
  • TAPISTR_50 : TapAPICommDef.h
  • TAPISTR_500 : TapAPICommDef.h
  • TAPISTR_70 : TapAPICommDef.h
  • TAPITIME : TapAPICommDef.h
  • TAPIUINT16 : TapAPICommDef.h
  • TAPIUINT32 : TapAPICommDef.h
  • TAPIUINT64 : TapAPICommDef.h
  • TAPIUINT8 : TapAPICommDef.h
  • TAPIYNFLAG : TapAPICommDef.h


TapQuoteAPI: 文件成员

  • 文件列表
  • 文件成员
  • 全部
  • 函数
  • 变量
  • 类型定义
  • 宏定义
  • a
  • t

- a -

  • APILOGLEVEL_DEBUG : TapAPICommDef.h
  • APILOGLEVEL_ERROR : TapAPICommDef.h
  • APILOGLEVEL_NONE : TapAPICommDef.h
  • APILOGLEVEL_WARNING : TapAPICommDef.h
  • APIYNFLAG_NO : TapAPICommDef.h
  • APIYNFLAG_YES : TapAPICommDef.h

- t -

  • TAPI_CALLPUT_FLAG_CALL : TapAPICommDef.h
  • TAPI_CALLPUT_FLAG_NONE : TapAPICommDef.h
  • TAPI_CALLPUT_FLAG_PUT : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_BER : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_BUL : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_CROSSFOREX : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_DIRECTFOREX : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_FUTURES : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_INDEX : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_INDIRECTFOREX : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_NONE : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_OPTION : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_PRT : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_SPOT : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_SPREAD_COMMODITY : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_SPREAD_MONTH : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_STD : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_STG : TapAPICommDef.h
  • TAPI_COMMODITY_TYPE_STOCK : TapAPICommDef.h
  • TAPIERROR_API_NotReady : TapAPIError.h
  • TAPIERROR_AuthCode_Expired : TapAPIError.h
  • TAPIERROR_AuthCode_Invalid : TapAPIError.h
  • TAPIERROR_AuthCode_TypeNotMatch : TapAPIError.h
  • TAPIERROR_CallOneTimeOnly : TapAPIError.h
  • TAPIERROR_ConnectFail : TapAPIError.h
  • TAPIERROR_CurTestNotOver : TapAPIError.h
  • TAPIERROR_DataPathAvaiable : TapAPIError.h
  • TAPIERROR_DISCONNECT_BUF_FULL : TapAPIError.h
  • TAPIERROR_DISCONNECT_CLOSE_INIT : TapAPIError.h
  • TAPIERROR_DISCONNECT_CLOSE_PASS : TapAPIError.h
  • TAPIERROR_DISCONNECT_CONNECT_TIMEOUT : TapAPIError.h
  • TAPIERROR_DISCONNECT_HAS_CONNECTED : TapAPIError.h
  • TAPIERROR_DISCONNECT_HAS_EXIT : TapAPIError.h
  • TAPIERROR_DISCONNECT_INIT_ERROR : TapAPIError.h
  • TAPIERROR_DISCONNECT_IOCP_ERROR : TapAPIError.h
  • TAPIERROR_DISCONNECT_PARSE_ERROR : TapAPIError.h
  • TAPIERROR_DISCONNECT_READ_ERROR : TapAPIError.h
  • TAPIERROR_DISCONNECT_TRY_LATER : TapAPIError.h
  • TAPIERROR_DISCONNECT_WRITE_ERROR : TapAPIError.h
  • TAPIERROR_HostUnavailable : TapAPIError.h
  • TAPIERROR_InnerError : TapAPIError.h
  • TAPIERROR_INPUTERROR_NULL : TapAPIError.h
  • TAPIERROR_INPUTERROR_TAPICallOrPutFlagType : TapAPIError.h
  • TAPIERROR_INPUTERROR_TAPICommodityType : TapAPIError.h
  • TAPIERROR_INPUTERROR_TAPILOGLEVEL : TapAPIError.h
  • TAPIERROR_INPUTERROR_TAPIYNFLAG : TapAPIError.h
  • TAPIERROR_InputValueError : TapAPIError.h
  • TAPIERROR_LastReqNotFinish : TapAPIError.h
  • TAPIERROR_LinkAuthFail : TapAPIError.h
  • TAPIERROR_LOGIN : TapAPIError.h
  • TAPIERROR_LOGIN_COUNT : TapAPIError.h
  • TAPIERROR_LOGIN_DDA : TapAPIError.h
  • TAPIERROR_LOGIN_LICENSE : TapAPIError.h
  • TAPIERROR_LOGIN_MODULE : TapAPIError.h
  • TAPIERROR_LOGIN_NOTIN_SERVERFLAGUSRES : TapAPIError.h
  • TAPIERROR_LOGIN_PASS : TapAPIError.h
  • TAPIERROR_LOGIN_RIGHT : TapAPIError.h
  • TAPIERROR_LOGIN_STATE : TapAPIError.h
  • TAPIERROR_LOGIN_USER : TapAPIError.h
  • TAPIERROR_NOFrontAvailable : TapAPIError.h
  • TAPIERROR_NotImplemented : TapAPIError.h
  • TAPIERROR_NotReadyTestNetwork : TapAPIError.h
  • TAPIERROR_RepeatLogin : TapAPIError.h
  • TAPIERROR_SendDataError : TapAPIError.h
  • TAPIERROR_SUBSCRIBEQUOTE_COMMODITY_NOT_EXIST : TapAPIError.h
  • TAPIERROR_SUBSCRIBEQUOTE_CONTRACT_MAY_NOT_EXIST : TapAPIError.h
  • TAPIERROR_SUBSCRIBEQUOTE_EXCHANGE_MAX : TapAPIError.h
  • TAPIERROR_SUBSCRIBEQUOTE_MAX : TapAPIError.h
  • TAPIERROR_SUBSCRIBEQUOTE_NO_EXCHANGE_RIGHT : TapAPIError.h
  • TAPIERROR_SUBSCRIBEQUOTE_NO_RIGHT : TapAPIError.h
  • TAPIERROR_SUCCEED : TapAPIError.h
  • TAPIERROR_TestIDError : TapAPIError.h
  • TAPIERROR_UDP_LISTEN_FAILED : TapAPIError.h
  • TAPIERROR_UDP_LISTENING : TapAPIError.h


TapQuoteAPI: 看涨看跌标示

类型定义 | 变量
看涨看跌标示

类型定义

typedef TAPICHAR TAPICallOrPutFlagType

变量

const TAPICallOrPutFlagType | TAPI_CALLPUT_FLAG_CALL = 'C'
const TAPICallOrPutFlagType | TAPI_CALLPUT_FLAG_PUT = 'P'
const TAPICallOrPutFlagType | TAPI_CALLPUT_FLAG_NONE = 'N'

详细描述

类型定义说明

typedef TAPICHAR TAPICallOrPutFlagType

看涨看跌标示

变量说明

const TAPICallOrPutFlagType TAPI_CALLPUT_FLAG_CALL = 'C'

买权

const TAPICallOrPutFlagType TAPI_CALLPUT_FLAG_NONE = 'N'

无

const TAPICallOrPutFlagType TAPI_CALLPUT_FLAG_PUT = 'P'

卖权


TapQuoteAPI: 基本字符串类型定义

类型定义
基本字符串类型定义

类型定义

typedef char | TAPISTR_10 [11]
typedef char | TAPISTR_20 [21]
typedef char | TAPISTR_30 [31]
typedef char | TAPISTR_40 [41]
typedef char | TAPISTR_50 [51]
typedef char | TAPISTR_70 [71]
typedef char | TAPISTR_100 [101]
typedef char | TAPISTR_300 [301]
typedef char | TAPISTR_500 [501]
typedef char | TAPISTR_2000 [2001]
typedef char | TAPIAUTHCODE [513]
typedef char | TAPICHAR

详细描述

类型定义说明

typedef char TAPIAUTHCODE[513]

Authorization Code.

typedef char TAPICHAR

单字符定义，可用于定义其他类型

typedef char TAPISTR_10[11]

长度为10的字符串

typedef char TAPISTR_100[101]

长度为100的字符串

typedef char TAPISTR_20[21]

长度为20的字符串

typedef char TAPISTR_2000[2001]

长度为2000的字符串

typedef char TAPISTR_30[31]

长度为30的字符串

typedef char TAPISTR_300[301]

长度为300的字符串

typedef char TAPISTR_40[41]

长度为40的字符串

typedef char TAPISTR_50[51]

长度为50的字符串

typedef char TAPISTR_500[501]

长度为500的字符串

typedef char TAPISTR_70[71]

长度为70的字符串


TapQuoteAPI: 品种类型

类型定义 | 变量
品种类型

类型定义

typedef TAPICHAR TAPICommodityType

变量

const TAPICommodityType | TAPI_COMMODITY_TYPE_NONE = 'N'
const TAPICommodityType | TAPI_COMMODITY_TYPE_SPOT = 'P'
const TAPICommodityType | TAPI_COMMODITY_TYPE_FUTURES = 'F'
const TAPICommodityType | TAPI_COMMODITY_TYPE_OPTION = 'O'
const TAPICommodityType | TAPI_COMMODITY_TYPE_SPREAD_MONTH = 'S'
const TAPICommodityType | TAPI_COMMODITY_TYPE_SPREAD_COMMODITY = 'M'
const TAPICommodityType | TAPI_COMMODITY_TYPE_BUL = 'U'
const TAPICommodityType | TAPI_COMMODITY_TYPE_BER = 'E'
const TAPICommodityType | TAPI_COMMODITY_TYPE_STD = 'D'
const TAPICommodityType | TAPI_COMMODITY_TYPE_STG = 'G'
const TAPICommodityType | TAPI_COMMODITY_TYPE_PRT = 'R'
const TAPICommodityType | TAPI_COMMODITY_TYPE_DIRECTFOREX = 'X'
const TAPICommodityType | TAPI_COMMODITY_TYPE_INDIRECTFOREX = 'I'
const TAPICommodityType | TAPI_COMMODITY_TYPE_CROSSFOREX = 'C'
const TAPICommodityType | TAPI_COMMODITY_TYPE_INDEX = 'Z'
const TAPICommodityType | TAPI_COMMODITY_TYPE_STOCK = 'T'

详细描述

类型定义说明

typedef TAPICHAR TAPICommodityType

品种类型

变量说明

const TAPICommodityType TAPI_COMMODITY_TYPE_BER = 'E'

看跌垂直套利

const TAPICommodityType TAPI_COMMODITY_TYPE_BUL = 'U'

看涨垂直套利

const TAPICommodityType TAPI_COMMODITY_TYPE_CROSSFOREX = 'C'

外汇――交叉汇率

const TAPICommodityType TAPI_COMMODITY_TYPE_DIRECTFOREX = 'X'

外汇――直接汇率

const TAPICommodityType TAPI_COMMODITY_TYPE_FUTURES = 'F'

期货

const TAPICommodityType TAPI_COMMODITY_TYPE_INDEX = 'Z'

指数

const TAPICommodityType TAPI_COMMODITY_TYPE_INDIRECTFOREX = 'I'

外汇――间接汇率

const TAPICommodityType TAPI_COMMODITY_TYPE_NONE = 'N'

无

const TAPICommodityType TAPI_COMMODITY_TYPE_OPTION = 'O'

期权

const TAPICommodityType TAPI_COMMODITY_TYPE_PRT = 'R'

备兑组合

const TAPICommodityType TAPI_COMMODITY_TYPE_SPOT = 'P'

现货

const TAPICommodityType TAPI_COMMODITY_TYPE_SPREAD_COMMODITY = 'M'

跨品种套利

const TAPICommodityType TAPI_COMMODITY_TYPE_SPREAD_MONTH = 'S'

跨期套利

const TAPICommodityType TAPI_COMMODITY_TYPE_STD = 'D'

跨式套利

const TAPICommodityType TAPI_COMMODITY_TYPE_STG = 'G'

宽跨式套利

const TAPICommodityType TAPI_COMMODITY_TYPE_STOCK = 'T'

股票


TapQuoteAPI: 日期时间类型定义

类型定义
日期时间类型定义

类型定义

typedef char | TAPIDTSTAMP [24]
typedef char | TAPIDATETIME [20]
typedef char | TAPIDATE [11]
typedef char | TAPITIME [9]

详细描述

类型定义说明

typedef char TAPIDATE[11]

日期类型(格式 yyyy-MM-dd)

typedef char TAPIDATETIME[20]

日期和时间类型(格式 yyyy-MM-dd hh:nn:ss)

typedef char TAPIDTSTAMP[24]

时间戳类型(格式 yyyy-MM-dd hh:nn:ss.xxx)

typedef char TAPITIME[9]

时间类型(格式 hh:nn:ss)


TapQuoteAPI: 日志级别

类型定义 | 变量
日志级别

类型定义

typedef TAPICHAR TAPILOGLEVEL

变量

const TAPILOGLEVEL | APILOGLEVEL_NONE ='N'
const TAPILOGLEVEL | APILOGLEVEL_ERROR ='E'
const TAPILOGLEVEL | APILOGLEVEL_WARNING ='W'
const TAPILOGLEVEL | APILOGLEVEL_DEBUG ='D'

详细描述

类型定义说明

typedef TAPICHAR TAPILOGLEVEL

日志级别

变量说明

const TAPILOGLEVEL APILOGLEVEL_DEBUG ='D'

Debug.

const TAPILOGLEVEL APILOGLEVEL_ERROR ='E'

Error.

const TAPILOGLEVEL APILOGLEVEL_NONE ='N'

无

const TAPILOGLEVEL APILOGLEVEL_WARNING ='W'

Warning.


TapQuoteAPI: 基本数值类型定义

类型定义
基本数值类型定义

类型定义

typedef int | TAPIINT32
typedef unsigned int | TAPIUINT32
typedef long long | TAPIINT64
typedef unsigned long long | TAPIUINT64
typedef unsigned short | TAPIUINT16
typedef unsigned char | TAPIUINT8
typedef double | TAPIREAL64

详细描述

类型定义说明

typedef int TAPIINT32

int 32

typedef long long TAPIINT64

int 64

typedef double TAPIREAL64

real 64

typedef unsigned short TAPIUINT16

unsigned 16

typedef unsigned int TAPIUINT32

unsigned 32

typedef unsigned long long TAPIUINT64

unsigned 64

typedef unsigned char TAPIUINT8

unsigned 8


TapQuoteAPI: 行情基本类型

类型定义
行情基本类型

类型定义

typedef TAPIREAL64 | TAPIQPRICE
typedef TAPIUINT64 | TAPIQVOLUME
typedef TAPIINT64 | TAPIQDIFF

详细描述

类型定义说明

typedef TAPIINT64 TAPIQDIFF

变化值

typedef TAPIREAL64 TAPIQPRICE

行情价格

typedef TAPIUINT64 TAPIQVOLUME

行情量


TapQuoteAPI: 是否标示

类型定义 | 变量
是否标示

类型定义

typedef TAPICHAR TAPIYNFLAG

变量

const TAPIYNFLAG | APIYNFLAG_YES ='Y'
const TAPIYNFLAG | APIYNFLAG_NO ='N'

详细描述

类型定义说明

typedef TAPICHAR TAPIYNFLAG

是否标示

变量说明

const TAPIYNFLAG APIYNFLAG_NO ='N'

否

const TAPIYNFLAG APIYNFLAG_YES ='Y'

是


TapQuoteAPI: 业务返回的错误代码定义

变量
业务返回的错误代码定义

变量

const int | TAPIERROR_LOGIN = 10001
const int | TAPIERROR_LOGIN_USER = 10002
const int | TAPIERROR_LOGIN_DDA = 10003
const int | TAPIERROR_LOGIN_LICENSE = 10004
const int | TAPIERROR_LOGIN_MODULE = 10005
const int | TAPIERROR_LOGIN_STATE = 10007
const int | TAPIERROR_LOGIN_PASS = 10008
const int | TAPIERROR_LOGIN_RIGHT = 10009
const int | TAPIERROR_LOGIN_COUNT = 10010
const int | TAPIERROR_LOGIN_NOTIN_SERVERFLAGUSRES = 10011
const int | TAPIERROR_SUBSCRIBEQUOTE_MAX = 72001
const int | TAPIERROR_SUBSCRIBEQUOTE_EXCHANGE_MAX = 72002
const int | TAPIERROR_SUBSCRIBEQUOTE_NO_RIGHT = 72101
const int | TAPIERROR_SUBSCRIBEQUOTE_NO_EXCHANGE_RIGHT = 72102
const int | TAPIERROR_SUBSCRIBEQUOTE_COMMODITY_NOT_EXIST = 72103
const int | TAPIERROR_SUBSCRIBEQUOTE_CONTRACT_MAY_NOT_EXIST = 72104

详细描述

变量说明

const int TAPIERROR_LOGIN = 10001

登录过程执行错误

const int TAPIERROR_LOGIN_COUNT = 10010

登录数量超限

const int TAPIERROR_LOGIN_DDA = 10003

需要进行动态认证

const int TAPIERROR_LOGIN_LICENSE = 10004

登录用户未授权

const int TAPIERROR_LOGIN_MODULE = 10005

登录模块不正确

const int TAPIERROR_LOGIN_NOTIN_SERVERFLAGUSRES = 10011

登录用户不在服务器标识下可登录用户列表中

const int TAPIERROR_LOGIN_PASS = 10008

登录密码不正确

const int TAPIERROR_LOGIN_RIGHT = 10009

没有该模块登录权限

const int TAPIERROR_LOGIN_STATE = 10007

登录状态禁止登陆

const int TAPIERROR_LOGIN_USER = 10002

登录用户不存在

const int TAPIERROR_SUBSCRIBEQUOTE_COMMODITY_NOT_EXIST = 72103

品种不存在

const int TAPIERROR_SUBSCRIBEQUOTE_CONTRACT_MAY_NOT_EXIST = 72104

合约可能不存在

const int TAPIERROR_SUBSCRIBEQUOTE_EXCHANGE_MAX = 72002

超过该交易所行情最大订阅数

const int TAPIERROR_SUBSCRIBEQUOTE_MAX = 72001

超过行情最大总订阅数

const int TAPIERROR_SUBSCRIBEQUOTE_NO_EXCHANGE_RIGHT = 72102

没有该交易所下行情的订阅权限

const int TAPIERROR_SUBSCRIBEQUOTE_NO_RIGHT = 72101

没有该行情的订阅权限


TapQuoteAPI: 网络断开错误代码定义

变量
网络断开错误代码定义

变量

const int | TAPIERROR_DISCONNECT_CLOSE_INIT = 1
const int | TAPIERROR_DISCONNECT_CLOSE_PASS = 2
const int | TAPIERROR_DISCONNECT_READ_ERROR = 3
const int | TAPIERROR_DISCONNECT_WRITE_ERROR = 4
const int | TAPIERROR_DISCONNECT_BUF_FULL = 5
const int | TAPIERROR_DISCONNECT_IOCP_ERROR = 6
const int | TAPIERROR_DISCONNECT_PARSE_ERROR = 7
const int | TAPIERROR_DISCONNECT_CONNECT_TIMEOUT = 8
const int | TAPIERROR_DISCONNECT_INIT_ERROR = 9
const int | TAPIERROR_DISCONNECT_HAS_CONNECTED = 10
const int | TAPIERROR_DISCONNECT_HAS_EXIT = 11
const int | TAPIERROR_DISCONNECT_TRY_LATER = 12

详细描述

变量说明

const int TAPIERROR_DISCONNECT_BUF_FULL = 5

缓冲区满

const int TAPIERROR_DISCONNECT_CLOSE_INIT = 1

主动断开

const int TAPIERROR_DISCONNECT_CLOSE_PASS = 2

被动断开

const int TAPIERROR_DISCONNECT_CONNECT_TIMEOUT = 8

连接超时

const int TAPIERROR_DISCONNECT_HAS_CONNECTED = 10

已经连接

const int TAPIERROR_DISCONNECT_HAS_EXIT = 11

工作线程已结束

const int TAPIERROR_DISCONNECT_INIT_ERROR = 9

初始化失败

const int TAPIERROR_DISCONNECT_IOCP_ERROR = 6

异步操作错误

const int TAPIERROR_DISCONNECT_PARSE_ERROR = 7

解析数据错误

const int TAPIERROR_DISCONNECT_READ_ERROR = 3

读错误

const int TAPIERROR_DISCONNECT_TRY_LATER = 12

操作正在进行，请稍后重试

const int TAPIERROR_DISCONNECT_WRITE_ERROR = 4

写错误


TapQuoteAPI: TapAPI内部返回的错误码定义。

变量
TapAPI内部返回的错误码定义。

变量

const int | TAPIERROR_SUCCEED = 0
const int | TAPIERROR_ConnectFail = -1
const int | TAPIERROR_LinkAuthFail = -2
const int | TAPIERROR_HostUnavailable = -3
const int | TAPIERROR_SendDataError = -4
const int | TAPIERROR_TestIDError = -5
const int | TAPIERROR_NotReadyTestNetwork = -6
const int | TAPIERROR_CurTestNotOver = -7
const int | TAPIERROR_NOFrontAvailable = -8
const int | TAPIERROR_DataPathAvaiable = -9
const int | TAPIERROR_RepeatLogin = -10
const int | TAPIERROR_InnerError = -11
const int | TAPIERROR_LastReqNotFinish = -12
const int | TAPIERROR_InputValueError = -13
const int | TAPIERROR_AuthCode_Invalid = -14
const int | TAPIERROR_AuthCode_Expired = -15
const int | TAPIERROR_AuthCode_TypeNotMatch = -16
const int | TAPIERROR_API_NotReady = -17
const int | TAPIERROR_UDP_LISTEN_FAILED = -18
const int | TAPIERROR_UDP_LISTENING = -19
const int | TAPIERROR_NotImplemented = -20
const int | TAPIERROR_CallOneTimeOnly = -21

详细描述

变量说明

const int TAPIERROR_API_NotReady = -17

API还没有准备好

const int TAPIERROR_AuthCode_Expired = -15

授权码超期

const int TAPIERROR_AuthCode_Invalid = -14

授权码不合法

const int TAPIERROR_AuthCode_TypeNotMatch = -16

授权码类型不匹配

const int TAPIERROR_CallOneTimeOnly = -21

每次登陆只允许调用一次

const int TAPIERROR_ConnectFail = -1

连接服务失败

const int TAPIERROR_CurTestNotOver = -7

当前网络测试还没结束

const int TAPIERROR_DataPathAvaiable = -9

数据路径不可用

const int TAPIERROR_HostUnavailable = -3

主机地址不可用

const int TAPIERROR_InnerError = -11

内部错误

const int TAPIERROR_InputValueError = -13

输入参数非法

const int TAPIERROR_LastReqNotFinish = -12

上一次请求还没有结束

const int TAPIERROR_LinkAuthFail = -2

链路认证失败

const int TAPIERROR_NOFrontAvailable = -8

没用可用的接入前置

const int TAPIERROR_NotImplemented = -20

接口未实现

const int TAPIERROR_NotReadyTestNetwork = -6

没准备好测试网络

const int TAPIERROR_RepeatLogin = -10

重复登录

const int TAPIERROR_SendDataError = -4

发送数据错误

const int TAPIERROR_SUCCEED = 0

成功

const int TAPIERROR_TestIDError = -5

测试编号不合法

const int TAPIERROR_UDP_LISTEN_FAILED = -18

UDP端口监听失败

const int TAPIERROR_UDP_LISTENING = -19

UDP正在监听


TapQuoteAPI: 输入参数检查错误

变量
输入参数检查错误

变量

const int | TAPIERROR_INPUTERROR_NULL = -10000
const int | TAPIERROR_INPUTERROR_TAPIYNFLAG = -10001
const int | TAPIERROR_INPUTERROR_TAPILOGLEVEL = -10002
const int | TAPIERROR_INPUTERROR_TAPICommodityType = -10003
const int | TAPIERROR_INPUTERROR_TAPICallOrPutFlagType = -10004

详细描述

变量说明

const int TAPIERROR_INPUTERROR_NULL = -10000

输入数据为NULL

const int TAPIERROR_INPUTERROR_TAPICallOrPutFlagType = -10004

输入错误的:TAPICallOrPutFlagType

const int TAPIERROR_INPUTERROR_TAPICommodityType = -10003

输入错误的:TAPICommodityType

const int TAPIERROR_INPUTERROR_TAPILOGLEVEL = -10002

输入错误的:TAPILOGLEVEL

const int TAPIERROR_INPUTERROR_TAPIYNFLAG = -10001

输入错误的:TAPIYNFLAG


TapQuoteAPI: 行情结构体定义

类
行情结构体定义

类

struct | TapAPIQuoteLoginAuth
struct | TapAPIQuotLoginRspInfo
struct | TapAPIQuoteCommodityInfo
struct | TapAPIQuoteContractInfo
struct | TapAPIQuoteWhole

详细描述

类说明

struct TapAPIQuoteLoginAuth

登录认证信息

Public 属性

TAPISTR_20 UserNo
TAPIYNFLAG ISModifyPassword
TAPISTR_20 Password
TAPISTR_20 NewPassword
TAPISTR_20 QuoteTempPassword
TAPIYNFLAG ISDDA
TAPISTR_30 DDASerialNo

类成员变量说明

TAPISTR_30 TapAPIQuoteLoginAuth::DDASerialNo

动态认证码

TAPIYNFLAG TapAPIQuoteLoginAuth::ISDDA

是否需呀动态认证，'Y'表示是，'N'表示否

TAPIYNFLAG TapAPIQuoteLoginAuth::ISModifyPassword

是否修改密码，'Y'表示是，'N'表示否

TAPISTR_20 TapAPIQuoteLoginAuth::NewPassword

新密码，如果设置了修改密码则需要填写此字段

TAPISTR_20 TapAPIQuoteLoginAuth::Password

用户密码

TAPISTR_20 TapAPIQuoteLoginAuth::QuoteTempPassword

行情临时密码

TAPISTR_20 TapAPIQuoteLoginAuth::UserNo

用户名

struct TapAPIQuotLoginRspInfo

登录反馈信息

Public 属性

TAPISTR_20 UserNo
TAPIINT32 UserType
TAPISTR_20 UserName
TAPISTR_20 QuoteTempPassword
TAPISTR_50 ReservedInfo
TAPISTR_40 LastLoginIP
TAPIUINT32 LastLoginProt
TAPIDATETIME LastLoginTime
TAPIDATETIME LastLogoutTime
TAPIDATE TradeDate
TAPIDATETIME LastSettleTime
TAPIDATETIME StartTime
TAPIDATETIME InitTime

类成员变量说明

TAPIDATETIME TapAPIQuotLoginRspInfo::InitTime

系统初始化时间

TAPISTR_40 TapAPIQuotLoginRspInfo::LastLoginIP

上次登录的地址

TAPIUINT32 TapAPIQuotLoginRspInfo::LastLoginProt

上次登录使用的端口

TAPIDATETIME TapAPIQuotLoginRspInfo::LastLoginTime

上次登录的时间

TAPIDATETIME TapAPIQuotLoginRspInfo::LastLogoutTime

上次退出的时间

TAPIDATETIME TapAPIQuotLoginRspInfo::LastSettleTime

上次结算时间

TAPISTR_20 TapAPIQuotLoginRspInfo::QuoteTempPassword

行情临时密码

TAPISTR_50 TapAPIQuotLoginRspInfo::ReservedInfo

用户自己设置的预留信息

TAPIDATETIME TapAPIQuotLoginRspInfo::StartTime

系统启动时间

TAPIDATE TapAPIQuotLoginRspInfo::TradeDate

当前交易日期

TAPISTR_20 TapAPIQuotLoginRspInfo::UserName

昵称，GBK编码格式

TAPISTR_20 TapAPIQuotLoginRspInfo::UserNo

用户名

TAPIINT32 TapAPIQuotLoginRspInfo::UserType

用户类型

struct TapAPIQuoteCommodityInfo

品种信息

Public 属性

TapAPICommodity Commodity
TAPISTR_20 CommodityName
TAPISTR_30 CommodityEngName
TAPIREAL64 ContractSize
TAPIREAL64 CommodityTickSize
TAPIINT32 CommodityDenominator
TAPICHAR CmbDirect
TAPIINT32 CommodityContractLen
TAPIYNFLAG IsDST
TapAPICommodity RelateCommodity1
TapAPICommodity RelateCommodity2

类成员变量说明

TAPICHAR TapAPIQuoteCommodityInfo::CmbDirect

组合方向

TapAPICommodity TapAPIQuoteCommodityInfo::Commodity

品种

TAPIINT32 TapAPIQuoteCommodityInfo::CommodityContractLen

品种合约年限

TAPIINT32 TapAPIQuoteCommodityInfo::CommodityDenominator

报价分母

TAPISTR_30 TapAPIQuoteCommodityInfo::CommodityEngName

品种英文名称

TAPISTR_20 TapAPIQuoteCommodityInfo::CommodityName

品种名称,GBK编码格式

TAPIREAL64 TapAPIQuoteCommodityInfo::CommodityTickSize

最小变动价位

TAPIREAL64 TapAPIQuoteCommodityInfo::ContractSize

每手乘数

TAPIYNFLAG TapAPIQuoteCommodityInfo::IsDST

是否夏令时,'Y'为是,'N'为否

TapAPICommodity TapAPIQuoteCommodityInfo::RelateCommodity1

关联品种1

TapAPICommodity TapAPIQuoteCommodityInfo::RelateCommodity2

关联品种2

struct TapAPIQuoteContractInfo

行情合约信息

Public 属性

TapAPIContract Contract
TAPICHAR ContractType
TAPISTR_10 QuoteUnderlyingContract
TAPISTR_70 ContractName
TAPIDATE ContractExpDate
TAPIDATE LastTradeDate
TAPIDATE FirstNoticeDate

类成员变量说明

TapAPIContract TapAPIQuoteContractInfo::Contract

合约

TAPIDATE TapAPIQuoteContractInfo::ContractExpDate

合约到期日

TAPISTR_70 TapAPIQuoteContractInfo::ContractName

合约名称

TAPICHAR TapAPIQuoteContractInfo::ContractType

合约类型,'1'表示交易行情合约,'2'表示行情合约

TAPIDATE TapAPIQuoteContractInfo::FirstNoticeDate

首次通知日

TAPIDATE TapAPIQuoteContractInfo::LastTradeDate

最后交易日

TAPISTR_10 TapAPIQuoteContractInfo::QuoteUnderlyingContract

行情真实合约

struct TapAPIQuoteWhole

行情全文

Public 属性

TapAPIContract Contract
TAPISTR_10 CurrencyNo
TAPICHAR TradingState
TAPIDTSTAMP DateTimeStamp
TAPIQPRICE QPreClosingPrice
TAPIQPRICE QPreSettlePrice
TAPIQVOLUME QPrePositionQty
TAPIQPRICE QOpeningPrice
TAPIQPRICE QLastPrice
TAPIQPRICE QHighPrice
TAPIQPRICE QLowPrice
TAPIQPRICE QHisHighPrice
TAPIQPRICE QHisLowPrice
TAPIQPRICE QLimitUpPrice
TAPIQPRICE QLimitDownPrice
TAPIQVOLUME QTotalQty
TAPIQPRICE QTotalTurnover
TAPIQVOLUME QPositionQty
TAPIQPRICE QAveragePrice
TAPIQPRICE QClosingPrice
TAPIQPRICE QSettlePrice
TAPIQVOLUME QLastQty
TAPIQPRICE | QBidPrice [20]
TAPIQVOLUME | QBidQty [20]
TAPIQPRICE | QAskPrice [20]
TAPIQVOLUME | QAskQty [20]
TAPIQPRICE QImpliedBidPrice
TAPIQVOLUME QImpliedBidQty
TAPIQPRICE QImpliedAskPrice
TAPIQVOLUME QImpliedAskQty
TAPIQPRICE QPreDelta
TAPIQPRICE QCurrDelta
TAPIQVOLUME QInsideQty
TAPIQVOLUME QOutsideQty
TAPIQPRICE QTurnoverRate
TAPIQVOLUME Q5DAvgQty
TAPIQPRICE QPERatio
TAPIQPRICE QTotalValue
TAPIQPRICE QNegotiableValue
TAPIQDIFF QPositionTrend
TAPIQPRICE QChangeSpeed
TAPIQPRICE QChangeRate
TAPIQPRICE QChangeValue
TAPIQPRICE QSwing
TAPIQVOLUME QTotalBidQty
TAPIQVOLUME QTotalAskQty

类成员变量说明

TapAPIContract TapAPIQuoteWhole::Contract

合约

TAPISTR_10 TapAPIQuoteWhole::CurrencyNo

币种编号

TAPIDTSTAMP TapAPIQuoteWhole::DateTimeStamp

时间戳

TAPIQVOLUME TapAPIQuoteWhole::Q5DAvgQty

五日均量

TAPIQPRICE TapAPIQuoteWhole::QAskPrice[20]

卖价1-20档

TAPIQVOLUME TapAPIQuoteWhole::QAskQty[20]

卖量1-20档

TAPIQPRICE TapAPIQuoteWhole::QAveragePrice

均价

TAPIQPRICE TapAPIQuoteWhole::QBidPrice[20]

买价1-20档

TAPIQVOLUME TapAPIQuoteWhole::QBidQty[20]

买量1-20档

TAPIQPRICE TapAPIQuoteWhole::QChangeRate

涨幅

TAPIQPRICE TapAPIQuoteWhole::QChangeSpeed

涨速

TAPIQPRICE TapAPIQuoteWhole::QChangeValue

涨跌值

TAPIQPRICE TapAPIQuoteWhole::QClosingPrice

收盘价

TAPIQPRICE TapAPIQuoteWhole::QCurrDelta

今虚实度

TAPIQPRICE TapAPIQuoteWhole::QHighPrice

最高价

TAPIQPRICE TapAPIQuoteWhole::QHisHighPrice

历史最高价

TAPIQPRICE TapAPIQuoteWhole::QHisLowPrice

历史最低价

TAPIQPRICE TapAPIQuoteWhole::QImpliedAskPrice

隐含卖价

TAPIQVOLUME TapAPIQuoteWhole::QImpliedAskQty

隐含卖量

TAPIQPRICE TapAPIQuoteWhole::QImpliedBidPrice

隐含买价

TAPIQVOLUME TapAPIQuoteWhole::QImpliedBidQty

隐含买量

TAPIQVOLUME TapAPIQuoteWhole::QInsideQty

内盘量

TAPIQPRICE TapAPIQuoteWhole::QLastPrice

最新价

TAPIQVOLUME TapAPIQuoteWhole::QLastQty

最新成交量

TAPIQPRICE TapAPIQuoteWhole::QLimitDownPrice

跌停价

TAPIQPRICE TapAPIQuoteWhole::QLimitUpPrice

涨停价

TAPIQPRICE TapAPIQuoteWhole::QLowPrice

最低价

TAPIQPRICE TapAPIQuoteWhole::QNegotiableValue

流通市值

TAPIQPRICE TapAPIQuoteWhole::QOpeningPrice

开盘价

TAPIQVOLUME TapAPIQuoteWhole::QOutsideQty

外盘量

TAPIQPRICE TapAPIQuoteWhole::QPERatio

市盈率

TAPIQVOLUME TapAPIQuoteWhole::QPositionQty

持仓量

TAPIQDIFF TapAPIQuoteWhole::QPositionTrend

持仓走势

TAPIQPRICE TapAPIQuoteWhole::QPreClosingPrice

昨收盘价

TAPIQPRICE TapAPIQuoteWhole::QPreDelta

昨虚实度

TAPIQVOLUME TapAPIQuoteWhole::QPrePositionQty

昨持仓量

TAPIQPRICE TapAPIQuoteWhole::QPreSettlePrice

昨结算价

TAPIQPRICE TapAPIQuoteWhole::QSettlePrice

结算价

TAPIQPRICE TapAPIQuoteWhole::QSwing

振幅

TAPIQVOLUME TapAPIQuoteWhole::QTotalAskQty

委卖总量

TAPIQVOLUME TapAPIQuoteWhole::QTotalBidQty

委买总量

TAPIQVOLUME TapAPIQuoteWhole::QTotalQty

当日总成交量

TAPIQPRICE TapAPIQuoteWhole::QTotalTurnover

当日成交金额

TAPIQPRICE TapAPIQuoteWhole::QTotalValue

总市值

TAPIQPRICE TapAPIQuoteWhole::QTurnoverRate

换手率

TAPICHAR TapAPIQuoteWhole::TradingState

交易状态。1,集合竞价;2,集合竞价撮合;3,连续交易;4,交易暂停;5,闭市


TapQuoteAPI: 模块

模块
这里列出了所有模块:
o 1.接口的创建和销毁
o 2.日志设置
o 3.使用API登录服务器
o 4.断开连接
o 5.获取品种信息
o 6.获取合约信息
o 7.行情信息的订阅与退订
o TapAPI内部返回的错误码定义。
o 业务返回的错误代码定义
o 品种类型
o 基本字符串类型定义
o 基本数值类型定义
o 日志级别
o 日期时间类型定义
o 是否标示
o 看涨看跌标示
o 网络断开错误代码定义
o 行情基本类型
o 行情结构体定义
\ 输入参数检查错误


TapQuoteAPI: 其他页

其他页
这里列出了所有相关页面:


TapQuoteAPI: TapAPIApplicationInfo结构体 参考

  • 类列表
  • 类索引
  • 类成员
Public 属性 | 所有成员列表
TapAPIApplicationInfo结构体 参考

#include <TapAPICommDef.h>

Public 属性

TAPIAUTHCODE AuthCode
TAPISTR_300 KeyOperationLogPath

详细描述

Application信息

类成员变量说明

TAPIAUTHCODE TapAPIApplicationInfo::AuthCode

授权码

TAPISTR_300 TapAPIApplicationInfo::KeyOperationLogPath

关键操作日志路径

该结构体的文档由以下文件生成:
  • TapAPICommDef.h


TapQuoteAPI: 成员列表

  • 类列表
  • 类索引
  • 类成员
TapAPIApplicationInfo 成员列表

成员的完整列表，这些成员属于 TapAPIApplicationInfo,包括所有继承而来的类成员

AuthCode | TapAPIApplicationInfo
KeyOperationLogPath | TapAPIApplicationInfo


TapQuoteAPI: TapAPIChangePasswordReq结构体 参考

  • 类列表
  • 类索引
  • 类成员
Public 属性 | 所有成员列表
TapAPIChangePasswordReq结构体 参考

#include <TapAPICommDef.h>

Public 属性

TAPISTR_20 OldPassword
TAPISTR_20 NewPassword

详细描述

修改密码请求

类成员变量说明

TAPISTR_20 TapAPIChangePasswordReq::NewPassword

新密码

TAPISTR_20 TapAPIChangePasswordReq::OldPassword

旧密码

该结构体的文档由以下文件生成:
  • TapAPICommDef.h


TapQuoteAPI: 成员列表

  • 类列表
  • 类索引
  • 类成员
TapAPIChangePasswordReq 成员列表

成员的完整列表，这些成员属于 TapAPIChangePasswordReq,包括所有继承而来的类成员

NewPassword | TapAPIChangePasswordReq
OldPassword | TapAPIChangePasswordReq


TapQuoteAPI: TapAPICommodity结构体 参考

  • 类列表
  • 类索引
  • 类成员
Public 属性 | 所有成员列表
TapAPICommodity结构体 参考

#include <TapAPICommDef.h>

Public 属性

TAPISTR_10 ExchangeNo
TAPICommodityType CommodityType
TAPISTR_10 CommodityNo

详细描述

品种编码结构

类成员变量说明

TAPISTR_10 TapAPICommodity::CommodityNo

品种编号

TAPICommodityType TapAPICommodity::CommodityType

品种类型

TAPISTR_10 TapAPICommodity::ExchangeNo

交易所编码

该结构体的文档由以下文件生成:
  • TapAPICommDef.h


TapQuoteAPI: 成员列表

  • 类列表
  • 类索引
  • 类成员
TapAPICommodity 成员列表

成员的完整列表，这些成员属于 TapAPICommodity,包括所有继承而来的类成员

CommodityNo | TapAPICommodity
CommodityType | TapAPICommodity
ExchangeNo | TapAPICommodity


TapQuoteAPI: TapAPIContract结构体 参考

  • 类列表
  • 类索引
  • 类成员
Public 属性 | 所有成员列表
TapAPIContract结构体 参考

#include <TapAPICommDef.h>

Public 属性

TapAPICommodity Commodity
TAPISTR_10 ContractNo1
TAPISTR_10 StrikePrice1
TAPICallOrPutFlagType CallOrPutFlag1
TAPISTR_10 ContractNo2
TAPISTR_10 StrikePrice2
TAPICallOrPutFlagType CallOrPutFlag2

详细描述

合约编码结构

类成员变量说明

TAPICallOrPutFlagType TapAPIContract::CallOrPutFlag1

看涨看跌标示1

TAPICallOrPutFlagType TapAPIContract::CallOrPutFlag2

看涨看跌标示2

TapAPICommodity TapAPIContract::Commodity

品种

TAPISTR_10 TapAPIContract::ContractNo1

合约代码1

TAPISTR_10 TapAPIContract::ContractNo2

合约代码2

TAPISTR_10 TapAPIContract::StrikePrice1

执行价1

TAPISTR_10 TapAPIContract::StrikePrice2

执行价2

该结构体的文档由以下文件生成:
  • TapAPICommDef.h


TapQuoteAPI: 成员列表

  • 类列表
  • 类索引
  • 类成员
TapAPIContract 成员列表

成员的完整列表，这些成员属于 TapAPIContract,包括所有继承而来的类成员

CallOrPutFlag1 | TapAPIContract
CallOrPutFlag2 | TapAPIContract
Commodity | TapAPIContract
ContractNo1 | TapAPIContract
ContractNo2 | TapAPIContract
StrikePrice1 | TapAPIContract
StrikePrice2 | TapAPIContract


TapQuoteAPI: TapAPIExchangeInfo结构体 参考

  • 类列表
  • 类索引
  • 类成员
Public 属性 | 所有成员列表
TapAPIExchangeInfo结构体 参考

#include <TapAPICommDef.h>

Public 属性

TAPISTR_10 ExchangeNo
TAPISTR_20 ExchangeName

详细描述

交易所信息

类成员变量说明

TAPISTR_20 TapAPIExchangeInfo::ExchangeName

交易所名称

TAPISTR_10 TapAPIExchangeInfo::ExchangeNo

交易所编码

该结构体的文档由以下文件生成:
  • TapAPICommDef.h


TapQuoteAPI: 成员列表

  • 类列表
  • 类索引
  • 类成员
TapAPIExchangeInfo 成员列表

成员的完整列表，这些成员属于 TapAPIExchangeInfo,包括所有继承而来的类成员

ExchangeName | TapAPIExchangeInfo
ExchangeNo | TapAPIExchangeInfo