eintopf.info@v0.13.16/flake.nix (about)

     1  {
     2    description = "A basic flake with a shell";
     3    inputs.nixpkgs.url = "github:NixOS/nixpkgs/nixpkgs-unstable";
     4    inputs.flake-utils.url = "github:numtide/flake-utils";
     5  
     6    outputs = { nixpkgs, flake-utils, ... }:
     7      flake-utils.lib.eachDefaultSystem (system:
     8        let
     9          pkgs = nixpkgs.legacyPackages.${system};
    10        in
    11        {
    12          devShells.default = pkgs.mkShell {
    13            packages = with pkgs; [
    14              go_1_21
    15              gopls
    16              delve
    17              yarn
    18              nodejs
    19              nodePackages.prettier
    20            ];
    21          };
    22        });
    23  }